* Fix build problem with newer rake.
* Use RDoc newer than included in ruby18-base. * misc clean up. Bump PKGREVISION.
This commit is contained in:
parent
86031c2776
commit
71688e7c22
3 changed files with 22 additions and 6 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.12 2013/02/06 23:22:10 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2013/03/07 17:00:44 taca Exp $
|
||||
|
||||
DISTNAME= ruby-eet-0.1.4
|
||||
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME:S/ruby-//}
|
||||
PKGREVISION= 6
|
||||
PKGREVISION= 7
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://code-monkey.de/pub/ruby-eet/
|
||||
|
||||
|
@ -13,16 +13,16 @@ LICENSE= mit
|
|||
|
||||
RUBY_VERSION_SUPPORTED= 18
|
||||
|
||||
RUBY_RDOC_REQD= 2.0.0
|
||||
USE_RAKE= YES
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
.include "../../devel/eet/buildlink3.mk"
|
||||
.include "../../lang/ruby/modules.mk"
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${RAKE}
|
||||
|
||||
do-install:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${INSTALL_ENV} ${RAKE} install
|
||||
|
||||
.include "../../lang/ruby/modules.mk"
|
||||
.include "../../devel/eet/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2011/08/12 16:29:04 taca Exp $
|
||||
$NetBSD: distinfo,v 1.3 2013/03/07 17:00:44 taca Exp $
|
||||
|
||||
SHA1 (ruby-eet-0.1.4.tar.gz) = 16e1824179b019f48a554388aadf5168521cad51
|
||||
RMD160 (ruby-eet-0.1.4.tar.gz) = 10521754510e8f8bd00372031d663c0ebdae41c2
|
||||
Size (ruby-eet-0.1.4.tar.gz) = 19972 bytes
|
||||
SHA1 (patch-Rakefile) = 5991edede98deb936702f775ec38b9e3a7ca68eb
|
||||
SHA1 (patch-rake_extensiontask.rb) = 89ab3da8bcbf2e1ec5a8ca4f9047ec19698f4392
|
||||
|
|
15
devel/ruby-eet/patches/patch-Rakefile
Normal file
15
devel/ruby-eet/patches/patch-Rakefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-Rakefile,v 1.1 2013/03/07 17:00:44 taca Exp $
|
||||
|
||||
* Require modern task rule from rdoc.
|
||||
|
||||
--- Rakefile.orig 2007-03-23 11:32:09.000000000 +0000
|
||||
+++ Rakefile
|
||||
@@ -1,7 +1,7 @@
|
||||
require "rbconfig"
|
||||
require "rake/clean"
|
||||
require "rake/testtask"
|
||||
-require "rake/rdoctask"
|
||||
+require "rdoc/task"
|
||||
require "rake/packagetask"
|
||||
require "rake/contrib/compositepublisher"
|
||||
require "rake/contrib/sshpublisher"
|
Loading…
Reference in a new issue