Add -Wno-import to the Objective-C CFLAGS to avoid stumbling over -Werror

This commit is contained in:
rh 2003-04-01 08:07:47 +00:00
parent a60b46c1bc
commit 71861d963c
5 changed files with 65 additions and 1 deletions

View file

@ -1,4 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2002/09/29 09:05:25 rh Exp $
$NetBSD: distinfo,v 1.2 2003/04/01 08:07:47 rh Exp $
SHA1 (Preferences-1.2.0.tar.bz2) = eb6b727c4f9eac2fd55237b3a3dc95e00bf748e9
Size (Preferences-1.2.0.tar.bz2) = 52293 bytes
SHA1 (patch-aa) = 72234b83635b5adef5a55de7b3c3188245f87a0c
SHA1 (patch-ab) = b2e59ffd762d4e519aa1385a391ece62e92c8530
SHA1 (patch-ac) = 7916a627f395a3b141d7cb1b07d7fb72f4d98da6
SHA1 (patch-ad) = aee5e8ae6ba4546991a43c25e12b0bc8d9054139

View file

@ -0,0 +1,17 @@
$NetBSD: patch-aa,v 1.1 2003/04/01 08:07:47 rh Exp $
--- GNUmakefile.preamble.orig Tue Feb 12 14:35:17 2002
+++ GNUmakefile.preamble
@@ -2,10 +2,10 @@
ADDITIONAL_CPPFLAGS +=
# Additional flags to pass to the Objective-C compiler
-ADDITIONAL_OBJCFLAGS += -Wall -Werror
+ADDITIONAL_OBJCFLAGS += -Wall -Wno-import -Werror
# Additional flags to pass to the C compiler
-ADDITIONAL_CFLAGS += -Wall -Werror
+ADDITIONAL_CFLAGS += -Wall -Wno-import -Werror
# Additional include directories the compiler should search
ADDITIONAL_INCLUDE_DIRS +=

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ab,v 1.1 2003/04/01 08:07:47 rh Exp $
--- PrefsModule/GNUmakefile.preamble.orig Tue Feb 12 15:02:11 2002
+++ PrefsModule/GNUmakefile.preamble
@@ -2,10 +2,10 @@
ADDITIONAL_CPPFLAGS +=
# Additional flags to pass to the Objective-C compiler
-ADDITIONAL_OBJCFLAGS += -Wall -Werror
+ADDITIONAL_OBJCFLAGS += -Wall -Wno-import -Werror
# Additional flags to pass to the C compiler
-ADDITIONAL_CFLAGS += -Wall -Werror
+ADDITIONAL_CFLAGS += -Wall -Wno-import -Werror
# Additional include directories the compiler should search
ADDITIONAL_INCLUDE_DIRS +=

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1 2003/04/01 08:07:47 rh Exp $
--- Modules/PrefsApp/GNUmakefile.preamble.orig Tue Feb 12 14:50:13 2002
+++ Modules/PrefsApp/GNUmakefile.preamble
@@ -2,7 +2,7 @@
ADDITIONAL_CPPFLAGS +=
# Additional flags to pass to the Objective-C compiler
-ADDITIONAL_OBJCFLAGS += -Wall -Werror
+ADDITIONAL_OBJCFLAGS += -Wall -Wno-import -Werror
# Additional flags to pass to the C compiler
ADDITIONAL_CFLAGS +=

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1 2003/04/01 08:07:47 rh Exp $
--- Modules/Keyboard/GNUmakefile.preamble.orig Tue Feb 12 14:49:55 2002
+++ Modules/Keyboard/GNUmakefile.preamble
@@ -2,7 +2,7 @@
ADDITIONAL_CPPFLAGS +=
# Additional flags to pass to the Objective-C compiler
-ADDITIONAL_OBJCFLAGS += -Wall -Werror
+ADDITIONAL_OBJCFLAGS += -Wall -Wno-import -Werror
# Additional flags to pass to the C compiler
ADDITIONAL_CFLAGS +=