Remove bash3, use bash4 instead.

bash2 stays for a little while longer, for A/UX and AIX 4 (requested by
Tim Larson).
This commit is contained in:
wiz 2010-02-15 12:58:14 +00:00
parent 3ede2b9b4d
commit 71940bc594
8 changed files with 1 additions and 191 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.47 2009/07/26 21:30:28 rillig Exp $
# $NetBSD: Makefile,v 1.48 2010/02/15 12:58:14 wiz Exp $
#
COMMENT= Shells
@ -8,7 +8,6 @@ SUBDIR+= bash
SUBDIR+= bash-completion
SUBDIR+= bash2
SUBDIR+= bash2-doc
SUBDIR+= bash3
SUBDIR+= dash
SUBDIR+= eltclsh
SUBDIR+= es

View file

@ -1,12 +0,0 @@
Bash is an sh-compatible shell that incorporates useful features from
the Korn shell (ksh) and C shell (csh). It is intended to conform to
the IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools standard.
It offers functional improvements over sh for both programming and
interactive use; these include command line editing, unlimited size
command history, job control, shell functions and aliases, indexed
arrays of unlimited size, and integer arithmetic in any base from two
to sixty-four. In addition, most sh scripts can be run by Bash without
modification.
This package contains the outdated version 3 of bash.

View file

@ -1,84 +0,0 @@
# $NetBSD: Makefile,v 1.2 2009/05/20 00:58:27 wiz Exp $
DISTNAME= bash-3.2.48
PKGREVISION= 1
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU:=bash/} \
ftp://ftp.cwru.edu/pub/bash/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.gnu.org/software/bash/bash.html
COMMENT= The GNU Bourne Again Shell (version 3)
CONFLICTS= static-bash-[0-9]*
PKG_INSTALLATION_TYPES= overwrite pkgviews
PKG_DESTDIR_SUPPORT= user-destdir
USE_TOOLS+= makeinfo yacc
USE_PKGLOCALEDIR= yes
TEXINFO_REQD= 4.1
GNU_CONFIGURE= yes
MAKE_ENV+= INSTALL_SCRIPT=${INSTALL_SCRIPT:Q}
CONFIGURE_ARGS= LOCAL_LDFLAGS=${EXPORT_SYMBOLS_LDFLAGS:M*:Q}
CPPFLAGS+= -DDEFAULT_PATH_VALUE="\"/usr/bin:/bin:${LOCALBASE}/bin:/usr/local/bin\""
MAKE_JOBS_SAFE= no
TEST_TARGET= test
INFO_FILES= YES # PLIST
PKG_SHELL= bin/bash
INSTALLATION_DIRS= ${PKGMANDIR}/man1
# All features enabled by default.
CONFIGURE_ARGS+= --enable-readline
CONFIGURE_ARGS+= --enable-progcomp
CONFIGURE_ARGS+= --enable-process-substitution
CONFIGURE_ARGS+= --enable-job-control
CONFIGURE_ARGS+= --enable-history
CONFIGURE_ARGS+= --enable-help-builtin
CONFIGURE_ARGS+= --enable-extended-glob
CONFIGURE_ARGS+= --enable-dparen-arithmetic
CONFIGURE_ARGS+= --enable-directory-stack
CONFIGURE_ARGS+= --enable-debugger
CONFIGURE_ARGS+= --enable-cond-regexp
CONFIGURE_ARGS+= --enable-alias
CONFIGURE_ARGS+= --enable-brace-expansion
CONFIGURE_ARGS+= --enable-array-variables
.include "../../mk/bsd.prefs.mk"
PKG_OPTIONS_VAR= PKG_OPTIONS.bash
PKG_SUPPORTED_OPTIONS= static
.include "../../mk/bsd.options.mk"
##
## Static link
##
.if !empty(PKG_OPTIONS:Mstatic)
CONFIGURE_ARGS+= --enable-static-link
BUILDLINK_DEPMETHOD.gettext= build
BUILDLINK_DEPMETHOD.readline= build
.endif
# the code has problems with older versions of yacc
.if !empty(MACHINE_PLATFORM:MIRIX-5*)
USE_TOOLS+= bison
.endif
# Use "readline" package on Darwin to avoid link erros.
.if ${OPSYS} == "Darwin"
CONFIGURE_ARGS+= --with-installed-readline
USE_GNU_READLINE= yes
BUILDLINK_API_DEPENDS.readline+= readline>=4.3
.include "../../devel/readline/buildlink3.mk"
.endif
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/bash.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
${INSTALL_MAN} ${WRKSRC}/doc/bashbug.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,8 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2009/02/24 15:47:43 wiz Exp $
bin/bash
bin/bashbug
info/bash.info
man/man1/bash.1
man/man1/bashbug.1
share/locale/en@boldquot/LC_MESSAGES/bash.mo
share/locale/en@quot/LC_MESSAGES/bash.mo

View file

@ -1,8 +0,0 @@
$NetBSD: distinfo,v 1.1.1.1 2009/02/24 15:47:43 wiz Exp $
SHA1 (bash-3.2.48.tar.gz) = efaff12f5d58d81999830891b030842858a1e7e8
RMD160 (bash-3.2.48.tar.gz) = 41b7091859e64b049d131ed3e84909916a2e4a2f
Size (bash-3.2.48.tar.gz) = 2541712 bytes
SHA1 (patch-af) = 34833c0628a60b5200a9559581c617d878eb62a8
SHA1 (patch-ag) = 4da0a43f6b890482affff46b18eef4be67770e48
SHA1 (patch-ah) = 6f88b33d9b56fabd319fa23cd1ff41594a01045b

View file

@ -1,54 +0,0 @@
$NetBSD: patch-af,v 1.1.1.1 2009/02/24 15:47:43 wiz Exp $
--- builtins/printf.def.orig 2007-09-18 15:24:09.000000000 +0000
+++ builtins/printf.def
@@ -74,6 +74,11 @@ $END
# undef PRIdMAX
#endif
+#if defined (_AIX) && !defined (_AIX51)
+ /* AIX defines do not work. Undefine them. */
+# undef PRIdMAX
+# undef PRIuMAX
+#endif
#if !defined (PRIdMAX)
# if HAVE_LONG_LONG
# define PRIdMAX "lld"
@@ -81,6 +86,13 @@ $END
# define PRIdMAX "ld"
# endif
#endif
+#if !defined (PRIuMAX) && defined (_AIX)
+# if HAVE_LONG_LONG
+# define PRIuMAX "llu"
+# else
+# define PRIuMAX "lu"
+# endif
+#endif
#if !defined (errno)
extern int errno;
@@ -466,7 +478,11 @@ printf_builtin (list)
p = pp = getintmax ();
if (p != pp)
{
+#if defined (_AIX) && !defined (_AIX51)
+ f = mklong (start, PRIdMAX, sizeof (intmax_t) - 2);
+#else
f = mklong (start, PRIdMAX, sizeof (PRIdMAX) - 2);
+#endif
PF (f, pp);
}
else
@@ -493,7 +509,11 @@ printf_builtin (list)
p = pp = getuintmax ();
if (p != pp)
{
+#if defined (_AIX) && !defined (_AIX51)
+ f = mklong (start, PRIuMAX, sizeof (uintmax_t) - 2);
+#else
f = mklong (start, PRIdMAX, sizeof (PRIdMAX) - 2);
+#endif
PF (f, pp);
}
else

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ag,v 1.1.1.1 2009/02/24 15:47:43 wiz Exp $
--- builtins/psize.c.orig 2005-07-07 14:21:32.000000000 +0200
+++ builtins/psize.c
@@ -41,10 +41,6 @@
#include "../general.h"
#include "../sig.h"
-#ifndef errno
-extern int errno;
-#endif
-
int nw;
sighandler

View file

@ -1,8 +0,0 @@
$NetBSD: patch-ah,v 1.1.1.1 2009/02/24 15:47:43 wiz Exp $
--- po/LINGUAS.orig 2006-01-10 22:51:33.000000000 +0000
+++ po/LINGUAS
@@ -1,2 +1,2 @@
# Set of available languages.
-en@quot en@boldquot ru
+en@quot en@boldquot