Update to 2.6.2:

* Speed up size allocation of labels, progress bars and text cell renderers
  [Anders Carlsson]
* Add a --quiet option to gtk-update-icon-cache [Matthias]
* GtkFileChooser
 - Bug fixes [Federico Mena Quintero]
 - Don't overwrite the contents of the name entry when changing folders
   in save mode.  [Federico]
 - Don't return nonexisting folders in save mode [Jean Marie Favreau]
 - Fix a size allocation loop [Milosz Derezynski, Robert Ögren]
* GtkAboutDialog
 - Better HIG compliance [Jorn Baayen]
* GDK
 - Work with Xservers implementing old versions of the Render extension
   [Albert Chin]
 - Respect _NET_VIRTUAL_ROOTS [Carsten Haitzler]
* Win32
 - Bug fixes [Tor Lillqvist, Ivan Wong, David Neary, Daniel Atallah,
   Takuro Ashie]
 - Make keyboard input work in Indic languages [Tor]
 - Initialize extended input devices lazily  [Robert Ögren]
* Other bug fixes [Owen Taylor, Richard Hult, Phil Blundell,
  Jens Finke, Michael Natterer, Manish Singh, Kjartan Maraas,
  Priit Laes, Dennis Cranston, Remus Draica, Matthias,
  Jeff Franks, Elijah Newren, Damon Chaplin, Vincent Ladeuil,
  Carlos Garnacho Parro, Thomas Zajic, Crispin Flowerday,
  Tommi Komulainen, Søren Sandmann, Chris Lee, Mark McLoughlin]
* Documentation improvements [Murray Cumming, Matthias, Alex Graveley,
  Jeff Franks, Christian Rose, Masao Mutoh, Karel Kulhavy, Roger Light]
* New and improved translations (bg,ca,cs,cy,da,de,el,en_CA,es,et,hu,it,
  ja,ko,lt,nb,nl,nn,no,pl,pt,pt_BR,sk,sq,sv,zh_CN)
This commit is contained in:
jmmv 2005-02-04 21:40:33 +00:00
parent da24824e10
commit 71e2aeee74
4 changed files with 6 additions and 42 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.73 2005/01/12 11:20:20 jmmv Exp $
# $NetBSD: Makefile,v 1.74 2005/02/04 21:40:33 jmmv Exp $
#
DISTNAME= gtk+-2.6.1
DISTNAME= gtk+-2.6.2
PKGNAME= ${DISTNAME:S/gtk/gtk2/}
PKGREVISION= 1
CATEGORIES= x11
MASTER_SITES= ftp://ftp.gtk.org/pub/gtk/v2.6/ \
ftp://ftp.cs.umn.edu/pub/gimp/gtk/v2.6/ \

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.37 2005/01/09 17:30:47 jmmv Exp $
@comment $NetBSD: PLIST,v 1.38 2005/02/04 21:40:33 jmmv Exp $
bin/gdk-pixbuf-csource
bin/gdk-pixbuf-query-loaders
bin/gtk-demo
@ -303,7 +303,6 @@ share/doc/gdk-pixbuf/license.html
share/doc/gdk-pixbuf/right.png
share/doc/gdk-pixbuf/rn01.html
share/doc/gdk-pixbuf/rn02.html
share/doc/gdk-pixbuf/style.css
share/doc/gdk-pixbuf/up.png
share/doc/gdk/GdkDisplay.html
share/doc/gdk/GdkDisplayManager.html
@ -410,7 +409,6 @@ share/doc/gdk/sizing.png
share/doc/gdk/spider.png
share/doc/gdk/spraycan.png
share/doc/gdk/star.png
share/doc/gdk/style.css
share/doc/gdk/target.png
share/doc/gdk/tcross.png
share/doc/gdk/top_left_arrow.png

View file

@ -1,9 +1,8 @@
$NetBSD: distinfo,v 1.39 2005/01/18 12:06:37 jmmv Exp $
$NetBSD: distinfo,v 1.40 2005/02/04 21:40:33 jmmv Exp $
SHA1 (gtk+-2.6.1.tar.bz2) = a584abc1d43e68dc79ebfb9e5d09bd9aa1a77781
Size (gtk+-2.6.1.tar.bz2) = 11070668 bytes
SHA1 (gtk+-2.6.2.tar.bz2) = 5c7d5e1bd05cd934718c72de4a4bc148a7005634
Size (gtk+-2.6.2.tar.bz2) = 11206837 bytes
SHA1 (patch-aa) = ab8a71ffa3b44816bb6f53ced068f80132b67c09
SHA1 (patch-ab) = 764729f9ee7e8b66e7165c34da0863b033af9552
SHA1 (patch-ac) = 42dff743263b141029a814d7dec9fdc5637a3cff
SHA1 (patch-ad) = dad88a4ee8bdac6bd3ea32b16ce4e0a3d1b202ab
SHA1 (patch-ae) = 04dbb379cea2bc1ca2e26893abddd3679f8476b3

View file

@ -1,32 +0,0 @@
$NetBSD: patch-ab,v 1.10 2005/01/09 17:30:47 jmmv Exp $
--- gtk/gtkicontheme.c.orig 2005-01-03 15:44:33.000000000 +0100
+++ gtk/gtkicontheme.c
@@ -568,10 +568,7 @@ gtk_icon_theme_init (GtkIconTheme *icon_
xdg_data_dirs = g_get_system_data_dirs ();
for (i = 0; xdg_data_dirs[i]; i++) ;
- priv->search_path_len = i + 2;
-#ifdef G_OS_UNIX
- priv->search_path_len++;
-#endif
+ priv->search_path_len = i * 2 + 2;
priv->search_path = g_new (char *, priv->search_path_len);
@@ -579,12 +576,10 @@ gtk_icon_theme_init (GtkIconTheme *icon_
priv->search_path[i++] = g_build_filename (g_get_home_dir (), ".icons", NULL);
priv->search_path[i++] = g_build_filename (g_get_user_data_dir (), "icons", NULL);
- for (j = 0; xdg_data_dirs[j]; j++)
+ for (j = 0; xdg_data_dirs[j]; j++) {
priv->search_path[i++] = g_build_filename (xdg_data_dirs[j], "icons", NULL);
-
-#ifdef G_OS_UNIX
- priv->search_path[i++] = g_strdup ("/usr/share/pixmaps");
-#endif
+ priv->search_path[i++] = g_build_filename (xdg_data_dirs[j], "pixmaps", NULL);
+ }
priv->themes_valid = FALSE;
priv->themes = NULL;