Thou shalt not clobber other packages files.

This commit is contained in:
tron 1998-02-23 08:38:55 +00:00
parent 867178b8dc
commit 71fbaa7159
5 changed files with 61 additions and 24 deletions

View file

@ -3,7 +3,7 @@
# Date created: 26 August 1997
# Whom: Michael Elbel (me)
#
# $NetBSD: Makefile,v 1.14 1998/02/20 12:09:51 frueauf Exp $
# $NetBSD: Makefile,v 1.15 1998/02/23 08:38:55 tron Exp $
# FreeBSD Id: Makefile,v 1.1.1.1 1997/09/03 19:27:57 gj Exp
#
@ -49,10 +49,10 @@ CONFIGURE_ARGS+= ${ARCH}--`echo ${OPSYS}|tr [A-Z] [a-z]` --prefix=${PREFIX} \
--sitelispdir="${PREFIX}/lib/xemacs/site-lisp ${PREFIX}/share/xemacs/site-lisp" \
${WITH_MULE} ${WITH_DIALOGS}
MAKE_ENV+= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
MAKE_ENV+= INSTALL_MAN="${INSTALL_MAN}" INSTALL_SCRIPT="${INSTALL_SCRIPT}"
MAN1= ctags.1 etags.1 gnuattach.1 gnuclient.1 gnudoit.1 \
gnuserv.1 xemacs.1
MAN1= gnuattach.1 gnuclient.1 gnudoit.1 gnuserv.1 xemacs.1 \
xemacs-ctags.1 xemacs-etags.1
# Include local make config file here. It is essential to have this
# precede any override targets (those that override defaults in
@ -82,14 +82,14 @@ pre-configure:
@echo "To compile in the MULE features, set the environment variable USE_MULE"
pre-install:
${RM} -f ${WRKSRC}/etc/ctags.1.orig
sed "s,@.GZ@,${DCOMPRESSUFFIX}," ${PKGDIR}/PLIST \
> ${PLIST_SRC}
post-install:
.for file in b2m ctags etags gnuclient xemacs-20.3
.for file in xemacs-b2m xemacs-ctags xemacs-etags gnuclient xemacs-20.3
strip ${PREFIX}/bin/${file}
.endfor
${MV} ${PREFIX}/bin/send-pr ${PREFIX}/bin/xemacs-send-pr
.if defined(MANZ)
${.CURDIR}/work/xemacs-20.3/lib-src/gzip-el.sh ${PREFIX}/lib/xemacs-20.3/lisp
.endif

View file

@ -1,6 +1,6 @@
--- lib-src/Makefile.in.in.orig Fri Feb 13 18:39:45 1998
+++ lib-src/Makefile.in.in Fri Feb 13 18:40:20 1998
@@ -197,7 +198,7 @@
--- lib-src/Makefile.in.in.orig Sun Oct 12 03:39:30 1997
+++ lib-src/Makefile.in.in Sun Feb 22 23:32:28 1998
@@ -197,7 +197,7 @@
if test `(cd ${archlibdir} && $(pwd))` \
!= `(cd ${srcdir} && $(pwd))`; then \
for f in ${SCRIPTS}; do \
@ -9,11 +9,26 @@
done ; \
fi
@@ -210,7 +211,7 @@
(cd .. && $(INSTALL_PROGRAM) lib-src/$${file} ${bindir}/$${file}) ; \
@@ -207,10 +207,20 @@
install: ${archlibdir}
@echo; echo "Installing utilities for users to run."
for file in ${INSTALLABLES} ; do \
- (cd .. && $(INSTALL_PROGRAM) lib-src/$${file} ${bindir}/$${file}) ; \
+ if [ $${file} = etags ] || [ $${file} = ctags ] || [ $${file} = b2m ] ; \
+ then \
+ (cd .. && $(INSTALL_PROGRAM) lib-src/$${file} ${bindir}/xemacs-$${file}) ; \
+ else \
+ (cd .. && $(INSTALL_PROGRAM) lib-src/$${file} ${bindir}/$${file}) ; \
+ fi \
done
for file in ${INSTALLABLE_SCRIPTS} ; do \
- (cd .. && $(INSTALL_PROGRAM) ${srcdir}/$${file} ${bindir}/$${file}) ; \
+ (cd .. && $(INSTALL_SCRIPT) ${srcdir}/$${file} ${bindir}/$${file}) ; \
+ if [ $${file} = rcs-checkin ] || [ $${file} = send-pr ] ; \
+ then \
+ (cd .. && $(INSTALL_SCRIPT) ${srcdir}/$${file} ${bindir}/xemacs-$${file}) ; \
+ else \
+ (cd .. && $(INSTALL_SCRIPT) ${srcdir}/$${file} ${bindir}/$${file}) ; \
+ fi \
done
uninstall:

View file

@ -0,0 +1,17 @@
--- Makefile.in.orig Fri Nov 21 01:07:10 1997
+++ Makefile.in Sun Feb 22 23:22:43 1998
@@ -467,8 +467,12 @@
fi
cd ${srcdir}/etc && \
for page in xemacs etags ctags gnuserv gnuclient gnuattach gnudoit; do \
- ${INSTALL_DATA} ${srcdir}/etc/$${page}.1 ${mandir}/$${page}${manext} ; \
- chmod 0644 ${mandir}/$${page}${manext} ; \
+ if [ $${page} = etags ] || [ $${page} = ctags ] ; \
+ then \
+ ${INSTALL_MAN} ${srcdir}/etc/$${page}.1 ${mandir}/xemacs-$${page}${manext} ; \
+ else \
+ ${INSTALL_MAN} ${srcdir}/etc/$${page}.1 ${mandir}/$${page}${manext} ; \
+ fi \
done
@echo "If you would like to save approximately 15M of disk space, do"
@echo "make gzip-el"

View file

@ -0,0 +1,5 @@
--- etc/ctags.1.orig Wed Dec 18 23:42:17 1996
+++ etc/ctags.1 Sun Feb 22 23:20:23 1998
@@ -1 +1 @@
-.so man1/etags.1
+.so man1/xemacs-etags.1

View file

@ -1,24 +1,24 @@
@comment $NetBSD: PLIST,v 1.9 1998/02/14 22:21:01 frueauf Exp $
bin/b2m
bin/ctags
bin/etags
@comment $NetBSD: PLIST,v 1.10 1998/02/23 08:38:56 tron Exp $
bin/xemacs-b2m
bin/xemacs-ctags
bin/xemacs-etags
bin/install-sid
bin/gnuattach
bin/gnuclient
bin/gnudoit
bin/pstogif
bin/rcs-checkin
bin/xemacs-rcs-checkin
bin/xemacs-send-pr
bin/xemacs-20.3
@exec ln -s %D/%F %B/xemacs
@unexec rm %B/xemacs
man/man1/ctags.1.gz
man/man1/etags.1.gz
man/man1/gnuattach.1.gz
man/man1/gnuclient.1.gz
man/man1/gnudoit.1.gz
man/man1/gnuserv.1.gz
man/man1/xemacs.1.gz
man/man1/xemacs-ctags.1
man/man1/xemacs-etags.1
man/man1/gnuattach.1
man/man1/gnuclient.1
man/man1/gnudoit.1
man/man1/gnuserv.1
man/man1/xemacs.1
@exec mkdir -p %D/lib/xemacs/lock ; chmod 1777 %D/lib/xemacs/lock
@exec mkdir -p %D/lib/xemacs/site-lisp ; chmod 755 %D/lib/xemacs/site-lisp
@unexec rm -rf %D/lib/xemacs