Convert to use buildlink.mk files and mark as USE_BUILDLINK_ONLY. Refer to
esd-config as $ESD_CONFIG in configure script.
This commit is contained in:
parent
42945c7c53
commit
72270071f4
3 changed files with 34 additions and 10 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.9 2001/02/16 13:30:45 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.10 2001/06/19 16:00:05 jlam Exp $
|
||||
|
||||
DISTNAME= libmikmod-3.1.9
|
||||
CATEGORIES= audio
|
||||
|
@ -8,17 +8,32 @@ MAINTAINER= kuebart@mathematik.uni-ulm.de
|
|||
HOMEPAGE= http://mikmod.darkorb.net/
|
||||
COMMENT= MikMod Sound Library
|
||||
|
||||
DEPENDS+= esound-0.2.*:../../audio/esound
|
||||
|
||||
USE_GMAKE= # defined
|
||||
USE_GTEXINFO= # defined
|
||||
GNU_CONFIGURE= # defined
|
||||
USE_LIBTOOL= # defined
|
||||
|
||||
USE_BUILDLINK_ONLY= # defined
|
||||
USE_CONFIG_WRAPPER= # defined
|
||||
|
||||
CONFIGURE_ARGS+= --disable-threads
|
||||
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
|
||||
|
||||
pre-build:
|
||||
${RM} -f ${WRKSRC}/docs/mikmod.info*
|
||||
|
||||
# Fix config scripts by removing buildlink directory references.
|
||||
post-build:
|
||||
@cd ${WRKSRC}; \
|
||||
config_scripts="libmikmod-config"; \
|
||||
for file in $${config_scripts}; do \
|
||||
${MV} -f $${file} $${file}.fixme; \
|
||||
${SED} -e "s|-I${BUILDLINK_DIR}/|-I${LOCALBASE}/|g" \
|
||||
-e "s|-L${BUILDLINK_DIR}/|-L${LOCALBASE}/|g" \
|
||||
$${file}.fixme > $${file}; \
|
||||
${RM} -f $${file}.fixme; \
|
||||
${CHMOD} +x $${file}; \
|
||||
done
|
||||
|
||||
.include "../../audio/esound/buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/18 12:14:32 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/06/19 16:00:05 jlam Exp $
|
||||
|
||||
SHA1 (libmikmod-3.1.9.tar.gz) = 1ecc623770f6cf8131a5cc68522acb027db6680b
|
||||
Size (libmikmod-3.1.9.tar.gz) = 513042 bytes
|
||||
SHA1 (patch-aa) = bfff6a9a77238e159e039bfa7d3f590bce8c9c9c
|
||||
SHA1 (patch-ab) = afda9a7d29e70e42c037163ac5b2d2742c77daab
|
||||
SHA1 (patch-ac) = c95d59a291570643c0b62c728ed3753fe9edb472
|
||||
SHA1 (patch-ac) = 19d7896c66818def7957e6fdfed44d3535aabc4a
|
||||
SHA1 (patch-ad) = fc5ac261ccf7ccd42ce49a30956f862e37d58723
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-ac,v 1.3 2000/06/09 07:53:03 jlam Exp $
|
||||
$NetBSD: patch-ac,v 1.4 2001/06/19 16:00:06 jlam Exp $
|
||||
|
||||
--- configure.orig Mon Feb 14 15:20:17 2000
|
||||
+++ configure Fri Jun 9 03:41:08 2000
|
||||
+++ configure
|
||||
@@ -1862,6 +1862,7 @@
|
||||
fi
|
||||
|
||||
|
@ -10,11 +10,20 @@ $NetBSD: patch-ac,v 1.3 2000/06/09 07:53:03 jlam Exp $
|
|||
# Check if makeinfo support html output. If it doesn't, pretend it's missing
|
||||
# rather than failing rebuilding the documentation.
|
||||
echo $ac_n "checking if makeinfo supports html output""... $ac_c" 1>&6
|
||||
@@ -1881,6 +1882,7 @@
|
||||
if test $libmikmod_cv_makeinfo_html = no
|
||||
@@ -1882,6 +1883,7 @@
|
||||
then
|
||||
MAKEINFO="$missing_dir/missing makeinfo"
|
||||
+fi
|
||||
fi
|
||||
+fi
|
||||
|
||||
# ====================
|
||||
# Check for libraries.
|
||||
@@ -2447,7 +2449,7 @@
|
||||
if eval "test \"`echo '$''{'libmikmod_cv_esd_needs_alsa'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
else
|
||||
- if (esd-config --libs 2>&1 |grep asound >/dev/null) 2>/dev/null
|
||||
+ if ($ESD_CONFIG --libs 2>&1 |grep asound >/dev/null) 2>/dev/null
|
||||
then
|
||||
libmikmod_cv_esd_needs_alsa=yes
|
||||
else
|
||||
|
|
Loading…
Reference in a new issue