Update groonga to 4.0.8.
Release 4.0.8 - 2014/11/29 -------------------------- Improvements ^^^^^^^^^^^^ * [deb] Supported Ubuntu 12.04 again because Travis-CI runs on it. * [mruby] Supported pretty print - ``"pp"`` for debugging. And supported to show internal objects more descriptive format when inspecting it. * Supported full text search query without index if one column is specified for ``--match_columns`` even though sequential search is executed by ``--query`` and ``--match_columns`` combination. [groonga-dev,02902] [Reported by Atsushi Shinoda] * [experimental] :doc:`/reference/functions/in_values` supports auto sequential search mode. There is a case that sequential search is faster than index search when the number of narrowed down records is small enough in contrast to the number of expected records to narrow down by ``in_values`` with ``AND`` operation which use indexes. The value of ``GRN_IN_VALUES_TOO_MANY_INDEX_MATCH_RATIO`` is used as threshold whether Groonga execute sequential search or search with indexes in such a case. * [mruby] Supported to load relative path of script. * Supported test suite to write query optimizer test more easily with mruby enabled build. * Supported offline index construction for token filters. [GitHub#239] [Patch by Naoya Murakami] * [experimental] :doc:`/reference/functions/between` supports auto sequential search mode. Use the value of ``GRN_BETWEEN_TOO_MANY_INDEX_MATCH_RATIO`` as threshold. Basic concept is similar to ``GRN_IN_VALUES_TOO_MANY_INDEX_MATCH_RATIO``. * [experimental] Supported multiple drilldowns for :doc:``/reference/command/select`` command. The syntax is extended to support this feature. The new one is ``--drilldown[LABEL1].keys COLUMN1,COLUMN2`` for keys, ``--drilldown[LABEL1].output_columns _value.COLUMN1,_value.COLUMN2,_nsubrecs`` for output columns. In the previous versions, a client application must implement by oneself for drilldown by multiple keys. Use ``_key[N]`` for ``--drilldown[LABEL1].output_columns`` to show original value of key in records. * Supported to search ``'reference_column @ "query"'`` without index. * [experimental] Added :doc:`/reference/commands/range_filter` command. It is faster than select command to fetch specific range of records in most cases, because it doesn't returns the number of matched records. There are limitations which doesn't support drilldown and so on. Thus, ``range_filter`` is suitable for extracting first ``N`` records in specific range for ranking or something else. * [httpd] Supported ``groonga-httpd`` on windows. * Supported vector column for drilldown. * [deb] Changed ``groonga-httpd`` as default HTTP server package. ``groonga-server-http`` is deprecated. Note that :doc:`/reference/executables/groonga-server-http` functionality itself is still exists in Groonga. If you just want to use simple HTTP server in traditional way, specify proper arguments by command line for :doc:`/reference/executables/groonga`. * Added configuration file for Windows CI on AppVeyor. [groonga-dev,02970,02981] [Patch by Hiroshi Hatake] Fixes ^^^^^ * [doc] Fixed duplicated execution example path about :doc:`/reference/commands/table_create`. [GitHub groonga.org#14] [Reported by Masafumi Yokoyama] * Fixed a bug that nested indexed full text search against ``X._key`` returns empty results. * Fixed flags parameter which is strict in BSD ``mkostemp(3)``. [GitHub#240] [Patch by Jun Kuriyama] * Fixed a bug that select command reports invalid value type (table) as index column value type. It was fixed to ``UInt32``. Note that it affects only the value of response header. The search results is not changed at all. * Fixed a bug that compare operations such as ``<``, ``<=``, ``>``, ``>=``, ``!=`` with Time and String type returns invalid results. * Fixed a bug that prefix search can't be executed against single character such as ``"x*"``. [GitHub#242] [Patch by Naoya Murakami] * Fixed a memory leak on drilldown ``ShortText`` value with ``--filter``. * Fixed missing ``","`` for ``"DDL:set_token_filters"`` log. [Reported by Naoya Murakami] Thanks ^^^^^^ * Atsushi Shinoda * Masafumi Yokoyama * Naoya Murakami * Jun Kuriyama * Hiroshi Hatake
This commit is contained in:
parent
a839a984b1
commit
724d90271c
5 changed files with 65 additions and 25 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.47 2014/11/15 02:13:19 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.48 2014/12/03 08:47:11 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= groonga-4.0.7
|
||||
PKGREVISION= 1
|
||||
DISTNAME= groonga-4.0.8
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://packages.groonga.org/source/groonga/
|
||||
|
||||
|
@ -26,7 +25,7 @@ EXTRACT_USING= bsdtar
|
|||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASEDIR}
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
|
||||
CONFIGURE_ARGS+= --with-ruby19=${RUBY}
|
||||
CONFIGURE_ARGS+= --with-ruby=${RUBY}
|
||||
|
||||
PKGCONFIG_OVERRIDE+= groonga.pc.in
|
||||
|
||||
|
@ -38,6 +37,8 @@ INSTALL_MAKE_FLAGS+= sysconfdir=${PREFIX}/share/examples
|
|||
|
||||
CONF_FILES+= share/examples/${PKGBASE}/groonga.conf \
|
||||
${PKG_SYSCONFDIR}/groonga.conf
|
||||
CONF_FILES+= share/examples/groonga/synonyms.tsv \
|
||||
${PKG_SYSCONFDIR}/synonyms.tsv
|
||||
|
||||
OWN_DIRS+= ${VARBASE}/log/${PKGBASE}
|
||||
|
||||
|
|
|
@ -1,15 +1,20 @@
|
|||
@comment $NetBSD: PLIST,v 1.25 2014/11/04 11:40:20 obache Exp $
|
||||
@comment $NetBSD: PLIST,v 1.26 2014/12/03 08:47:11 obache Exp $
|
||||
bin/groonga
|
||||
bin/groonga-benchmark
|
||||
bin/groonga-suggest-create-dataset
|
||||
${PLIST.learner}bin/groonga-suggest-httpd
|
||||
${PLIST.learner}bin/groonga-suggest-learner
|
||||
include/groonga/groonga.h
|
||||
include/groonga/groonga/expr.h
|
||||
include/groonga/groonga/groonga.h
|
||||
include/groonga/groonga/ii.h
|
||||
include/groonga/groonga/nfkc.h
|
||||
include/groonga/groonga/normalizer.h
|
||||
include/groonga/groonga/plugin.h
|
||||
include/groonga/groonga/token.h
|
||||
include/groonga/groonga/token_filter.h
|
||||
include/groonga/groonga/tokenizer.h
|
||||
include/groonga/groonga/util.h
|
||||
lib/groonga/plugins/query_expanders/tsv.la
|
||||
lib/groonga/plugins/suggest/suggest.la
|
||||
lib/groonga/plugins/table/table.la
|
||||
|
@ -67,6 +72,7 @@ share/doc/groonga/en/html/_sources/reference/api/global_configurations.txt
|
|||
share/doc/groonga/en/html/_sources/reference/api/grn_cache.txt
|
||||
share/doc/groonga/en/html/_sources/reference/api/grn_column.txt
|
||||
share/doc/groonga/en/html/_sources/reference/api/grn_command_version.txt
|
||||
share/doc/groonga/en/html/_sources/reference/api/grn_content_type.txt
|
||||
share/doc/groonga/en/html/_sources/reference/api/grn_ctx.txt
|
||||
share/doc/groonga/en/html/_sources/reference/api/grn_db.txt
|
||||
share/doc/groonga/en/html/_sources/reference/api/grn_encoding.txt
|
||||
|
@ -111,6 +117,7 @@ share/doc/groonga/en/html/_sources/reference/commands/log_reopen.txt
|
|||
share/doc/groonga/en/html/_sources/reference/commands/normalize.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/normalizer_list.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/quit.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/range_filter.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/register.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/ruby_eval.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/ruby_load.txt
|
||||
|
@ -121,6 +128,7 @@ share/doc/groonga/en/html/_sources/reference/commands/suggest.txt
|
|||
share/doc/groonga/en/html/_sources/reference/commands/table_create.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/table_list.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/table_remove.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/table_tokenize.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/tokenize.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/tokenizer_list.txt
|
||||
share/doc/groonga/en/html/_sources/reference/commands/truncate.txt
|
||||
|
@ -142,6 +150,7 @@ share/doc/groonga/en/html/_sources/reference/functions/geo_in_rectangle.txt
|
|||
share/doc/groonga/en/html/_sources/reference/functions/highlight_full.txt
|
||||
share/doc/groonga/en/html/_sources/reference/functions/highlight_html.txt
|
||||
share/doc/groonga/en/html/_sources/reference/functions/html_untag.txt
|
||||
share/doc/groonga/en/html/_sources/reference/functions/in_values.txt
|
||||
share/doc/groonga/en/html/_sources/reference/functions/now.txt
|
||||
share/doc/groonga/en/html/_sources/reference/functions/query.txt
|
||||
share/doc/groonga/en/html/_sources/reference/functions/rand.txt
|
||||
|
@ -164,6 +173,7 @@ share/doc/groonga/en/html/_sources/reference/suggest/correction.txt
|
|||
share/doc/groonga/en/html/_sources/reference/suggest/introduction.txt
|
||||
share/doc/groonga/en/html/_sources/reference/suggest/suggestion.txt
|
||||
share/doc/groonga/en/html/_sources/reference/tables.txt
|
||||
share/doc/groonga/en/html/_sources/reference/token_filters.txt
|
||||
share/doc/groonga/en/html/_sources/reference/tokenizers.txt
|
||||
share/doc/groonga/en/html/_sources/reference/tuning.txt
|
||||
share/doc/groonga/en/html/_sources/reference/types.txt
|
||||
|
@ -205,6 +215,7 @@ share/doc/groonga/en/html/_static/file.png
|
|||
share/doc/groonga/en/html/_static/groonga.css
|
||||
share/doc/groonga/en/html/_static/header-background.png
|
||||
share/doc/groonga/en/html/_static/jp.png
|
||||
share/doc/groonga/en/html/_static/jquery-1.11.1.js
|
||||
share/doc/groonga/en/html/_static/jquery.js
|
||||
share/doc/groonga/en/html/_static/logo.png
|
||||
share/doc/groonga/en/html/_static/minus.png
|
||||
|
@ -212,6 +223,7 @@ share/doc/groonga/en/html/_static/navigation-bar.png
|
|||
share/doc/groonga/en/html/_static/plus.png
|
||||
share/doc/groonga/en/html/_static/pygments.css
|
||||
share/doc/groonga/en/html/_static/searchtools.js
|
||||
share/doc/groonga/en/html/_static/underscore-1.3.1.js
|
||||
share/doc/groonga/en/html/_static/underscore.js
|
||||
share/doc/groonga/en/html/_static/up-pressed.png
|
||||
share/doc/groonga/en/html/_static/up.png
|
||||
|
@ -263,6 +275,7 @@ share/doc/groonga/en/html/reference/api/global_configurations.html
|
|||
share/doc/groonga/en/html/reference/api/grn_cache.html
|
||||
share/doc/groonga/en/html/reference/api/grn_column.html
|
||||
share/doc/groonga/en/html/reference/api/grn_command_version.html
|
||||
share/doc/groonga/en/html/reference/api/grn_content_type.html
|
||||
share/doc/groonga/en/html/reference/api/grn_ctx.html
|
||||
share/doc/groonga/en/html/reference/api/grn_db.html
|
||||
share/doc/groonga/en/html/reference/api/grn_encoding.html
|
||||
|
@ -307,6 +320,7 @@ share/doc/groonga/en/html/reference/commands/log_reopen.html
|
|||
share/doc/groonga/en/html/reference/commands/normalize.html
|
||||
share/doc/groonga/en/html/reference/commands/normalizer_list.html
|
||||
share/doc/groonga/en/html/reference/commands/quit.html
|
||||
share/doc/groonga/en/html/reference/commands/range_filter.html
|
||||
share/doc/groonga/en/html/reference/commands/register.html
|
||||
share/doc/groonga/en/html/reference/commands/ruby_eval.html
|
||||
share/doc/groonga/en/html/reference/commands/ruby_load.html
|
||||
|
@ -317,6 +331,7 @@ share/doc/groonga/en/html/reference/commands/suggest.html
|
|||
share/doc/groonga/en/html/reference/commands/table_create.html
|
||||
share/doc/groonga/en/html/reference/commands/table_list.html
|
||||
share/doc/groonga/en/html/reference/commands/table_remove.html
|
||||
share/doc/groonga/en/html/reference/commands/table_tokenize.html
|
||||
share/doc/groonga/en/html/reference/commands/tokenize.html
|
||||
share/doc/groonga/en/html/reference/commands/tokenizer_list.html
|
||||
share/doc/groonga/en/html/reference/commands/truncate.html
|
||||
|
@ -338,6 +353,7 @@ share/doc/groonga/en/html/reference/functions/geo_in_rectangle.html
|
|||
share/doc/groonga/en/html/reference/functions/highlight_full.html
|
||||
share/doc/groonga/en/html/reference/functions/highlight_html.html
|
||||
share/doc/groonga/en/html/reference/functions/html_untag.html
|
||||
share/doc/groonga/en/html/reference/functions/in_values.html
|
||||
share/doc/groonga/en/html/reference/functions/now.html
|
||||
share/doc/groonga/en/html/reference/functions/query.html
|
||||
share/doc/groonga/en/html/reference/functions/rand.html
|
||||
|
@ -360,6 +376,7 @@ share/doc/groonga/en/html/reference/suggest/correction.html
|
|||
share/doc/groonga/en/html/reference/suggest/introduction.html
|
||||
share/doc/groonga/en/html/reference/suggest/suggestion.html
|
||||
share/doc/groonga/en/html/reference/tables.html
|
||||
share/doc/groonga/en/html/reference/token_filters.html
|
||||
share/doc/groonga/en/html/reference/tokenizers.html
|
||||
share/doc/groonga/en/html/reference/tuning.html
|
||||
share/doc/groonga/en/html/reference/types.html
|
||||
|
@ -436,6 +453,7 @@ share/doc/groonga/ja/html/_sources/reference/api/global_configurations.txt
|
|||
share/doc/groonga/ja/html/_sources/reference/api/grn_cache.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/api/grn_column.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/api/grn_command_version.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/api/grn_content_type.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/api/grn_ctx.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/api/grn_db.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/api/grn_encoding.txt
|
||||
|
@ -480,6 +498,7 @@ share/doc/groonga/ja/html/_sources/reference/commands/log_reopen.txt
|
|||
share/doc/groonga/ja/html/_sources/reference/commands/normalize.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/normalizer_list.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/quit.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/range_filter.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/register.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/ruby_eval.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/ruby_load.txt
|
||||
|
@ -490,6 +509,7 @@ share/doc/groonga/ja/html/_sources/reference/commands/suggest.txt
|
|||
share/doc/groonga/ja/html/_sources/reference/commands/table_create.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/table_list.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/table_remove.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/table_tokenize.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/tokenize.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/tokenizer_list.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/commands/truncate.txt
|
||||
|
@ -511,6 +531,7 @@ share/doc/groonga/ja/html/_sources/reference/functions/geo_in_rectangle.txt
|
|||
share/doc/groonga/ja/html/_sources/reference/functions/highlight_full.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/functions/highlight_html.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/functions/html_untag.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/functions/in_values.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/functions/now.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/functions/query.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/functions/rand.txt
|
||||
|
@ -533,6 +554,7 @@ share/doc/groonga/ja/html/_sources/reference/suggest/correction.txt
|
|||
share/doc/groonga/ja/html/_sources/reference/suggest/introduction.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/suggest/suggestion.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/tables.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/token_filters.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/tokenizers.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/tuning.txt
|
||||
share/doc/groonga/ja/html/_sources/reference/types.txt
|
||||
|
@ -574,6 +596,7 @@ share/doc/groonga/ja/html/_static/file.png
|
|||
share/doc/groonga/ja/html/_static/groonga.css
|
||||
share/doc/groonga/ja/html/_static/header-background.png
|
||||
share/doc/groonga/ja/html/_static/jp.png
|
||||
share/doc/groonga/ja/html/_static/jquery-1.11.1.js
|
||||
share/doc/groonga/ja/html/_static/jquery.js
|
||||
share/doc/groonga/ja/html/_static/logo.png
|
||||
share/doc/groonga/ja/html/_static/minus.png
|
||||
|
@ -581,6 +604,7 @@ share/doc/groonga/ja/html/_static/navigation-bar.png
|
|||
share/doc/groonga/ja/html/_static/plus.png
|
||||
share/doc/groonga/ja/html/_static/pygments.css
|
||||
share/doc/groonga/ja/html/_static/searchtools.js
|
||||
share/doc/groonga/ja/html/_static/underscore-1.3.1.js
|
||||
share/doc/groonga/ja/html/_static/underscore.js
|
||||
share/doc/groonga/ja/html/_static/up-pressed.png
|
||||
share/doc/groonga/ja/html/_static/up.png
|
||||
|
@ -632,6 +656,7 @@ share/doc/groonga/ja/html/reference/api/global_configurations.html
|
|||
share/doc/groonga/ja/html/reference/api/grn_cache.html
|
||||
share/doc/groonga/ja/html/reference/api/grn_column.html
|
||||
share/doc/groonga/ja/html/reference/api/grn_command_version.html
|
||||
share/doc/groonga/ja/html/reference/api/grn_content_type.html
|
||||
share/doc/groonga/ja/html/reference/api/grn_ctx.html
|
||||
share/doc/groonga/ja/html/reference/api/grn_db.html
|
||||
share/doc/groonga/ja/html/reference/api/grn_encoding.html
|
||||
|
@ -676,6 +701,7 @@ share/doc/groonga/ja/html/reference/commands/log_reopen.html
|
|||
share/doc/groonga/ja/html/reference/commands/normalize.html
|
||||
share/doc/groonga/ja/html/reference/commands/normalizer_list.html
|
||||
share/doc/groonga/ja/html/reference/commands/quit.html
|
||||
share/doc/groonga/ja/html/reference/commands/range_filter.html
|
||||
share/doc/groonga/ja/html/reference/commands/register.html
|
||||
share/doc/groonga/ja/html/reference/commands/ruby_eval.html
|
||||
share/doc/groonga/ja/html/reference/commands/ruby_load.html
|
||||
|
@ -686,6 +712,7 @@ share/doc/groonga/ja/html/reference/commands/suggest.html
|
|||
share/doc/groonga/ja/html/reference/commands/table_create.html
|
||||
share/doc/groonga/ja/html/reference/commands/table_list.html
|
||||
share/doc/groonga/ja/html/reference/commands/table_remove.html
|
||||
share/doc/groonga/ja/html/reference/commands/table_tokenize.html
|
||||
share/doc/groonga/ja/html/reference/commands/tokenize.html
|
||||
share/doc/groonga/ja/html/reference/commands/tokenizer_list.html
|
||||
share/doc/groonga/ja/html/reference/commands/truncate.html
|
||||
|
@ -707,6 +734,7 @@ share/doc/groonga/ja/html/reference/functions/geo_in_rectangle.html
|
|||
share/doc/groonga/ja/html/reference/functions/highlight_full.html
|
||||
share/doc/groonga/ja/html/reference/functions/highlight_html.html
|
||||
share/doc/groonga/ja/html/reference/functions/html_untag.html
|
||||
share/doc/groonga/ja/html/reference/functions/in_values.html
|
||||
share/doc/groonga/ja/html/reference/functions/now.html
|
||||
share/doc/groonga/ja/html/reference/functions/query.html
|
||||
share/doc/groonga/ja/html/reference/functions/rand.html
|
||||
|
@ -729,6 +757,7 @@ share/doc/groonga/ja/html/reference/suggest/correction.html
|
|||
share/doc/groonga/ja/html/reference/suggest/introduction.html
|
||||
share/doc/groonga/ja/html/reference/suggest/suggestion.html
|
||||
share/doc/groonga/ja/html/reference/tables.html
|
||||
share/doc/groonga/ja/html/reference/token_filters.html
|
||||
share/doc/groonga/ja/html/reference/tokenizers.html
|
||||
share/doc/groonga/ja/html/reference/tuning.html
|
||||
share/doc/groonga/ja/html/reference/types.html
|
||||
|
@ -801,8 +830,8 @@ share/groonga/examples/dictionary/html/css/smoothness/images/ui-icons_cd0a0a_256
|
|||
share/groonga/examples/dictionary/html/css/smoothness/jquery-ui-1.8.12.custom.css
|
||||
share/groonga/examples/dictionary/html/index.html
|
||||
share/groonga/examples/dictionary/html/js/dictionary.js
|
||||
share/groonga/examples/dictionary/html/js/jquery-1.7.2.min.js
|
||||
share/groonga/examples/dictionary/html/js/jquery-ui-1.8.18.custom.min.js
|
||||
share/groonga/examples/dictionary/html/js/jquery-1.7.2.js
|
||||
share/groonga/examples/dictionary/html/js/jquery-ui-1.8.18.custom.js
|
||||
share/groonga/examples/dictionary/init-db.sh
|
||||
share/groonga/examples/dictionary/jmdict/jmdict.rb
|
||||
share/groonga/examples/dictionary/readme.txt
|
||||
|
@ -833,9 +862,9 @@ share/groonga/html/admin/index.html
|
|||
share/groonga/html/admin/index.ja.html
|
||||
share/groonga/html/admin/js/groonga-admin.ja.js
|
||||
share/groonga/html/admin/js/groonga-admin.js
|
||||
share/groonga/html/admin/js/jquery-1.7.2.min.js
|
||||
share/groonga/html/admin/js/jquery-ui-1.8.18.custom.min.js
|
||||
share/groonga/html/admin/js/jquery.flot-0.7.min.js
|
||||
share/groonga/html/admin/js/jquery-1.7.2.js
|
||||
share/groonga/html/admin/js/jquery-ui-1.8.18.custom.js
|
||||
share/groonga/html/admin/js/jquery.flot-0.7.js
|
||||
share/groonga/html/admin/js/jquery.flot.license.txt
|
||||
share/groonga/images/logo/groonga-icon-foreground-white.png
|
||||
share/groonga/images/logo/groonga-icon-foreground-white.svg
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.32 2014/11/04 11:40:20 obache Exp $
|
||||
$NetBSD: distinfo,v 1.33 2014/12/03 08:47:11 obache Exp $
|
||||
|
||||
SHA1 (groonga-4.0.7.tar.gz) = b00c56c6d7318fe1a87f6f55366182ace4014a2a
|
||||
RMD160 (groonga-4.0.7.tar.gz) = 9254e7651161b196f5ed57987cb5cdb8195d8e1b
|
||||
Size (groonga-4.0.7.tar.gz) = 10990151 bytes
|
||||
SHA1 (groonga-4.0.8.tar.gz) = 894bf426c79aaab6e3b1f19811db4634aecdc4c2
|
||||
RMD160 (groonga-4.0.8.tar.gz) = ec9317049a5ef468ac66a2da93f2352ba6a20e8e
|
||||
Size (groonga-4.0.8.tar.gz) = 11343571 bytes
|
||||
SHA1 (patch-lib_grn.h) = 8d1c150fa96dd19fe9092d61ce9e82b425049251
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.14 2014/11/08 11:24:28 obache Exp $
|
||||
# $NetBSD: options.mk,v 1.15 2014/12/03 08:47:11 obache Exp $
|
||||
#
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.groonga
|
||||
|
@ -23,17 +23,8 @@ CONFIGURE_ARGS+= --without-mecab
|
|||
CONFIGURE_ARGS+= --with-cutter
|
||||
USE_TOOLS+= gmake
|
||||
TEST_TARGET= check
|
||||
TEST_ENV+= RUBYOPT="-Ku"
|
||||
.include "../../lang/ruby/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.cutter+= cutter>=1.1.6
|
||||
.include "../../devel/cutter/buildlink3.mk"
|
||||
RUBY_JSON_REQD= 1.8.0:build
|
||||
BUILD_DEPENDS+= ${RUBY_PKGPREFIX}-bundler-[0-9]*:../../misc/ruby-bundler
|
||||
BUILD_DEPENDS+= ${RUBY_PKGPREFIX}-msgpack>=0.5.6:../../devel/ruby-msgpack
|
||||
BUILD_DEPENDS+= ${RUBY_PKGPREFIX}-test-unit>=2.5.5:../../devel/ruby-test-unit
|
||||
BUILD_DEPENDS+= ${RUBY_PKGPREFIX}-test-unit-notify>=1.0.1:../../devel/ruby-test-unit-notify
|
||||
RUBY_JSON_REQD= 0:build
|
||||
.include "../../lang/ruby/json.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-cutter
|
||||
.endif
|
||||
|
@ -101,7 +92,7 @@ CONF_FILES+= share/examples/${PKGBASE}/httpd/win-utf \
|
|||
|
||||
SUBST_CLASSES+= confpath
|
||||
SUBST_STAGE.confpath= post-configure
|
||||
SUBST_FILES.confpath= vendor/nginx-1.7.6/objs/Makefile
|
||||
SUBST_FILES.confpath= vendor/nginx-1.7.7/objs/Makefile
|
||||
SUBST_SED.confpath= -e 's,\$$(DESTDIR)${PKG_SYSCONFDIR}/httpd,\$$(DESTDIR)${PREFIX}/share/examples/${PKGBASE}/httpd,g'
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-groonga-httpd
|
||||
|
|
18
textproc/groonga/patches/patch-lib_grn.h
Normal file
18
textproc/groonga/patches/patch-lib_grn.h
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-lib_grn.h,v 1.1 2014/12/03 08:47:11 obache Exp $
|
||||
|
||||
*BSD doesn't define off64_t. We should use off_t on the environment.
|
||||
https://github.com/groonga/groonga/commit/c019cfbfbf5365c28ce727a46448aa6f77de8543
|
||||
|
||||
--- lib/grn.h.orig 2014-11-28 03:10:30.000000000 +0000
|
||||
+++ lib/grn.h
|
||||
@@ -174,6 +174,10 @@ typedef SOCKET grn_sock;
|
||||
# include <unistd.h>
|
||||
# endif /* HAVE_UNISTD_H */
|
||||
|
||||
+# ifndef __off64_t_defined
|
||||
+typedef off_t off64_t;
|
||||
+# endif
|
||||
+
|
||||
# ifndef PATH_MAX
|
||||
# if defined(MAXPATHLEN)
|
||||
# define PATH_MAX MAXPATHLEN
|
Loading…
Reference in a new issue