Fix build failure on Darwin when pkgsrc libiconv is used
patches/patch-src_portable__c.c: Remove kludge for MacPorts bug, otherwise linking against pkgsrc libiconv will fail due to symbol name mismatch. patches/patch-tmake_lib_macosx-c++_tmake.conf: Make build honor PKGSRC_CFLAGS, otherwise linking against pkgsrc libiconv will fail due to header/library mismatch.
This commit is contained in:
parent
bcb6d09991
commit
726bef2dec
3 changed files with 36 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.54 2014/09/09 00:44:56 mef Exp $
|
||||
$NetBSD: distinfo,v 1.55 2015/01/26 13:35:37 pho Exp $
|
||||
|
||||
SHA1 (doxygen-1.8.8.src.tar.gz) = cd511c73e7669dde5ac3e14a5d1abae093aaf1d9
|
||||
RMD160 (doxygen-1.8.8.src.tar.gz) = d701eb47631aa5e47d8a0fa245b58238276105f3
|
||||
|
@ -9,3 +9,5 @@ SHA1 (patch-ac) = 87c68a2ce598c10d90d775764f4c05739eb51435
|
|||
SHA1 (patch-af) = 2af16b257b49c7917aff5f919da43e20bedec376
|
||||
SHA1 (patch-ah) = db6f117bf1faa3a1ed0b2ca9af81fc4f8d0913f9
|
||||
SHA1 (patch-aj) = 504dfce5474e017e7872208b15a436be669c293c
|
||||
SHA1 (patch-src_portable__c.c) = 88bb2ae294f8eaf16d48d9f07a1e95e754647947
|
||||
SHA1 (patch-tmake_lib_macosx-c++_tmake.conf) = 994cf7ec7eb9d25dacf74c6d6775f4d0573eee5d
|
||||
|
|
17
devel/doxygen/patches/patch-src_portable__c.c
Normal file
17
devel/doxygen/patches/patch-src_portable__c.c
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-src_portable__c.c,v 1.1 2015/01/26 13:35:37 pho Exp $
|
||||
|
||||
Remove kludge for MacPorts bug, otherwise linking against pkgsrc
|
||||
libiconv will fail due to symbol name mismatch.
|
||||
|
||||
--- src/portable_c.c.orig 2014-08-19 12:22:20.000000000 +0000
|
||||
+++ src/portable_c.c
|
||||
@@ -1,9 +1,3 @@
|
||||
-#if (defined(__APPLE__) || defined(macintosh)) && !defined(DMG_BUILD)
|
||||
-// define this before including iconv.h to avoid a mapping of
|
||||
-// iconv_open and friends to libicon_open (done by mac ports),
|
||||
-// while the symbols without 'lib' are linked from /usr/lib/libiconv
|
||||
-#define LIBICONV_PLUG
|
||||
-#endif
|
||||
#include <iconv.h>
|
||||
|
||||
// These functions are implemented in a C file, because there are different
|
16
devel/doxygen/patches/patch-tmake_lib_macosx-c++_tmake.conf
Normal file
16
devel/doxygen/patches/patch-tmake_lib_macosx-c++_tmake.conf
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-tmake_lib_macosx-c++_tmake.conf,v 1.3 2015/01/26 13:35:37 pho Exp $
|
||||
|
||||
Make build honor PKGSRC_CFLAGS, otherwise linking against pkgsrc
|
||||
libiconv will fail due to header/library mismatch.
|
||||
|
||||
--- tmake/lib/macosx-c++/tmake.conf.orig 2014-07-13 13:04:37.000000000 +0000
|
||||
+++ tmake/lib/macosx-c++/tmake.conf
|
||||
@@ -11,7 +11,7 @@ TMAKE_CC = cc
|
||||
TMAKE_CFLAGS = -pipe
|
||||
TMAKE_CFLAGS_WARN_ON = -Wall -W -Wno-deprecated-declarations
|
||||
TMAKE_CFLAGS_WARN_OFF =
|
||||
-TMAKE_CFLAGS_RELEASE = -O2
|
||||
+TMAKE_CFLAGS_RELEASE = ${PKGSRC_CFLAGS}
|
||||
TMAKE_CFLAGS_DEBUG = -g -fstack-protector
|
||||
TMAKE_CFLAGS_SHLIB = -fPIC
|
||||
TMAKE_CFLAGS_YACC = -Wno-unused -Wno-parentheses
|
Loading…
Reference in a new issue