Rather than try to guess which flex version changed the prototype of

yyget_leng() from returning int to returning size_t, since it was
apparently somewhere between the flex I have and the flex Joerg's
build machine has, skip the declaration, since it's apparently no
longer necessary to provide it for flex. This should fix the build on
netbsd-6.
This commit is contained in:
dholland 2013-06-22 22:12:42 +00:00
parent d3edcc962e
commit 729435044c
2 changed files with 7 additions and 6 deletions

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.12 2013/05/25 23:42:45 joerg Exp $
$NetBSD: distinfo,v 1.13 2013/06/22 22:12:42 dholland Exp $
SHA1 (vile-9.8.tgz) = d99f41479fa9726147301193a0e10e4282e4779c
RMD160 (vile-9.8.tgz) = 83a0a76be2e2914a193de9c61b7f1a7d159068df
Size (vile-9.8.tgz) = 2109000 bytes
SHA1 (patch-filters_filters.h) = df8001a5f6607709dd4ba3cf88c25a898b85bb05
SHA1 (patch-filters_filters.h) = b960ebd709e0808837ab5a17af6cc05cf4675d96
SHA1 (patch-filters_makefile.in) = c2127de2f65ee09bce3ee0fd9163be95bf686c61
SHA1 (patch-makefile.in) = 758c8864da18c4929a2287a9fe7ebbedd45352fe

View file

@ -1,13 +1,14 @@
$NetBSD: patch-filters_filters.h,v 1.1 2013/05/25 23:42:45 joerg Exp $
$NetBSD: patch-filters_filters.h,v 1.2 2013/06/22 22:12:42 dholland Exp $
--- filters/filters.h.orig 2013-05-25 20:14:11.000000000 +0000
+++ filters/filters.h
@@ -210,7 +210,7 @@ extern FILE *yyget_in (void);
@@ -210,7 +210,9 @@ extern FILE *yyget_in (void);
extern FILE *yyget_out (void);
extern char *yyget_text (void);
extern int yyget_debug (void);
-extern int yyget_leng (void);
+extern size_t yyget_leng (void);
+#if 0
extern int yyget_leng (void);
+#endif
extern int yyget_lineno (void);
extern int yylex_destroy (void);
extern void yyset_debug (int bdebug);