update to 1.1.19

changes:
-bugfixes
-support WebM container format
-support Xv gamma adjustment
-handle some more formats and Ogg tags

many pkgsrc patches were integrated upstream
This commit is contained in:
drochner 2010-07-28 09:24:14 +00:00
parent d13b100155
commit 72db7c94ab
12 changed files with 21 additions and 284 deletions

View file

@ -1,11 +1,9 @@
# $NetBSD: Makefile,v 1.79 2010/06/13 22:45:08 wiz Exp $
# $NetBSD: Makefile,v 1.80 2010/07/28 09:24:14 drochner Exp $
PKG_DESTDIR_SUPPORT= user-destdir
.include "Makefile.common"
PKGREVISION= 2
COMMENT= Multimedia player library
CONFIGURE_ARGS+= --disable-v4l

View file

@ -1,12 +1,12 @@
# $NetBSD: Makefile.common,v 1.64 2010/04/13 15:09:40 drochner Exp $
# $NetBSD: Makefile.common,v 1.65 2010/07/28 09:24:14 drochner Exp $
#
# used by audio/xine-arts/Makefile
# used by audio/xine-esound/Makefile
# used by audio/xine-pulse/Makefile
DISTNAME= xine-lib-1.1.18.1
XINE_PKGNAME= xine-lib-1.1.18.1
DISTNAME= xine-lib-1.1.19
XINE_PKGNAME= xine-lib-1.1.19
PKGNAME?= ${XINE_PKGNAME}
CATEGORIES?= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xine/}
@ -15,7 +15,7 @@ EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://xinehq.de/
XINE_MOD_DIR_VER= 1.28
XINE_MOD_DIR_VER= 1.29
PLIST_SUBST+= XINE_MOD_DIR_VER=${XINE_MOD_DIR_VER:Q}
DISTINFO_FILE= ${.CURDIR}/../../multimedia/xine-lib/distinfo

View file

@ -1,21 +1,15 @@
$NetBSD: distinfo,v 1.67 2010/07/21 16:47:57 drochner Exp $
$NetBSD: distinfo,v 1.68 2010/07/28 09:24:14 drochner Exp $
SHA1 (xine-lib-1.1.18.1.tar.bz2) = 783232b6d6e23850a7ac97bf53b2a8bc2e743270
RMD160 (xine-lib-1.1.18.1.tar.bz2) = caa05f16a58bb5ba438b6bd4605cdc2ed91c7201
Size (xine-lib-1.1.18.1.tar.bz2) = 7530681 bytes
SHA1 (patch-aa) = 740b3132bcf27886632a6cfe126c3ca493d38c5b
SHA1 (patch-ab) = eb58985011ed97d61dc18ef648c97477558f2ad8
SHA1 (xine-lib-1.1.19.tar.bz2) = 5afcc28c5cf2bdaab99d951960f6587797e1e5a0
RMD160 (xine-lib-1.1.19.tar.bz2) = 84999c43d3cc115c3bda4b2e06089dc827c646cc
Size (xine-lib-1.1.19.tar.bz2) = 7531642 bytes
SHA1 (patch-ad) = 94aaac03f74c72a1ca753d1320aac07d1bb8a846
SHA1 (patch-ae) = 0c101fd7360ba6abfe9003b8fd6eae4028a3cd2d
SHA1 (patch-ag) = 6dee1af3eba997df95d833a2d46331a9e4c46d36
SHA1 (patch-ah) = 56a0cbb1b5b3c9d1a0e55694ebb82307f82d3198
SHA1 (patch-ai) = 4644746f1a5105cdc1e0d20612fc7be467852140
SHA1 (patch-ag) = 26e0937a6018342660180bc6b7076004b68bd545
SHA1 (patch-aj) = 4215c3bc37cf636e563a509f9a391081ed8e773b
SHA1 (patch-ak) = 987700e6526b5112ac66bd6a8f9ee41f338c3508
SHA1 (patch-ao) = 2682548a181803bc2d79f79d76828b6b3ba0e4fa
SHA1 (patch-ap) = f22810c78ac0d1bb7e958ed92fd2ad8a7f889d92
SHA1 (patch-as) = a0a93a256589e87a66eef31494441aa1b200f834
SHA1 (patch-aw) = 52520d47bd9b5af313fab9a38e79f24f5c58d37c
SHA1 (patch-be) = 966d057b118728ff509fd4e7f8005ab5b00b5633
SHA1 (patch-bg) = f072486eb8441b8bed2c825380aa04d99bc70cc1
SHA1 (patch-cb) = db4ff27418e05e97bf30b554beecc24d6e578d15
@ -23,7 +17,5 @@ SHA1 (patch-cd) = a080c745d08ded46db7c1173fe55350c1eb9ff33
SHA1 (patch-da) = f79701d7c036e78d760c12119d88fe3f0dd1762d
SHA1 (patch-db) = 3ad4ca6f43a379b251211477972cd6d34b1f821a
SHA1 (patch-dc) = 11c4212029e67f22796e57706b42400a0dbcac3a
SHA1 (patch-eb) = b65e2c7c30fc04115d55da1ce1f6f65216ac1d23
SHA1 (patch-fa) = 9312a3bab4ae8482a208948277f1d11fb7eaaf8c
SHA1 (patch-fb) = fe4913041758b6e42f32cd810534199129d61351
SHA1 (patch-ga) = c4770b6be12bbc4dd72f8299f3b0bbf92546cc68

View file

@ -1,38 +0,0 @@
$NetBSD: patch-aa,v 1.6 2009/12/09 10:13:03 drochner Exp $
--- src/xine-engine/video_decoder.c.orig 2009-11-30 21:55:51.000000000 +0100
+++ src/xine-engine/video_decoder.c
@@ -41,6 +41,10 @@
#define SPU_SLEEP_INTERVAL (90000/2)
+#ifndef SCHED_OTHER
+#define SCHED_OTHER 0
+#endif
+
static void update_spu_decoder (xine_stream_t *stream, int type) {
@@ -486,7 +490,9 @@ int _x_video_decoder_init (xine_stream_t
} else {
pthread_attr_t pth_attrs;
+#ifdef _POSIX_THREAD_PRIORITY_SCHEDULING
struct sched_param pth_params;
+#endif
int err, num_buffers;
/* The fifo size is based on dvd playback where buffers are filled
* with 2k of data. With 500 buffers and a typical video data rate
@@ -515,10 +521,12 @@ int _x_video_decoder_init (xine_stream_t
stream->spu_track_map_entries = 0;
pthread_attr_init(&pth_attrs);
+#ifdef _POSIX_THREAD_PRIORITY_SCHEDULING
pthread_attr_getschedparam(&pth_attrs, &pth_params);
pth_params.sched_priority = sched_get_priority_min(SCHED_OTHER);
pthread_attr_setschedparam(&pth_attrs, &pth_params);
pthread_attr_setscope(&pth_attrs, PTHREAD_SCOPE_SYSTEM);
+#endif
stream->video_thread_created = 1;
if ((err = pthread_create (&stream->video_thread,

View file

@ -1,27 +0,0 @@
$NetBSD: patch-ab,v 1.5 2009/12/09 10:13:03 drochner Exp $
--- src/xine-engine/audio_decoder.c.orig 2009-11-30 21:55:52.000000000 +0100
+++ src/xine-engine/audio_decoder.c
@@ -463,7 +463,9 @@ static void *audio_decoder_loop (void *s
int _x_audio_decoder_init (xine_stream_t *stream) {
pthread_attr_t pth_attrs;
+#ifdef _POSIX_THREAD_PRIORITY_SCHEDULING
struct sched_param pth_params;
+#endif
int err;
if (stream->audio_out == NULL) {
@@ -501,10 +503,12 @@ int _x_audio_decoder_init (xine_stream_t
*/
pthread_attr_init(&pth_attrs);
+#ifdef _POSIX_THREAD_PRIORITY_SCHEDULING
pthread_attr_getschedparam(&pth_attrs, &pth_params);
pth_params.sched_priority = sched_get_priority_min(SCHED_OTHER);
pthread_attr_setschedparam(&pth_attrs, &pth_params);
pthread_attr_setscope(&pth_attrs, PTHREAD_SCOPE_SYSTEM);
+#endif
stream->audio_thread_created = 1;
if ((err = pthread_create (&stream->audio_thread,

View file

@ -1,84 +0,0 @@
$NetBSD: patch-ae,v 1.7 2009/12/09 10:13:03 drochner Exp $
--- src/input/input_vcd.c.orig 2009-11-30 21:55:44.000000000 +0100
+++ src/input/input_vcd.c
@@ -29,6 +29,7 @@
#include <errno.h>
#include <fcntl.h>
#include <sys/ioctl.h>
+#include <sys/param.h>
#include <string.h>
#include <netinet/in.h>
#ifdef HAVE_LINUX_CDROM_H
@@ -92,7 +93,7 @@ typedef struct {
#if defined (__linux__) || defined(__sun)
struct cdrom_tochdr tochdr;
struct cdrom_tocentry tocent[100];
-#elif defined (__FreeBSD_kernel__) || defined (__OpenBSD__)
+#elif (defined(BSD) && BSD >= 199306)
struct ioc_toc_header tochdr;
struct cd_toc_entry *tocent;
off_t cur_sec;
@@ -117,7 +118,7 @@ typedef struct {
int cur_track;
-#if defined (__linux__) || defined(__sun) || defined (__FreeBSD_kernel__) || defined (__OpenBSD__)
+#if defined (__linux__) || defined(__sun) || (defined(BSD) && BSD >= 199306)
uint8_t cur_min, cur_sec, cur_frame;
#endif
@@ -177,7 +178,7 @@ static int input_vcd_read_toc (vcd_input
return 0;
}
-#elif defined (__FreeBSD_kernel__) || defined (__OpenBSD__)
+#elif (defined(BSD) && BSD >= 199306)
static int input_vcd_read_toc (vcd_input_class_t *this, int fd) {
struct ioc_read_toc_entry te;
@@ -393,7 +394,7 @@ static off_t vcd_plugin_read (input_plug
memcpy (buf, data.data, VCDSECTORSIZE); /* FIXME */
return VCDSECTORSIZE;
}
-#elif defined (__FreeBSD_kernel__) || defined (__OpenBSD__)
+#elif (defined(BSD) && BSD >= 199306)
static off_t vcd_plugin_read (input_plugin_t *this_gen,
char *buf, off_t nlen) {
vcd_input_plugin_t *this = (vcd_input_plugin_t *) this_gen;
@@ -531,7 +532,7 @@ static buf_element_t *vcd_plugin_read_bl
memcpy (buf->mem, data.data, VCDSECTORSIZE); /* FIXME */
return buf;
}
-#elif defined (__FreeBSD_kernel__) || defined (__OpenBSD__)
+#elif (defined(BSD) && BSD >= 199306)
static buf_element_t *vcd_plugin_read_block (input_plugin_t *this_gen,
fifo_buffer_t *fifo, off_t nlen) {
@@ -690,7 +691,7 @@ static off_t vcd_plugin_seek (input_plug
return offset ; /* FIXME */
}
-#elif defined (__FreeBSD_kernel__) || defined (__OpenBSD__)
+#elif (defined(BSD) && BSD >= 199306)
static off_t vcd_plugin_seek (input_plugin_t *this_gen,
off_t offset, int origin) {
@@ -764,7 +765,7 @@ static off_t vcd_plugin_get_length (inpu
return (off_t) 0;
}
-#elif defined (__FreeBSD_kernel__) || defined (__OpenBSD__)
+#elif (defined(BSD) && BSD >= 199306)
static off_t vcd_plugin_get_length (input_plugin_t *this_gen) {
vcd_input_plugin_t *this = (vcd_input_plugin_t *) this_gen;
off_t len ;
@@ -859,7 +860,7 @@ static int vcd_plugin_open (input_plugin
this->cur_min = this->cls->tocent[this->cur_track].cdte_addr.msf.minute;
this->cur_sec = this->cls->tocent[this->cur_track].cdte_addr.msf.second;
this->cur_frame = this->cls->tocent[this->cur_track].cdte_addr.msf.frame;
-#elif defined (__OpenBSD__)
+#elif defined (__OpenBSD__) || defined(__NetBSD__)
this->cur_min = this->cls->tocent[this->cur_track + 1 - this->cls->tochdr.starting_track].addr.msf.minute;
this->cur_sec = this->cls->tocent[this->cur_track + 1 - this->cls->tochdr.starting_track].addr.msf.second;
this->cur_frame = this->cls->tocent[this->cur_track + 1 - this->cls->tochdr.starting_track].addr.msf.frame;

View file

@ -1,17 +1,8 @@
$NetBSD: patch-ag,v 1.20 2009/12/09 10:13:03 drochner Exp $
$NetBSD: patch-ag,v 1.21 2010/07/28 09:24:14 drochner Exp $
--- configure.ac.orig 2009-12-01 02:52:45.000000000 +0100
--- configure.ac.orig 2010-07-26 10:02:15.000000000 +0000
+++ configure.ac
@@ -109,7 +109,7 @@ dnl ------------------------------------
AC_CANONICAL_HOST
AC_CANONICAL_BUILD
-test "$host" == "$build" && check_athlon=yes
+test "$host" = "$build" && check_athlon=yes
AC_CONFIG_HEADERS([include/configure.h])
@@ -580,6 +580,9 @@ AC_CHECK_LIB(socket, socket, NET_LIBS="-
@@ -581,6 +581,9 @@ AC_CHECK_LIB(socket, socket, NET_LIBS="-
AC_CHECK_LIB(nsl, gethostbyname, NET_LIBS="-lnsl $NET_LIBS",)
AC_SUBST(NET_LIBS)
@ -21,34 +12,7 @@ $NetBSD: patch-ag,v 1.20 2009/12/09 10:13:03 drochner Exp $
dnl ---------------------------------------------
dnl socklen_t
@@ -770,7 +773,7 @@ XXMC_LIBS="${xxmc_path:+-L}$xxmc_path -l
AC_MSG_CHECKING(whether to enable the xxmc plugin with vld extensions)
AC_MSG_RESULT()
dnl Check if vld "extended" XvMC is available
-if test "x$xxmc_stub" == "xXvMCW" && test "x$ac_have_xv" == "xyes"; then
+if test "x$xxmc_stub" = "xXvMCW" && test "x$ac_have_xv" = "xyes"; then
AC_CHECK_LIB($xxmc_stub, XvMCPutSlice,
ac_have_xxmc="yes",
[ac_have_xxmc="no"
@@ -800,7 +803,7 @@ if test "x$ac_have_xxmc" = "xyes"; then
fi
dnl Try fallback to standard XvMC if vld failed
if test "x$ac_have_xxmc" = "xno"; then
- if test "x$xxmc_stub" == "xXvMCW"; then
+ if test "x$xxmc_stub" = "xXvMCW"; then
AC_CHECK_LIB($xxmc_stub, XvMCCreateContext,
ac_have_xxmc="yes",
[ac_have_xxmc="no"
@@ -854,7 +857,7 @@ saved_libs="$LIBS"
XVMC_LIBS="${xvmc_path:+-L}$xvmc_path -l$xvmc_stub"
AC_MSG_CHECKING(whether to enable the xvmc plugin)
AC_MSG_RESULT()
-if test "x$xvmc_stub" == "xXvMCW"; then
+if test "x$xvmc_stub" = "xXvMCW"; then
AC_CHECK_LIB($xvmc_stub, XvMCCreateContext,
ac_have_xvmc="yes",
[ac_have_xvmc="no"
@@ -945,7 +948,6 @@ if test "x$enable_xinerama" != "xno"; th
@@ -968,7 +971,6 @@ if test "x$enable_xinerama" != "xno"; th
])
if test "x$ac_have_xinerama" = "xyes"; then
AC_DEFINE(HAVE_XINERAMA,1,[Define this if you have libXinerama installed])
@ -56,11 +20,11 @@ $NetBSD: patch-ag,v 1.20 2009/12/09 10:13:03 drochner Exp $
fi
else
ac_have_xinerama=no
@@ -1457,8 +1459,21 @@ AC_ARG_ENABLE([oss],
@@ -1480,8 +1482,21 @@ AC_ARG_ENABLE([oss],
AS_HELP_STRING([--disable-oss], [Do not build OSS audio output support]))
if test "x$enable_oss" != "xno"; then
+
+
+ case "$host" in
+ *-*-netbsd*|*-*-openbsd*)
+ OSS_LIBS="-lossaudio"
@ -78,7 +42,7 @@ $NetBSD: patch-ag,v 1.20 2009/12/09 10:13:03 drochner Exp $
#ifdef HAVE_SYS_SOUNDCARD_H
# include <sys/soundcard.h>
#endif
@@ -1476,6 +1491,7 @@ if test "x$enable_oss" != "xno"; then
@@ -1499,6 +1514,7 @@ if test "x$enable_oss" != "xno"; then
fi
AM_CONDITIONAL(HAVE_OSS, test "x$have_ossaudio" = "xyes")
@ -86,7 +50,7 @@ $NetBSD: patch-ag,v 1.20 2009/12/09 10:13:03 drochner Exp $
dnl ---------------------------------------------
@@ -1607,9 +1623,10 @@ AC_ARG_ENABLE([gnomevfs],
@@ -1630,9 +1646,10 @@ AC_ARG_ENABLE([gnomevfs],
[with_gnome_vfs=$enableval], [with_gnome_vfs=yes])
if test "x$with_gnome_vfs" = "xyes"; then
@ -94,13 +58,13 @@ $NetBSD: patch-ag,v 1.20 2009/12/09 10:13:03 drochner Exp $
- no_gnome_vfs=no,
- no_gnome_vfs=yes)
+dnl PKG_CHECK_MODULES(GNOME_VFS, gnome-vfs-2.0,
+dnl no_gnome_vfs=no,
+dnl no_gnome_vfs=yes)
+dnl no_gnome_vfs=no,
+dnl no_gnome_vfs=yes)
+no_gnome_vfs=yes
AC_SUBST(GNOME_VFS_CFLAGS)
AC_SUBST(GNOME_VFS_LIBS)
if test "x$no_gnome_vfs" != "xyes"; then
@@ -1944,7 +1961,7 @@ int has_timeout=sizeof(test.timeout);]])
@@ -1973,7 +1990,7 @@ int has_timeout=sizeof(test.timeout);]])
AC_DEFINE([HAVE_WIN32_CDROM], [1],
[Define 1 if you have MinGW CD-ROM support])
;;

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ah,v 1.4 2009/12/09 10:13:03 drochner Exp $
--- src/xine-engine/video_out.c.orig 2009-12-01 02:33:30.000000000 +0100
+++ src/xine-engine/video_out.c
@@ -1905,7 +1905,9 @@ xine_video_port_t *_x_vo_new_port (xine_
this->grab_only = 0;
pthread_attr_init(&pth_attrs);
+#ifdef _POSIX_THREAD_PRIORITY_SCHEDULING
pthread_attr_setscope(&pth_attrs, PTHREAD_SCOPE_SYSTEM);
+#endif
if ((err = pthread_create (&this->video_thread,
&pth_attrs, video_out_loop, this)) != 0) {

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ai,v 1.4 2009/12/09 10:13:03 drochner Exp $
--- src/xine-engine/audio_out.c.orig 2009-12-01 02:33:30.000000000 +0100
+++ src/xine-engine/audio_out.c
@@ -2279,7 +2279,9 @@ xine_audio_port_t *_x_ao_new_port (xine_
this->audio_loop_running = 1;
pthread_attr_init(&pth_attrs);
+#ifdef _POSIX_THREAD_PRIORITY_SCHEDULING
pthread_attr_setscope(&pth_attrs, PTHREAD_SCOPE_SYSTEM);
+#endif
this->audio_thread_created = 1;
if ((err = pthread_create (&this->audio_thread,

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aw,v 1.4 2009/12/09 10:13:03 drochner Exp $
--- src/post/audio/upmix.c.orig 2009-11-30 21:55:58.000000000 +0100
+++ src/post/audio/upmix.c
@@ -396,6 +396,8 @@ static post_plugin_t *upmix_open_plugin(
_x_post_init(&this->post, 1, 0);
+ pthread_mutex_init(&this->lock, 0);
+
this->params.cut_off_freq = 100;
port = _x_post_intercept_audio_port(&this->post, audio_target[0], &input, &output);

View file

@ -1,12 +0,0 @@
$NetBSD: patch-eb,v 1.1 2007/01/09 14:46:31 drochner Exp $
--- src/input/libdvdnav/dvd_input.c.orig 2007-01-09 00:03:58.000000000 +0100
+++ src/input/libdvdnav/dvd_input.c
@@ -319,6 +319,7 @@ static int file_read(dvd_input_t dev, vo
return (int) (bytes / DVD_VIDEO_LB_LEN);
}
+ buffer += ret;
len -= ret;
}

View file

@ -1,15 +0,0 @@
$NetBSD: patch-fb,v 1.2 2009/12/09 10:13:03 drochner Exp $
--- ./src/xine-engine/demux.c.orig 2009-11-30 21:55:52.000000000 +0100
+++ ./src/xine-engine/demux.c
@@ -349,6 +349,10 @@ static void *demux_loop (void *stream_ge
gettimeofday(&tv, NULL);
ts.tv_sec = tv.tv_sec;
ts.tv_nsec = (tv.tv_usec + 100000) * 1000;
+ if (ts.tv_nsec >= 1000000000) {
+ ts.tv_nsec -= 1000000000;
+ ts.tv_sec += 1;
+ }
pthread_cond_timedwait (&stream->demux_resume, &stream->demux_lock, &ts);
}