Make this package compile:

+ use cpp0 rather than cpp
+ add missing dependency on Perl
+ use NetBSD's libtool rather than rolling our own at config time
This commit is contained in:
agc 2002-07-17 08:36:10 +00:00
parent 687d6d1cb4
commit 72dbba9b67
3 changed files with 19 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2002/06/15 20:57:51 wiz Exp $
# $NetBSD: Makefile,v 1.3 2002/07/17 08:36:10 agc Exp $
DISTNAME= cilk-5.3.1
CATEGORIES= lang parallel
@ -12,8 +12,11 @@ COMMENT= multithreaded parallel programming language based on ANSI C
GNU_CONFIGURE= # defined
USE_BUILDLINK_ONLY= # defined
USE_GMAKE= # defined
USE_PERL5= yes
USE_PTHREAD= native pth
USE_LIBTOOL= yes
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
INFO_FILES= cilk-faq.info

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2002/05/04 00:37:29 jtb Exp $
$NetBSD: distinfo,v 1.2 2002/07/17 08:36:11 agc Exp $
SHA1 (cilk-5.3.1.tar.gz) = 2a0d142badc7be57787c4608fc07b98090207994
Size (cilk-5.3.1.tar.gz) = 848755 bytes
SHA1 (patch-aa) = de31546280810242eb44f1d06ded023d23109092
SHA1 (patch-ab) = e4ae168977deb547e9c388ebcf2bac4dc7d8bbcd

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2002/07/17 08:36:12 agc Exp $
--- support/Makefile.in 2002/07/17 08:20:43 1.1
+++ support/Makefile.in 2002/07/17 08:21:04
@@ -83,7 +83,7 @@
CILK_PAGESIZE = @CILK_PAGESIZE@
PTHREAD_LIBS = @PTHREAD_LIBS@ @HOARD_LIBS@
GNU_LD = "@HAVE_GNU_LD@"
-CPP_FOR_CILK = @CPP_FOR_CILK@
+CPP_FOR_CILK = cpp0
CC = ./cilk-local