Fix build with gcc2. From Hauke Fath.

This commit is contained in:
wiz 2005-01-26 14:11:34 +00:00
parent 4ec1d9b286
commit 72f595644e
2 changed files with 25 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2005/01/19 12:54:13 wiz Exp $
$NetBSD: distinfo,v 1.3 2005/01/26 14:11:34 wiz Exp $
SHA1 (radmind-1.4.0.tgz) = 68fcb7cf9dba6449cb501f216d510bf4f5badff1
Size (radmind-1.4.0.tgz) = 342647 bytes
SHA1 (patch-aa) = a6a8de2f5f91dbdbd7b46ec795fa5e4bf60c97c9
SHA1 (patch-ab) = b973563ae1899f2f3acf8a682d3d6a51cd0db889
SHA1 (patch-ac) = c12925c0eba55ed1406a6bb5243d99f3a2a52ea2

View file

@ -0,0 +1,23 @@
$NetBSD: patch-ac,v 1.1 2005/01/26 14:11:34 wiz Exp $
--- tls.c.orig 2005-01-26 15:07:39.000000000 +0100
+++ tls.c
@@ -194,7 +194,8 @@ tls_client_start( SNET *sn, char *host,
char *line;
int ntype;
struct in_addr addr;
-
+ int alt_ext;
+
if ( inet_aton( host, &addr )) {
ntype = IS_IP4;
} else {
@@ -239,7 +240,7 @@ tls_client_start( SNET *sn, char *host,
/* This code gratiously borrowed from openldap-2.2.17,
* it allows the use of aliases in the certificate.
*/
- int alt_ext = X509_get_ext_by_NID( peer, NID_subject_alt_name, -1);
+ alt_ext = X509_get_ext_by_NID( peer, NID_subject_alt_name, -1);
if ( alt_ext >= 0 ) {
X509_EXTENSION *ex;