Update to 1.7.8. Not pasting the upstream changelog here, because it's a
massive (6 years of development).
This commit is contained in:
parent
7affdb90c1
commit
72fb218751
5 changed files with 77 additions and 36 deletions
|
@ -1,25 +1,32 @@
|
|||
# $NetBSD: Makefile,v 1.20 2009/08/26 19:56:43 sno Exp $
|
||||
# $NetBSD: Makefile,v 1.21 2009/09/01 16:44:26 hasso Exp $
|
||||
#
|
||||
|
||||
DISTNAME= DevIL-1.6.6
|
||||
DISTNAME= DevIL-${DEVIL_VERSION}
|
||||
PKGNAME= ${DISTNAME:S/D/d/}
|
||||
PKGREVISION= 10
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=openil/}
|
||||
|
||||
DEVIL_VERSION= 1.7.8
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://openil.sourceforge.net/
|
||||
COMMENT= Developer's Image Library
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
WRKSRC= ${WRKDIR}/DevIL
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
WRKSRC= ${WRKDIR}/devil-${DEVIL_VERSION}
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
CONFIGURE_ARGS+= --disable-lcms
|
||||
INFO_FILES= yes
|
||||
|
||||
CONFIGURE_ARGS+= --enable-ILU
|
||||
CONFIGURE_ARGS+= --enable-ILUT
|
||||
|
||||
.include "../../devel/SDL/buildlink3.mk"
|
||||
.include "../../graphics/glu/buildlink3.mk"
|
||||
.include "../../graphics/jasper/buildlink3.mk"
|
||||
.include "../../graphics/jpeg/buildlink3.mk"
|
||||
.include "../../graphics/libungif/buildlink3.mk"
|
||||
.include "../../graphics/mng/buildlink3.mk"
|
||||
|
|
|
@ -1,11 +1,14 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2009/06/14 17:48:40 joerg Exp $
|
||||
include/IL/config.h
|
||||
include/IL/devil_internal_exports.h
|
||||
@comment $NetBSD: PLIST,v 1.4 2009/09/01 16:44:26 hasso Exp $
|
||||
bin/ilur
|
||||
include/IL/devil_cpp_wrapper.hpp
|
||||
include/IL/il.h
|
||||
include/IL/il_wrap.h
|
||||
include/IL/ilu.h
|
||||
include/IL/ilu_region.h
|
||||
include/IL/ilut.h
|
||||
lib/libIL.la
|
||||
lib/libILU.la
|
||||
lib/libILUT.la
|
||||
lib/pkgconfig/IL.pc
|
||||
lib/pkgconfig/ILU.pc
|
||||
lib/pkgconfig/ILUT.pc
|
||||
info/DevIL_manual.info
|
||||
|
|
|
@ -1,15 +1,17 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.16 2009/08/26 19:56:43 sno Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.17 2009/09/01 16:44:26 hasso Exp $
|
||||
|
||||
BUILDLINK_TREE+= devIL
|
||||
|
||||
.if !defined(DEVIL_BUILDLINK3_MK)
|
||||
DEVIL_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.devIL+= devIL>=1.6.6nb1
|
||||
BUILDLINK_ABI_DEPENDS.devIL+= devIL>=1.6.6nb10
|
||||
BUILDLINK_API_DEPENDS.devIL+= devIL>=1.7.8
|
||||
BUILDLINK_ABI_DEPENDS.devIL+= devIL>=1.7.8
|
||||
BUILDLINK_PKGSRCDIR.devIL?= ../../devel/devIL
|
||||
|
||||
.include "../../devel/SDL/buildlink3.mk"
|
||||
.include "../../graphics/glu/buildlink3.mk"
|
||||
.include "../../graphics/jasper/buildlink3.mk"
|
||||
.include "../../graphics/jpeg/buildlink3.mk"
|
||||
.include "../../graphics/libungif/buildlink3.mk"
|
||||
.include "../../graphics/mng/buildlink3.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.3 2006/04/28 14:30:58 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.4 2009/09/01 16:44:26 hasso Exp $
|
||||
|
||||
SHA1 (DevIL-1.6.6.tar.gz) = 946883351dcd72d00618887f1faa01d173317903
|
||||
RMD160 (DevIL-1.6.6.tar.gz) = f609c71397c143517b045f764c549528f7cb5e84
|
||||
Size (DevIL-1.6.6.tar.gz) = 787878 bytes
|
||||
SHA1 (patch-aa) = 1cc5f64f053b7b229156a6283604cf47aff47c6e
|
||||
SHA1 (DevIL-1.7.8.tar.gz) = bc27e3e830ba666a3af03548789700d10561fcb1
|
||||
RMD160 (DevIL-1.7.8.tar.gz) = a3cdb14fcca5e75ada240a53cbdc3e749a759da5
|
||||
Size (DevIL-1.7.8.tar.gz) = 2051993 bytes
|
||||
SHA1 (patch-aa) = 19709646bddabe8160adaf2b03b6f9628b712a94
|
||||
|
|
|
@ -1,20 +1,49 @@
|
|||
$NetBSD: patch-aa,v 1.1 2006/04/28 14:30:58 joerg Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2009/09/01 16:44:26 hasso Exp $
|
||||
|
||||
--- src-IL/src/il_tiff.c.orig 2006-04-28 12:38:43.000000000 +0000
|
||||
+++ src-IL/src/il_tiff.c
|
||||
@@ -168,13 +168,13 @@ ILboolean ilLoadTiffL(ILvoid *Lump, ILui
|
||||
void warningHandler(const char* mod, const char* fmt, va_list ap)
|
||||
{
|
||||
char buff[1024];
|
||||
- _vsnprintf(buff, 1024, fmt, ap);
|
||||
+ vsnprintf(buff, 1024, fmt, ap);
|
||||
}
|
||||
--- src-ILUT/src/ilut_opengl.c.orig 2009-08-30 23:51:10 +0300
|
||||
+++ src-ILUT/src/ilut_opengl.c 2009-08-30 23:53:28 +0300
|
||||
@@ -58,7 +58,7 @@ void *aglGetProcAddress( const GLubyte *
|
||||
// #pragma comment(lib, "freeglut.lib")
|
||||
#endif
|
||||
|
||||
void errorHandler(const char* mod, const char* fmt, va_list ap)
|
||||
{
|
||||
char buff[1024];
|
||||
- _vsnprintf(buff, 1024, fmt, ap);
|
||||
+ vsnprintf(buff, 1024, fmt, ap);
|
||||
}
|
||||
-#ifdef linux
|
||||
+#if defined(linux) || defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD) || defined(__OpenBSD__)
|
||||
// fix for glXGetProcAddressARB
|
||||
#define GLX_GLXEXT_PROTOTYPES
|
||||
#include <GL/glx.h>
|
||||
@@ -84,7 +84,7 @@ void *aglGetProcAddress( const GLubyte *
|
||||
|
||||
// Internal function used to load the Tiff.
|
||||
static ILboolean HasCubemapHardware = IL_FALSE;
|
||||
static ILboolean HasNonPowerOfTwoHardware = IL_FALSE;
|
||||
-#if defined(_WIN32) || defined(_WIN64) || defined(linux) || defined(__APPLE__)
|
||||
+#if defined(_WIN32) || defined(_WIN64) || defined(linux) || defined(__APPLE__) || defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD) || defined(__OpenBSD__)
|
||||
ILGLTEXIMAGE3DARBPROC ilGLTexImage3D = NULL;
|
||||
ILGLTEXSUBIMAGE3DARBPROC ilGLTexSubImage3D = NULL;
|
||||
ILGLCOMPRESSEDTEXIMAGE2DARBPROC ilGLCompressed2D = NULL;
|
||||
@@ -127,7 +127,7 @@ ILboolean ilutGLInit()
|
||||
IsExtensionSupported("GL_EXT_texture3D")) {
|
||||
ilGLCompressed3D = (ILGLCOMPRESSEDTEXIMAGE3DARBPROC)wglGetProcAddress("glCompressedTexImage3DARB");
|
||||
}
|
||||
- #elif linux
|
||||
+ #elif defined(linux) || defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD) || defined(__OpenBSD__)
|
||||
if (IsExtensionSupported("GL_ARB_texture_compression") &&
|
||||
IsExtensionSupported("GL_EXT_texture_compression_s3tc")) {
|
||||
ilGLCompressed2D = (ILGLCOMPRESSEDTEXIMAGE2DARBPROC)
|
||||
@@ -246,7 +246,7 @@ ILuint GLGetDXTCNum(ILenum DXTCFormat)
|
||||
ILboolean ILAPIENTRY ilutGLTexImage_(GLuint Level, GLuint Target, ILimage *Image)
|
||||
{
|
||||
ILimage *ImageCopy, *OldImage;
|
||||
-#if defined (_MSC_VER) || defined (linux) || defined(__APPLE__)
|
||||
+#if defined (_MSC_VER) || defined (linux) || defined(__APPLE__) || defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD) || defined(__OpenBSD__)
|
||||
ILenum DXTCFormat;
|
||||
ILuint Size;
|
||||
ILubyte *Buffer;
|
||||
@@ -259,7 +259,7 @@ ILboolean ILAPIENTRY ilutGLTexImage_(GLu
|
||||
|
||||
OldImage = ilGetCurImage();
|
||||
|
||||
-#if defined (_MSC_VER) || defined (linux) || defined(__APPLE__)
|
||||
+#if defined (_MSC_VER) || defined (linux) || defined(__APPLE__) || defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD) || defined(__OpenBSD__)
|
||||
if (ilutGetBoolean(ILUT_GL_USE_S3TC) && ilGLCompressed2D != NULL) {
|
||||
if (Image->DxtcData != NULL && Image->DxtcSize != 0) {
|
||||
DXTCFormat = GLGetDXTCNum(Image->DxtcFormat);
|
||||
|
|
Loading…
Reference in a new issue