spirv-llvm-translator: update to 14.0.0 fix the build

Changes unknown.
This commit is contained in:
tnn 2022-08-15 20:39:21 +00:00
parent ff08c9ed90
commit 73032a694a
25 changed files with 28 additions and 346 deletions

View file

@ -1,13 +1,17 @@
# $NetBSD: Makefile,v 1.1 2021/11/20 20:06:55 wiz Exp $
# $NetBSD: Makefile,v 1.2 2022/08/15 20:39:21 tnn Exp $
DISTNAME= SPIRV-Headers-1.2.198.0
# This version should be kept in sync with what
# parallel/spirv-llvm-translator's ${WRKSRC}/spirv-headers-tag.conf
# contains.
DISTNAME= SPIRV-Headers-1.3.216.0
CATEGORIES= parallel
MASTER_SITES= ${MASTER_SITE_GITHUB:=KhronosGroup/}
GITHUB_TAG= sdk-1.2.198.0
GITHUB_TAG= sdk-${PKGVERSION_NOREV}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/KhronosGroup/SPIRV-Headers
COMMENT= Headers for translation between SPIR-V and LLVM IR
LICENSE= mit
USE_CMAKE= yes
USE_LANGUAGES= c c++

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2021/11/20 20:06:55 wiz Exp $
@comment $NetBSD: PLIST,v 1.2 2022/08/15 20:39:21 tnn Exp $
include/spirv/1.0/GLSL.std.450.h
include/spirv/1.0/OpenCL.std.h
include/spirv/1.0/extinst.glsl.std.450.grammar.json
@ -58,6 +58,7 @@ include/spirv/unified1/extinst.spv-amd-gcn-shader.grammar.json
include/spirv/unified1/extinst.spv-amd-shader-ballot.grammar.json
include/spirv/unified1/extinst.spv-amd-shader-explicit-vertex-parameter.grammar.json
include/spirv/unified1/extinst.spv-amd-shader-trinary-minmax.grammar.json
include/spirv/unified1/spirv.bf
include/spirv/unified1/spirv.core.grammar.json
include/spirv/unified1/spirv.cs
include/spirv/unified1/spirv.h

View file

@ -1,11 +1,11 @@
# $NetBSD: buildlink3.mk,v 1.1 2021/11/20 20:06:55 wiz Exp $
# $NetBSD: buildlink3.mk,v 1.2 2022/08/15 20:39:21 tnn Exp $
BUILDLINK_TREE+= SPIRV-Headers
.if !defined(SPIRV_HEADERS_BUILDLINK3_MK)
SPIRV_HEADERS_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.SPIRV-Headers+= SPIRV-Headers>=1.2.198.0
BUILDLINK_API_DEPENDS.SPIRV-Headers+= SPIRV-Headers>=1.3.216.0
BUILDLINK_PKGSRCDIR.SPIRV-Headers?= ../../parallel/spirv-headers
BUILDLINK_DEPMETHOD.SPIRV-Headers?= build
.endif # SPIRV_HEADERS_BUILDLINK3_MK

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.1 2021/11/20 20:06:55 wiz Exp $
$NetBSD: distinfo,v 1.2 2022/08/15 20:39:21 tnn Exp $
BLAKE2s (SPIRV-Headers-1.2.198.0.tar.gz) = 9c797196b2fdc42dfbf34eed28acfe78037cbba614cfffdfd925ba882e9bbbb8
SHA512 (SPIRV-Headers-1.2.198.0.tar.gz) = a35167f8de66f2e16c6d2dccdd69f95c58b08abcdef5dac5a705e8e52af049ec9b0e2d0ef6fb732454a0671cd331b69bea75b24911599c0a2ce3972d40addfef
Size (SPIRV-Headers-1.2.198.0.tar.gz) = 416113 bytes
BLAKE2s (SPIRV-Headers-1.3.216.0.tar.gz) = d8f2122fc7c99084f5526066093ea412b29d3674b3e65cfc4b6f76b5b544b5a9
SHA512 (SPIRV-Headers-1.3.216.0.tar.gz) = 951715cf62a643bfce6a3854f2206b95dd65e60b27355a2f290e829da0f06e19877e9dfcbf53f455b8a0524fb851a851742f3e16bb29be2f470cd62d3a8fc8f0
Size (SPIRV-Headers-1.3.216.0.tar.gz) = 437011 bytes

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.5 2022/08/15 19:22:52 wiz Exp $
# $NetBSD: Makefile,v 1.6 2022/08/15 20:39:21 tnn Exp $
DISTNAME= SPIRV-LLVM-Translator-13.0.0
DISTNAME= SPIRV-LLVM-Translator-14.0.0
PKGNAME= ${DISTNAME:tl}
CATEGORIES= parallel
MASTER_SITES= ${MASTER_SITE_GITHUB:=KhronosGroup/}
@ -13,15 +13,13 @@ LICENSE= modified-bsd
WRKSRC= ${WRKDIR}/${DISTNAME}
BROKEN= "This version does not support llvm 14, please update this to 14.0.0."
USE_CMAKE= yes
USE_LANGUAGES= c c++
GCC_REQD+= 5 # C++14
GCC_REQD+= 7 # sync with llvm
CMAKE_ARGS+= -DBUILD_SHARED_LIBS=ON
CMAKE_ARGS+= -DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR=${PREFIX}/include
CMAKE_ARGS+= -DLLVM_EXTERNAL_SPIRV_HEADERS_SOURCE_DIR=${PREFIX}/include/libLLVM
PKGCONFIG_OVERRIDE+= LLVMSPIRVLib.pc.in

View file

@ -1,7 +1,7 @@
@comment $NetBSD: PLIST,v 1.3 2021/11/23 20:55:44 wiz Exp $
@comment $NetBSD: PLIST,v 1.4 2022/08/15 20:39:21 tnn Exp $
include/LLVMSPIRVLib/LLVMSPIRVExtensions.inc
include/LLVMSPIRVLib/LLVMSPIRVLib.h
include/LLVMSPIRVLib/LLVMSPIRVOpts.h
lib/libLLVMSPIRVLib.so
lib/libLLVMSPIRVLib.so.13
lib/libLLVMSPIRVLib.so.14
lib/pkgconfig/LLVMSPIRVLib.pc

View file

@ -1,13 +1,13 @@
# $NetBSD: buildlink3.mk,v 1.2 2021/06/09 14:56:51 nia Exp $
# $NetBSD: buildlink3.mk,v 1.3 2022/08/15 20:39:21 tnn Exp $
BUILDLINK_TREE+= spirv-llvm-translator
.if !defined(SPIRV_LLVM_TRANSLATOR_BUILDLINK3_MK)
SPIRV_LLVM_TRANSLATOR_BUILDLINK3_MK:=
GCC_REQD+= 5 # C++14
GCC_REQD+= 7 # sync with llvm
BUILDLINK_API_DEPENDS.spirv-llvm-translator+= spirv-llvm-translator>=10.0.0
BUILDLINK_API_DEPENDS.spirv-llvm-translator+= spirv-llvm-translator>=14.0.0
BUILDLINK_PKGSRCDIR.spirv-llvm-translator?= ../../parallel/spirv-llvm-translator
.include "../../lang/llvm/buildlink3.mk"

View file

@ -1,23 +1,6 @@
$NetBSD: distinfo,v 1.5 2021/11/23 20:55:44 wiz Exp $
$NetBSD: distinfo,v 1.6 2022/08/15 20:39:21 tnn Exp $
BLAKE2s (SPIRV-LLVM-Translator-13.0.0.tar.gz) = 1d544e845cb4adfc4c9a5056ab48c4347bf5cc0848bcf21f5ab098a583e6d272
SHA512 (SPIRV-LLVM-Translator-13.0.0.tar.gz) = 1ce7a38c2c3447249e19d50063a7a2acf32699905572950e4f102d8ce1680785433035154b7b55782d5a56211a50e042aef775836f37c33fe847b347a02b5a04
Size (SPIRV-LLVM-Translator-13.0.0.tar.gz) = 1436324 bytes
BLAKE2s (SPIRV-LLVM-Translator-14.0.0.tar.gz) = c3aa2584d427b33aacd85cb3406a222505a56ae32a7f3d674822bf34e8417ea2
SHA512 (SPIRV-LLVM-Translator-14.0.0.tar.gz) = 5659149a380ceef7acdcb274bcad9b23e4817bf88e795e0a8464dfe14fbd102dbf7199cbe67eb611a16d3a411c7a1b8afc6f0eef61fec5a2b8f9fba06748bcb1
Size (SPIRV-LLVM-Translator-14.0.0.tar.gz) = 1482704 bytes
SHA1 (patch-CMakeLists.txt) = db9173e06fb702c3fa88844fc87380262024cbe1
SHA1 (patch-lib_SPIRV_SPIRVReader.cpp) = 25dc02f63e6b32f69afa0388ceb945131c2fb48e
SHA1 (patch-lib_SPIRV_SPIRVWriter.cpp) = cd9030f5ab63b0c7ba9492e101578b7431fdc903
SHA1 (patch-lib_SPIRV_SPIRVWriter.h) = db22ff84b6cd8494898ea5cd35f53bde8e6c35a0
SHA1 (patch-lib_SPIRV_libSPIRV_SPIRVFunction.h) = 8290d8246db59c3beb27866a7c555a08468e8d05
SHA1 (patch-lib_SPIRV_libSPIRV_SPIRVModule.cpp) = 683a2d76e4faaed82179f6f995e1c272e706fcf5
SHA1 (patch-lib_SPIRV_libSPIRV_SPIRVModule.h) = 83ddc00be71ce79d1fe1b63564857053da9fd1f3
SHA1 (patch-lib_SPIRV_libSPIRV_SPIRVOpCode.h) = bc0e6685c80e82190f7b327e5ebb5ccf19b3e810
SHA1 (patch-lib_SPIRV_libSPIRV_SPIRVOpCodeEnum.h) = e2a7329fbdcdadbae07334b0c735056837a88121
SHA1 (patch-spirv-headers-tag.conf) = ecfb5efbaceb94672f8cc8e9d6242315c44818bd
SHA1 (patch-test_constexpr__vector.ll) = b4527f06912fa18dc824fc43f5fed433cca84354
SHA1 (patch-test_transcoding_SPV__INTEL__function__pointers_bitcast.ll) = 373852e3963a06e991e231f0c5ab2ae766404410
SHA1 (patch-test_transcoding_SPV__INTEL__function__pointers_const-function-pointer.ll) = f6067833cdcb1620aba9394f9535bde76056c191
SHA1 (patch-test_transcoding_SPV__INTEL__function__pointers_function-pointer.ll) = 4e0ac321159280936fb38b7f16b417cf060cafbd
SHA1 (patch-test_transcoding_SPV__INTEL__function__pointers_global__ctor__dtor.ll) = f11189c9f6df87402dc0cd44015206cbbf0591af
SHA1 (patch-test_transcoding_SPV__INTEL__function__pointers_non-uniform-function-pointer.ll) = 25a6766ee57116d3b8296bfea8c8b8983016a9cd
SHA1 (patch-test_transcoding_SPV__INTEL__function__pointers_select.ll) = 17fc3d504c94a9f88eda183e07e8ec8a2a9e8624
SHA1 (patch-test_transcoding_SPV__INTEL__function__pointers_vector__elem.ll) = c019121148a8d95269ca7b41a0c1c162ae46eed9

View file

@ -1,19 +0,0 @@
$NetBSD: patch-lib_SPIRV_SPIRVReader.cpp,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- lib/SPIRV/SPIRVReader.cpp.orig 2021-10-15 21:15:19.000000000 +0000
+++ lib/SPIRV/SPIRVReader.cpp
@@ -1452,9 +1452,9 @@ Value *SPIRVToLLVM::transValueWithoutDec
return mapValue(BV, transValue(BI, nullptr, nullptr, false));
}
- case OpConstFunctionPointerINTEL: {
- SPIRVConstFunctionPointerINTEL *BC =
- static_cast<SPIRVConstFunctionPointerINTEL *>(BV);
+ case OpConstantFunctionPointerINTEL: {
+ SPIRVConstantFunctionPointerINTEL *BC =
+ static_cast<SPIRVConstantFunctionPointerINTEL *>(BV);
SPIRVFunction *F = BC->getFunction();
BV->setName(F->getName());
return mapValue(BV, transFunction(F));

View file

@ -1,15 +0,0 @@
$NetBSD: patch-lib_SPIRV_SPIRVWriter.cpp,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- lib/SPIRV/SPIRVWriter.cpp.orig 2021-10-15 21:15:19.000000000 +0000
+++ lib/SPIRV/SPIRVWriter.cpp
@@ -1418,7 +1418,7 @@ LLVMToSPIRVBase::transValueWithoutDecora
if (!BM->checkExtension(ExtensionID::SPV_INTEL_function_pointers,
SPIRVEC_FunctionPointers, toString(V)))
return nullptr;
- return BM->addConstFunctionPointerINTEL(
+ return BM->addConstantFunctionPointerINTEL(
transType(F->getType()),
static_cast<SPIRVFunction *>(transValue(F, nullptr)));
}

View file

@ -1,16 +0,0 @@
$NetBSD: patch-lib_SPIRV_SPIRVWriter.h,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- lib/SPIRV/SPIRVWriter.h.orig 2021-10-15 21:15:19.000000000 +0000
+++ lib/SPIRV/SPIRVWriter.h
@@ -75,7 +75,8 @@ public:
// a function, that is necessary for a convenient function pointers handling.
// By default transValue uses 'Decl' mode, which means every function
// we meet during the translation should result in its declaration generated.
- // In 'Pointer' mode we generate OpConstFunctionPointerINTEL constant instead.
+ // In 'Pointer' mode we generate OpConstantFunctionPointerINTEL constant
+ // instead.
enum class FuncTransMode { Decl, Pointer };
SPIRVType *transType(Type *T);

View file

@ -1,30 +0,0 @@
$NetBSD: patch-lib_SPIRV_libSPIRV_SPIRVFunction.h,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- lib/SPIRV/libSPIRV/SPIRVFunction.h.orig 2021-10-15 21:15:19.000000000 +0000
+++ lib/SPIRV/libSPIRV/SPIRVFunction.h
@@ -171,18 +171,18 @@ private:
typedef SPIRVEntryOpCodeOnly<OpFunctionEnd> SPIRVFunctionEnd;
-class SPIRVConstFunctionPointerINTEL : public SPIRVValue {
- const static Op OC = OpConstFunctionPointerINTEL;
+class SPIRVConstantFunctionPointerINTEL : public SPIRVValue {
+ const static Op OC = OpConstantFunctionPointerINTEL;
const static SPIRVWord FixedWordCount = 4;
public:
- SPIRVConstFunctionPointerINTEL(SPIRVId TheId, SPIRVType *TheType,
- SPIRVFunction *TheFunction, SPIRVModule *M)
+ SPIRVConstantFunctionPointerINTEL(SPIRVId TheId, SPIRVType *TheType,
+ SPIRVFunction *TheFunction, SPIRVModule *M)
: SPIRVValue(M, FixedWordCount, OC, TheType, TheId),
TheFunction(TheFunction->getId()) {
validate();
}
- SPIRVConstFunctionPointerINTEL()
+ SPIRVConstantFunctionPointerINTEL()
: SPIRVValue(OC), TheFunction(SPIRVID_INVALID) {}
SPIRVFunction *getFunction() const { return get<SPIRVFunction>(TheFunction); }
_SPIRV_DEF_ENCDEC3(Type, Id, TheFunction)

View file

@ -1,31 +0,0 @@
$NetBSD: patch-lib_SPIRV_libSPIRV_SPIRVModule.cpp,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- lib/SPIRV/libSPIRV/SPIRVModule.cpp.orig 2021-10-15 21:15:19.000000000 +0000
+++ lib/SPIRV/libSPIRV/SPIRVModule.cpp
@@ -269,8 +269,8 @@ public:
const std::vector<SPIRVValue *> &Elements) override;
SPIRVEntry *addSpecConstantCompositeContinuedINTEL(
const std::vector<SPIRVValue *> &) override;
- SPIRVValue *addConstFunctionPointerINTEL(SPIRVType *Ty,
- SPIRVFunction *F) override;
+ SPIRVValue *addConstantFunctionPointerINTEL(SPIRVType *Ty,
+ SPIRVFunction *F) override;
SPIRVValue *addConstant(SPIRVValue *) override;
SPIRVValue *addConstant(SPIRVType *, uint64_t) override;
SPIRVValue *addConstant(SPIRVType *, llvm::APInt) override;
@@ -1142,9 +1142,10 @@ SPIRVEntry *SPIRVModuleImpl::addSpecCons
return add(new SPIRVSpecConstantCompositeContinuedINTEL(this, Elements));
}
-SPIRVValue *SPIRVModuleImpl::addConstFunctionPointerINTEL(SPIRVType *Ty,
- SPIRVFunction *F) {
- return addConstant(new SPIRVConstFunctionPointerINTEL(getId(), Ty, F, this));
+SPIRVValue *SPIRVModuleImpl::addConstantFunctionPointerINTEL(SPIRVType *Ty,
+ SPIRVFunction *F) {
+ return addConstant(
+ new SPIRVConstantFunctionPointerINTEL(getId(), Ty, F, this));
}
SPIRVValue *SPIRVModuleImpl::addUndef(SPIRVType *TheType) {

View file

@ -1,17 +0,0 @@
$NetBSD: patch-lib_SPIRV_libSPIRV_SPIRVModule.h,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- lib/SPIRV/libSPIRV/SPIRVModule.h.orig 2021-10-15 21:15:19.000000000 +0000
+++ lib/SPIRV/libSPIRV/SPIRVModule.h
@@ -263,8 +263,8 @@ public:
const std::vector<SPIRVValue *> &Elements) = 0;
virtual SPIRVEntry *
addSpecConstantCompositeContinuedINTEL(const std::vector<SPIRVValue *> &) = 0;
- virtual SPIRVValue *addConstFunctionPointerINTEL(SPIRVType *Ty,
- SPIRVFunction *F) = 0;
+ virtual SPIRVValue *addConstantFunctionPointerINTEL(SPIRVType *Ty,
+ SPIRVFunction *F) = 0;
virtual SPIRVValue *addConstant(SPIRVValue *) = 0;
virtual SPIRVValue *addConstant(SPIRVType *, uint64_t) = 0;
virtual SPIRVValue *addConstant(SPIRVType *, llvm::APInt) = 0;

View file

@ -1,15 +0,0 @@
$NetBSD: patch-lib_SPIRV_libSPIRV_SPIRVOpCode.h,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- lib/SPIRV/libSPIRV/SPIRVOpCode.h.orig 2021-10-15 21:15:19.000000000 +0000
+++ lib/SPIRV/libSPIRV/SPIRVOpCode.h
@@ -226,7 +226,7 @@ inline bool isSpecConstantOpCode(Op OpCo
inline bool isConstantOpCode(Op OpCode) {
unsigned OC = OpCode;
return (OpConstantTrue <= OC && OC <= OpSpecConstantOp) || OC == OpUndef ||
- OC == OpConstantPipeStorage || OC == OpConstFunctionPointerINTEL;
+ OC == OpConstantPipeStorage || OC == OpConstantFunctionPointerINTEL;
}
inline bool isModuleScopeAllowedOpCode(Op OpCode) {

View file

@ -1,15 +0,0 @@
$NetBSD: patch-lib_SPIRV_libSPIRV_SPIRVOpCodeEnum.h,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- lib/SPIRV/libSPIRV/SPIRVOpCodeEnum.h.orig 2021-10-15 21:15:19.000000000 +0000
+++ lib/SPIRV/libSPIRV/SPIRVOpCodeEnum.h
@@ -344,7 +344,7 @@ _SPIRV_OP(SubgroupImageBlockReadINTEL, 5
_SPIRV_OP(SubgroupImageBlockWriteINTEL, 5578)
_SPIRV_OP(SubgroupImageMediaBlockReadINTEL, 5580)
_SPIRV_OP(SubgroupImageMediaBlockWriteINTEL, 5581)
-_SPIRV_OP(ConstFunctionPointerINTEL, 5600)
+_SPIRV_OP(ConstantFunctionPointerINTEL, 5600)
_SPIRV_OP(FunctionPointerCallINTEL, 5601)
_SPIRV_OP(AsmTargetINTEL, 5609)
_SPIRV_OP(AsmINTEL, 5610)

View file

@ -1,9 +0,0 @@
$NetBSD: patch-spirv-headers-tag.conf,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- spirv-headers-tag.conf.orig 2021-10-15 21:15:19.000000000 +0000
+++ spirv-headers-tag.conf
@@ -1 +1 @@
-ddf3230c14c71e81fc0eae9b781cc4bcc2d1f0f5
+814e728b30ddd0f4509233099a3ad96fd4318c07

View file

@ -1,21 +0,0 @@
$NetBSD: patch-test_constexpr__vector.ll,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- test/constexpr_vector.ll.orig 2021-10-15 21:15:19.000000000 +0000
+++ test/constexpr_vector.ll
@@ -62,10 +62,10 @@
; CHECK-SPIRV-DAG: 4 TypePointer [[StorePtr:[0-9]+]] 7 [[TypeVec16]]
; CHECK-SPIRV-DAG: 3 Undef [[TypeVec16]] [[TypeUndefV16:[0-9]+]]
; CHECK-SPIRV-DAG: 3 Undef [[TypeVec64]] [[TypeUndefV64:[0-9]+]]
-; CHECK-SPIRV-DAG: 4 ConstFunctionPointerINTEL [[FuncPtrTy:[0-9]+]] [[F1Ptr:[0-9]+]] [[F1]]
-; CHECK-SPIRV-DAG: 4 ConstFunctionPointerINTEL [[FuncPtrTy]] [[F2Ptr:[0-9]+]] [[F2]]
-; CHECK-SPIRV-DAG: 4 ConstFunctionPointerINTEL [[FuncPtrTy]] [[F11Ptr:[0-9]+]] [[F1]]
-; CHECK-SPIRV-DAG: 4 ConstFunctionPointerINTEL [[FuncPtrTy]] [[F21Ptr:[0-9]+]] [[F2]]
+; CHECK-SPIRV-DAG: 4 ConstantFunctionPointerINTEL [[FuncPtrTy:[0-9]+]] [[F1Ptr:[0-9]+]] [[F1]]
+; CHECK-SPIRV-DAG: 4 ConstantFunctionPointerINTEL [[FuncPtrTy]] [[F2Ptr:[0-9]+]] [[F2]]
+; CHECK-SPIRV-DAG: 4 ConstantFunctionPointerINTEL [[FuncPtrTy]] [[F11Ptr:[0-9]+]] [[F1]]
+; CHECK-SPIRV-DAG: 4 ConstantFunctionPointerINTEL [[FuncPtrTy]] [[F21Ptr:[0-9]+]] [[F2]]
; CHECK-SPIRV: 4 ConvertPtrToU [[TypeInt64]] [[Ptr1:[0-9]+]] [[F1Ptr]]
; CHECK-SPIRV: 4 Bitcast [[TypeVec8]] [[Vec1:[0-9]+]] [[Ptr1]]

View file

@ -1,15 +0,0 @@
$NetBSD: patch-test_transcoding_SPV__INTEL__function__pointers_bitcast.ll,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- test/transcoding/SPV_INTEL_function_pointers/bitcast.ll.orig 2021-10-15 21:15:19.000000000 +0000
+++ test/transcoding/SPV_INTEL_function_pointers/bitcast.ll
@@ -18,7 +18,7 @@
; CHECK-SPIRV: TypeFunction [[#DEST_TY:]] [[#]] [[#]]
; CHECK-SPIRV: TypePointer [[#DEST_TY_PTR:]] [[#]] [[#DEST_TY]]
; CHECK-SPIRV: TypePointer [[#FOO_TY_PTR:]] [[#]] [[#FOO_TY]]
-; CHECK-SPIRV: ConstFunctionPointerINTEL [[#FOO_TY_PTR]] [[#FOO_PTR:]] [[#FOO:]]
+; CHECK-SPIRV: ConstantFunctionPointerINTEL [[#FOO_TY_PTR]] [[#FOO_PTR:]] [[#FOO:]]
; CHECK-SPIRV: Function [[#]] [[#FOO]] [[#]] [[#FOO_TY]]
; CHECK-SPIRV: Bitcast [[#DEST_TY_PTR]] [[#]] [[#FOO_PTR]]

View file

@ -1,17 +0,0 @@
$NetBSD: patch-test_transcoding_SPV__INTEL__function__pointers_const-function-pointer.ll,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- test/transcoding/SPV_INTEL_function_pointers/const-function-pointer.ll.orig 2021-10-15 21:15:19.000000000 +0000
+++ test/transcoding/SPV_INTEL_function_pointers/const-function-pointer.ll
@@ -14,8 +14,8 @@
; CHECK-SPIRV-DAG: Constant [[Int32]] [[XArg:[0-9]+]] 32
; CHECK-SPIRV-DAG: Constant [[Int32]] [[YArg:[0-9]+]] 2
-; CHECK-SPIRV: ConstFunctionPointerINTEL {{[0-9]+}} [[F1:[0-9]+]] [[F1Name]]
-; CHECK-SPIRV: ConstFunctionPointerINTEL {{[0-9]+}} [[F2:[0-9]+]] [[F2Name]]
+; CHECK-SPIRV: ConstantFunctionPointerINTEL {{[0-9]+}} [[F1:[0-9]+]] [[F1Name]]
+; CHECK-SPIRV: ConstantFunctionPointerINTEL {{[0-9]+}} [[F2:[0-9]+]] [[F2Name]]
; CHECK-SPIRV: ConstantComposite {{[0-9]+}} [[ConstComp:[0-9]+]] [[F1]] [[F2]]
; CHECK-SPIRV: Variable {{[0-9]+}} [[Var:[0-9]+]] {{[0-9]+}} [[ConstComp]]

View file

@ -1,15 +0,0 @@
$NetBSD: patch-test_transcoding_SPV__INTEL__function__pointers_function-pointer.ll,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- test/transcoding/SPV_INTEL_function_pointers/function-pointer.ll.orig 2021-10-15 21:15:19.000000000 +0000
+++ test/transcoding/SPV_INTEL_function_pointers/function-pointer.ll
@@ -24,7 +24,7 @@
; CHECK-SPIRV: TypeFunction [[FOO_TYPE_ID:[0-9]+]] [[TYPE_INT_ID]] [[TYPE_INT_ID]]
; CHECK-SPIRV: TypePointer [[FOO_PTR_ID:[0-9]+]] {{[0-9]+}} [[FOO_TYPE_ID]]
; CHECK-SPIRV: TypePointer [[FOO_PTR_ALLOCA_ID:[0-9]+]] 7 [[FOO_PTR_ID]]
-; CHECK-SPIRV: ConstFunctionPointerINTEL [[FOO_PTR_ID]] [[FOO_PTR:[0-9]+]] [[FOO_ID:[0-9]+]]
+; CHECK-SPIRV: ConstantFunctionPointerINTEL [[FOO_PTR_ID]] [[FOO_PTR:[0-9]+]] [[FOO_ID:[0-9]+]]
;
; CHECK-SPIRV: Function {{[0-9]+}} [[FOO_ID]] {{[0-9]+}} [[FOO_TYPE_ID]]
; CHECK-SPIRV: Function {{[0-9]+}} [[KERNEL_ID]]

View file

@ -1,18 +0,0 @@
$NetBSD: patch-test_transcoding_SPV__INTEL__function__pointers_global__ctor__dtor.ll,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- test/transcoding/SPV_INTEL_function_pointers/global_ctor_dtor.ll.orig 2021-10-15 21:15:19.000000000 +0000
+++ test/transcoding/SPV_INTEL_function_pointers/global_ctor_dtor.ll
@@ -22,9 +22,9 @@ target triple = "spir64-unknown-unknown"
; CHECK: TypeFunction {{[0-9]+}} [[TF:[0-9]+]]
; CHECK: TypePointer [[TP:[0-9]+]]
-; CHECK: ConstFunctionPointerINTEL [[TP]] [[FPCtor:[0-9]+]] [[NameCtor]]
+; CHECK: ConstantFunctionPointerINTEL [[TP]] [[FPCtor:[0-9]+]] [[NameCtor]]
; CHECK: ConstantComposite {{[0-9]+}} {{[0-9]+}} {{[0-9]+}} [[FPCtor]]
-; CHECK: ConstFunctionPointerINTEL [[TP]] [[FPDtor:[0-9]+]] [[NameDtor]]
+; CHECK: ConstantFunctionPointerINTEL [[TP]] [[FPDtor:[0-9]+]] [[NameDtor]]
; CHECK: ConstantComposite {{[0-9]+}} {{[0-9]+}} {{[0-9]+}} [[FPDtor]]
; CHECK: 5 Function [[TF]] [[NameCtor]] 0

View file

@ -1,17 +0,0 @@
$NetBSD: patch-test_transcoding_SPV__INTEL__function__pointers_non-uniform-function-pointer.ll,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- test/transcoding/SPV_INTEL_function_pointers/non-uniform-function-pointer.ll.orig 2021-10-15 21:15:19.000000000 +0000
+++ test/transcoding/SPV_INTEL_function_pointers/non-uniform-function-pointer.ll
@@ -34,8 +34,8 @@
; CHECK-SPIRV: TypeFunction [[FOO_TYPE_ID:[0-9]+]] [[TYPE_INT32_ID]] [[TYPE_INT32_ID]]
; CHECK-SPIRV: TypePointer [[FOO_PTR_TYPE_ID:[0-9]+]] {{[0-9]+}} [[FOO_TYPE_ID]]
; CHECK-SPIRV: TypePointer [[FOO_PTR_ALLOCA_TYPE_ID:[0-9]+]] 7 [[FOO_PTR_TYPE_ID]]
-; CHECK-SPIRV: ConstFunctionPointerINTEL [[FOO_PTR_TYPE_ID]] [[FOO_PTR_ID:[0-9]+]] [[FOO_ID:[0-9]+]]
-; CHECK-SPIRV: ConstFunctionPointerINTEL [[FOO_PTR_TYPE_ID]] [[BAR_PTR_ID:[0-9]+]] [[BAR_ID:[0-9]+]]
+; CHECK-SPIRV: ConstantFunctionPointerINTEL [[FOO_PTR_TYPE_ID]] [[FOO_PTR_ID:[0-9]+]] [[FOO_ID:[0-9]+]]
+; CHECK-SPIRV: ConstantFunctionPointerINTEL [[FOO_PTR_TYPE_ID]] [[BAR_PTR_ID:[0-9]+]] [[BAR_ID:[0-9]+]]
;
; CHECK-SPIRV: Function {{[0-9]+}} [[FOO_ID]] {{[0-9]+}} [[FOO_TYPE_ID]]
; CHECK-SPIRV: Function {{[0-9]+}} [[BAR_ID]] {{[0-9]+}} [[FOO_TYPE_ID]]

View file

@ -1,17 +0,0 @@
$NetBSD: patch-test_transcoding_SPV__INTEL__function__pointers_select.ll,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- test/transcoding/SPV_INTEL_function_pointers/select.ll.orig 2021-10-15 21:15:19.000000000 +0000
+++ test/transcoding/SPV_INTEL_function_pointers/select.ll
@@ -13,8 +13,8 @@
; CHECK-SPIRV: TypeFunction [[#FUNC_TYPE:]] [[#INT32]] [[#INT32]]
; CHECK-SPIRV: TypePointer [[#FUNC_PTR_TYPE:]] [[#]] [[#FUNC_TYPE]]
; CHECK-SPIRV: TypePointer [[#FUNC_PTR_ALLOCA_TYPE:]] [[#]] [[#FUNC_PTR_TYPE]]
-; CHECK-SPIRV-DAG: ConstFunctionPointerINTEL [[#FUNC_PTR_TYPE]] [[#BARPTR:]] [[#BAR]]
-; CHECK-SPIRV-DAG: ConstFunctionPointerINTEL [[#FUNC_PTR_TYPE]] [[#BAZPTR:]] [[#BAZ]]
+; CHECK-SPIRV-DAG: ConstantFunctionPointerINTEL [[#FUNC_PTR_TYPE]] [[#BARPTR:]] [[#BAR]]
+; CHECK-SPIRV-DAG: ConstantFunctionPointerINTEL [[#FUNC_PTR_TYPE]] [[#BAZPTR:]] [[#BAZ]]
; CHECK-SPIRV: Function [[#]] [[#KERNEL_ID]]
; CHECK-SPIRV: Variable [[#FUNC_PTR_ALLOCA_TYPE]] [[#FPTR:]]
; CHECK-SPIRV: Select [[#FUNC_PTR_TYPE]] [[#SELECT:]] [[#]] [[#BARPTR]] [[#BAZPTR]]

View file

@ -1,17 +0,0 @@
$NetBSD: patch-test_transcoding_SPV__INTEL__function__pointers_vector__elem.ll,v 1.1 2021/11/23 20:55:44 wiz Exp $
https://github.com/KhronosGroup/SPIRV-LLVM-Translator/pull/1265
--- test/transcoding/SPV_INTEL_function_pointers/vector_elem.ll.orig 2021-10-15 21:15:19.000000000 +0000
+++ test/transcoding/SPV_INTEL_function_pointers/vector_elem.ll
@@ -9,8 +9,8 @@
; CHECK-SPIRV: 4 TypePointer [[TypePtr:[0-9]+]] {{[0-9]+}} [[TypeFunc]]
; CHECK-SPIRV: 4 TypeVector [[TypeVec:[0-9]+]] [[TypePtr]] [[TypeInt32]]
; CHECK-SPIRV-DAG: 3 Undef [[TypeVec]] [[TypeUndef:[0-9]+]]
-; CHECK-SPIRV-DAG: 4 ConstFunctionPointerINTEL [[TypePtr]] [[F1Ptr:[0-9]+]] [[F1]]
-; CHECK-SPIRV-DAG: 4 ConstFunctionPointerINTEL [[TypePtr]] [[F2Ptr:[0-9]+]] [[F2]]
+; CHECK-SPIRV-DAG: 4 ConstantFunctionPointerINTEL [[TypePtr]] [[F1Ptr:[0-9]+]] [[F1]]
+; CHECK-SPIRV-DAG: 4 ConstantFunctionPointerINTEL [[TypePtr]] [[F2Ptr:[0-9]+]] [[F2]]
; CHECK-SPIRV: 6 CompositeInsert [[TypeVec]] [[NewVec0:[0-9]+]] [[F1Ptr]] [[TypeUndef]] 0
; CHECK-SPIRV: 6 CompositeInsert [[TypeVec]] [[NewVec1:[0-9]+]] [[F2Ptr]] [[NewVec0]] 1