Update to 1.2.8:

* Version 1.2.8 (2005-10-07)
- Libgcrypt 1.2.2 is required to fix a bug for forking GnuTLS servers.
- Don't install the auxilliary libexamples library used by the
  examples in doc/examples/ on "make install", report and tiny patch
  from Thomas Klausner
- If you pass a X.509 CA or PGP trust database to the command line
  tool, it will now abort the connection if the server certificate
  validation fails.  Use the parameter --insecure to continue even
  after certificate validation failures.  Inspired from discussion
  with Alexander Kotelnikov
- The test for socklen_t has been moved to gnulib.
- Link failures for duplicate or missing "program_name" symbol has been fixed,
  patch from Martin Lambers
- The command line tool and the examples no longer uses mmap or bzero,
  to make them more portable, patch from Martin Lambers
- Made the PKCS #12 API handle null passwords. Based on patch by
  Anton Altaparmakov
- The GTK-DOC manual should build with current released tools.
  (But a copy of the output is included, so the tools are not required.)
- API and ABI modifications:
  No changes since last version.
This commit is contained in:
wiz 2005-10-20 00:43:32 +00:00
parent 19cf9f3f63
commit 7317db7a85
5 changed files with 13 additions and 153 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.34 2005/09/30 13:11:34 wiz Exp $
# $NetBSD: Makefile,v 1.35 2005/10/20 00:43:32 wiz Exp $
DISTNAME= gnutls-1.2.7
DISTNAME= gnutls-1.2.8
CATEGORIES= security devel
MASTER_SITES= http://josefsson.org/gnutls/releases/ \
ftp://ftp.gnutls.org/pub/gnutls/ \
@ -16,6 +16,7 @@ COMMENT= GNU Transport Layer Security library
PKG_INSTALLATION_TYPES= overwrite pkgviews
USE_LIBTOOL= yes
USE_TOOLS= gmake
GNU_CONFIGURE= yes
TEST_TARGET= check
@ -26,8 +27,9 @@ PKGCONFIG_OVERRIDE+= libextra/gnutls-extra.pc.in
BUILDLINK_DEPENDS.opencdk= opencdk>=0.5.5
BUILDLINK_DEPENDS.libtasn1= libtasn1>=0.2.11
BUILDLINK_DEPENDS.libgcrypt= libgcrypt>=1.2.2
MAKE_ENV+= RM="${RM}"
MAKE_ENV+= RM=${RM:Q}
MAKE_ENV+= TZ=UTC
DOCDIR= ${PREFIX}/share/doc/gnutls

View file

@ -1,8 +1,6 @@
$NetBSD: distinfo,v 1.20 2005/09/30 13:11:34 wiz Exp $
$NetBSD: distinfo,v 1.21 2005/10/20 00:43:32 wiz Exp $
SHA1 (gnutls-1.2.7.tar.bz2) = c1a583052a16521363d0dab5615bfc547f291fca
RMD160 (gnutls-1.2.7.tar.bz2) = d41db9a202cac17d71f6eb1b9546970bd8d091cc
Size (gnutls-1.2.7.tar.bz2) = 2525612 bytes
SHA1 (patch-aa) = a5b5c3fd69cf37cf3da31c6303499bc361dd0826
SHA1 (patch-ab) = 91673a4ae323d002f75aed63d4a41e1c42f866ad
SHA1 (patch-ac) = 772702e006ffb30913584a050581b4512fac3cb3
SHA1 (gnutls-1.2.8.tar.bz2) = b49c86de7c10946bf440ea146f89a31474297872
RMD160 (gnutls-1.2.8.tar.bz2) = efd431cffe74a4cf539d6dbb272ae158b71e0710
Size (gnutls-1.2.8.tar.bz2) = 2527436 bytes
SHA1 (patch-ab) = df9d588891ff88c41f297fa595d618c31dc8ef97

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.5 2005/09/30 13:11:34 wiz Exp $
--- doc/examples/Makefile.am.orig 2005-08-24 00:51:41.000000000 +0200
+++ doc/examples/Makefile.am
@@ -28,7 +28,7 @@ noinst_PROGRAMS = ex-cert-select ex-clie
ex-client-resume ex-client-srp ex-crq ex-serv1 ex-serv-anon \
ex-serv-export ex-serv-pgp ex-serv-srp
-lib_LTLIBRARIES = libexamples.la
+noinst_LTLIBRARIES = libexamples.la
libexamples_la_SOURCES = ex-alert.c ex-pkcs12.c ex-rfc2818.c \
ex-session-info.c ex-x509-info.c ex-verify.c tcp.c

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.3 2005/09/30 13:11:34 wiz Exp $
$NetBSD: patch-ab,v 1.4 2005/10/20 00:43:32 wiz Exp $
--- doc/Makefile.in.orig 2005-09-30 14:32:44.000000000 +0200
--- doc/Makefile.in.orig 2005-10-07 13:26:30.000000000 +0200
+++ doc/Makefile.in
@@ -385,7 +385,7 @@ gnutls.dvi: gnutls.texi $(srcdir)/versio
@@ -387,7 +387,7 @@ gnutls.dvi: gnutls.texi $(srcdir)/versio
gnutls.pdf: gnutls.texi $(srcdir)/version.texi $(gnutls_TEXINFOS)
gnutls.html: gnutls.texi $(srcdir)/version.texi $(gnutls_TEXINFOS)
$(srcdir)/version.texi: $(srcdir)/stamp-vti

View file

@ -1,127 +0,0 @@
$NetBSD: patch-ac,v 1.1 2005/09/30 13:11:34 wiz Exp $
--- doc/examples/Makefile.in.orig 2005-09-08 15:41:05.000000000 +0200
+++ doc/examples/Makefile.in
@@ -95,15 +95,7 @@ am__configure_deps = $(am__aclocal_m4_de
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
-am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
-am__vpath_adj = case $$p in \
- $(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
- *) f=$$p;; \
- esac;
-am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
-am__installdirs = "$(DESTDIR)$(libdir)"
-libLTLIBRARIES_INSTALL = $(INSTALL)
-LTLIBRARIES = $(lib_LTLIBRARIES)
+LTLIBRARIES = $(noinst_LTLIBRARIES)
libexamples_la_LIBADD =
am_libexamples_la_OBJECTS = ex-alert.lo ex-pkcs12.lo ex-rfc2818.lo \
ex-session-info.lo ex-x509-info.lo ex-verify.lo tcp.lo
@@ -349,7 +341,7 @@ LDADD = libexamples.la \
../../lib/libgnutls.la \
../../libextra/libgnutls-extra.la
-lib_LTLIBRARIES = libexamples.la
+noinst_LTLIBRARIES = libexamples.la
libexamples_la_SOURCES = ex-alert.c ex-pkcs12.c ex-rfc2818.c \
ex-session-info.c ex-x509-info.c ex-verify.c tcp.c
@@ -386,35 +378,17 @@ $(top_srcdir)/configure: $(am__configur
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
$(ACLOCAL_M4): $(am__aclocal_m4_deps)
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
-install-libLTLIBRARIES: $(lib_LTLIBRARIES)
- @$(NORMAL_INSTALL)
- test -z "$(libdir)" || $(mkdir_p) "$(DESTDIR)$(libdir)"
- @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
- if test -f $$p; then \
- f=$(am__strip_dir) \
- echo " $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(libdir)/$$f'"; \
- $(LIBTOOL) --mode=install $(libLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(libdir)/$$f"; \
- else :; fi; \
- done
-
-uninstall-libLTLIBRARIES:
- @$(NORMAL_UNINSTALL)
- @set -x; list='$(lib_LTLIBRARIES)'; for p in $$list; do \
- p=$(am__strip_dir) \
- echo " $(LIBTOOL) --mode=uninstall rm -f '$(DESTDIR)$(libdir)/$$p'"; \
- $(LIBTOOL) --mode=uninstall rm -f "$(DESTDIR)$(libdir)/$$p"; \
- done
-clean-libLTLIBRARIES:
- -test -z "$(lib_LTLIBRARIES)" || rm -f $(lib_LTLIBRARIES)
- @list='$(lib_LTLIBRARIES)'; for p in $$list; do \
+clean-noinstLTLIBRARIES:
+ -test -z "$(noinst_LTLIBRARIES)" || rm -f $(noinst_LTLIBRARIES)
+ @list='$(noinst_LTLIBRARIES)'; for p in $$list; do \
dir="`echo $$p | sed -e 's|/[^/]*$$||'`"; \
test "$$dir" != "$$p" || dir=.; \
echo "rm -f \"$${dir}/so_locations\""; \
rm -f "$${dir}/so_locations"; \
done
libexamples.la: $(libexamples_la_OBJECTS) $(libexamples_la_DEPENDENCIES)
- $(LINK) -rpath $(libdir) $(libexamples_la_LDFLAGS) $(libexamples_la_OBJECTS) $(libexamples_la_LIBADD) $(LIBS)
+ $(LINK) $(libexamples_la_LDFLAGS) $(libexamples_la_OBJECTS) $(libexamples_la_LIBADD) $(LIBS)
clean-noinstPROGRAMS:
@list='$(noinst_PROGRAMS)'; for p in $$list; do \
@@ -591,9 +565,6 @@ check-am: all-am
check: check-am
all-am: Makefile $(LTLIBRARIES) $(PROGRAMS)
installdirs:
- for dir in "$(DESTDIR)$(libdir)"; do \
- test -z "$$dir" || $(mkdir_p) "$$dir"; \
- done
install: install-am
install-exec: install-exec-am
install-data: install-data-am
@@ -620,7 +591,7 @@ maintainer-clean-generic:
@echo "it deletes files that may require special tools to rebuild."
clean: clean-am
-clean-am: clean-generic clean-libLTLIBRARIES clean-libtool \
+clean-am: clean-generic clean-libtool clean-noinstLTLIBRARIES \
clean-noinstPROGRAMS mostlyclean-am
distclean: distclean-am
@@ -641,7 +612,7 @@ info-am:
install-data-am:
-install-exec-am: install-libLTLIBRARIES
+install-exec-am:
install-info: install-info-am
@@ -667,20 +638,19 @@ ps: ps-am
ps-am:
-uninstall-am: uninstall-info-am uninstall-libLTLIBRARIES
+uninstall-am: uninstall-info-am
.PHONY: CTAGS GTAGS all all-am check check-am clean clean-generic \
- clean-libLTLIBRARIES clean-libtool clean-noinstPROGRAMS ctags \
- distclean distclean-compile distclean-generic \
+ clean-libtool clean-noinstLTLIBRARIES clean-noinstPROGRAMS \
+ ctags distclean distclean-compile distclean-generic \
distclean-libtool distclean-tags distdir dvi dvi-am html \
html-am info info-am install install-am install-data \
install-data-am install-exec install-exec-am install-info \
- install-info-am install-libLTLIBRARIES install-man \
- install-strip installcheck installcheck-am installdirs \
- maintainer-clean maintainer-clean-generic mostlyclean \
- mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
- pdf pdf-am ps ps-am tags uninstall uninstall-am \
- uninstall-info-am uninstall-libLTLIBRARIES
+ install-info-am install-man install-strip installcheck \
+ installcheck-am installdirs maintainer-clean \
+ maintainer-clean-generic mostlyclean mostlyclean-compile \
+ mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
+ tags uninstall uninstall-am uninstall-info-am
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.