Second try, this time with testing whether the fix works.

This commit is contained in:
rillig 2007-11-17 14:14:01 +00:00
parent bea05be913
commit 737de34270
2 changed files with 15 additions and 8 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.21 2007/11/17 14:08:35 rillig Exp $
$NetBSD: distinfo,v 1.22 2007/11/17 14:14:01 rillig Exp $
SHA1 (dia-0.96.1.tar.gz) = 25efddb44cf78e94555ce31e9b36645a9aa7c8b9
RMD160 (dia-0.96.1.tar.gz) = b876a9e3760be1774bc0e69ab35d9a7f02a03ae0
@ -9,4 +9,4 @@ SHA1 (patch-be) = dab7626daefcd702b31f54d198311d9be921e1ff
SHA1 (patch-ca) = 48617d334d852253f858176bbe9222f61d379c37
SHA1 (patch-cb) = fab6a63d25781fa9ab7c6a4f6e5ff43ff29aec6e
SHA1 (patch-cc) = f2c58551d31ec577d25f9dfc62f48f28845d2dd7
SHA1 (patch-da) = b9ad90926447183d52e2e43be0901fe98ca78efe
SHA1 (patch-da) = e61d7adeec3b1e5edffa422904551f686d9c7b8b

View file

@ -1,14 +1,21 @@
$NetBSD: patch-da,v 1.1 2007/11/17 14:08:36 rillig Exp $
$NetBSD: patch-da,v 1.2 2007/11/17 14:14:01 rillig Exp $
Some shells don't like syntactically empty "for" loops.
--- omf.make.orig 2007-01-06 23:39:36.000000000 +0100
+++ omf.make 2007-11-17 15:07:19.000000000 +0100
@@ -44,6 +44,7 @@ omf_timestamp: $(omffile)
+++ omf.make 2007-11-17 15:12:01.000000000 +0100
@@ -44,11 +44,10 @@ omf_timestamp: $(omffile)
install-data-hook-omf:
$(mkinstalldirs) $(DESTDIR)$(omf_dest_dir)
+ test "$(omffile)" || exit 0; \
if test "$(omffile)"; then \
for file in $(omffile); do \
- if test "$(omffile)"; then \
- for file in $(omffile); do \
+ omffile="$(omffile)"; \
+ for file in $$omffile; do \
$(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \
- done; \
- fi
+ done
-scrollkeeper-update -p $(scrollkeeper_localstate_dir) -o $(DESTDIR)$(omf_dest_dir)
uninstall-local-omf: