Fix namespace placement of operator <<.

This commit is contained in:
joerg 2012-11-18 01:53:07 +00:00
parent e4b78c1edb
commit 73bc50df05
3 changed files with 54 additions and 1 deletions

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.4 2011/07/28 22:24:16 pettai Exp $
$NetBSD: distinfo,v 1.5 2012/11/18 01:53:07 joerg Exp $
SHA1 (xmltooling-1.4.2.tar.gz) = 599d3ba098bb615df1d1ac063f1ebda67613ac7f
RMD160 (xmltooling-1.4.2.tar.gz) = 84749fc8e26bc8c315a704e1d31e90d3e512ebd1
Size (xmltooling-1.4.2.tar.gz) = 636598 bytes
SHA1 (patch-xmltooling_Makefile.in) = 9c6764c89d0c81c46486283063e02791c22c37e2
SHA1 (patch-xmltooling_util_XMLHelper.cpp) = 2dc0915af93e4b2aeb0a946ea14f2de89050867f
SHA1 (patch-xmltooling_util_XMLHelper.h) = 98c6c0552c81a8599c5337642bcdcaa9cdb76d80

View file

@ -0,0 +1,13 @@
$NetBSD: patch-xmltooling_util_XMLHelper.cpp,v 1.1 2012/11/18 01:53:07 joerg Exp $
--- xmltooling/util/XMLHelper.cpp.orig 2012-11-18 00:26:45.000000000 +0000
+++ xmltooling/util/XMLHelper.cpp
@@ -440,7 +440,7 @@ ostream& XMLHelper::serialize(const DOMN
return out;
}
-ostream& xmltooling::operator<<(ostream& ostr, const DOMNode& node)
+ostream& xercesc_3_1::operator<<(ostream& ostr, const DOMNode& node)
{
return XMLHelper::serialize(&node, ostr);
}

View file

@ -0,0 +1,38 @@
$NetBSD: patch-xmltooling_util_XMLHelper.h,v 1.1 2012/11/18 01:53:07 joerg Exp $
--- xmltooling/util/XMLHelper.h.orig 2012-11-18 00:23:44.000000000 +0000
+++ xmltooling/util/XMLHelper.h
@@ -352,16 +352,6 @@ namespace xmltooling {
};
/**
- * Serializes the DOM node provided to a stream using UTF-8 encoding and
- * the default XML serializer available. No manipulation or formatting is applied.
- *
- * @param n node to serialize
- * @param ostr stream to serialize element into
- * @return reference to output stream
- */
- extern XMLTOOL_API std::ostream& operator<<(std::ostream& ostr, const xercesc::DOMNode& n);
-
- /**
* Marshalls and serializes the XMLObject provided to a stream using UTF-8 encoding and
* the default XML serializer available. No manipulation or formatting is applied.
*
@@ -374,4 +364,16 @@ namespace xmltooling {
extern XMLTOOL_API std::ostream& operator<<(std::ostream& ostr, const XMLObject& obj);
};
+namespace xercesc_3_1 {
+ /**
+ * Serializes the DOM node provided to a stream using UTF-8 encoding and
+ * the default XML serializer available. No manipulation or formatting is applied.
+ *
+ * @param n node to serialize
+ * @param ostr stream to serialize element into
+ * @return reference to output stream
+ */
+ extern XMLTOOL_API std::ostream& operator<<(std::ostream& ostr, const xercesc::DOMNode& n);
+};
+
#endif /* __xmltooling_xmlhelper_h__ */