Restore argp patches. They haven't changed at all and they are still
needed.
This commit is contained in:
parent
4f460522dd
commit
74471d7b77
3 changed files with 70 additions and 1 deletions
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.28 2013/09/08 03:38:52 manu Exp $
|
||||
$NetBSD: distinfo,v 1.29 2013/09/15 12:29:21 joerg Exp $
|
||||
|
||||
SHA1 (glusterfs-3.4.0.tar.gz) = 8795bcb309730c173a226c8cb1e08587e56ea692
|
||||
RMD160 (glusterfs-3.4.0.tar.gz) = 15a290ad890541ec365134eb998e5f0ec48d3bbc
|
||||
Size (glusterfs-3.4.0.tar.gz) = 3774842 bytes
|
||||
SHA1 (patch-argp-standalone_argp-fmtstream.c) = 241873f41bb774e1de4f777227c38b0dcae4ac59
|
||||
SHA1 (patch-argp-standalone_argp-fmtstream.h) = 9f2ead2a11c35fcc6347977082fa347343fccab2
|
||||
SHA1 (patch-libglusterfs_src_glusterfs.h) = 59a0523652628ed24641d63a926f5e33b33bc802
|
||||
|
|
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-argp-standalone_argp-fmtstream.c,v 1.3 2013/09/15 12:29:21 joerg Exp $
|
||||
|
||||
--- argp-standalone/argp-fmtstream.c.orig 2013-07-12 17:43:25.000000000 +0000
|
||||
+++ argp-standalone/argp-fmtstream.c
|
||||
@@ -389,6 +389,7 @@ __argp_fmtstream_printf (struct argp_fmt
|
||||
weak_alias (__argp_fmtstream_printf, argp_fmtstream_printf)
|
||||
#endif
|
||||
|
||||
+#if __STDC_VERSION__ - 199900L < 1
|
||||
/* Duplicate the inline definitions in argp-fmtstream.h, for compilers
|
||||
* that don't do inlining. */
|
||||
size_t
|
||||
@@ -471,5 +472,6 @@ __argp_fmtstream_point (argp_fmtstream_t
|
||||
__argp_fmtstream_update (__fs);
|
||||
return __fs->point_col >= 0 ? __fs->point_col : 0;
|
||||
}
|
||||
+#endif
|
||||
|
||||
#endif /* !ARGP_FMTSTREAM_USE_LINEWRAP */
|
|
@ -0,0 +1,48 @@
|
|||
$NetBSD: patch-argp-standalone_argp-fmtstream.h,v 1.3 2013/09/15 12:29:21 joerg Exp $
|
||||
|
||||
--- argp-standalone/argp-fmtstream.h.orig 2013-07-12 17:43:25.000000000 +0000
|
||||
+++ argp-standalone/argp-fmtstream.h
|
||||
@@ -153,6 +153,7 @@ extern ssize_t argp_fmtstream_printf (ar
|
||||
__const char *__fmt, ...)
|
||||
PRINTF_STYLE(2,3);
|
||||
|
||||
+#if 0
|
||||
extern int __argp_fmtstream_putc (argp_fmtstream_t __fs, int __ch);
|
||||
extern int argp_fmtstream_putc (argp_fmtstream_t __fs, int __ch);
|
||||
|
||||
@@ -163,6 +164,7 @@ extern size_t __argp_fmtstream_write (ar
|
||||
__const char *__str, size_t __len);
|
||||
extern size_t argp_fmtstream_write (argp_fmtstream_t __fs,
|
||||
__const char *__str, size_t __len);
|
||||
+#endif
|
||||
|
||||
/* Access macros for various bits of state. */
|
||||
#define argp_fmtstream_lmargin(__fs) ((__fs)->lmargin)
|
||||
@@ -172,6 +174,7 @@ extern size_t argp_fmtstream_write (argp
|
||||
#define __argp_fmtstream_rmargin argp_fmtstream_rmargin
|
||||
#define __argp_fmtstream_wmargin argp_fmtstream_wmargin
|
||||
|
||||
+#if 0
|
||||
/* Set __FS's left margin to LMARGIN and return the old value. */
|
||||
extern size_t argp_fmtstream_set_lmargin (argp_fmtstream_t __fs,
|
||||
size_t __lmargin);
|
||||
@@ -193,6 +196,7 @@ extern size_t __argp_fmtstream_set_wmarg
|
||||
/* Return the column number of the current output point in __FS. */
|
||||
extern size_t argp_fmtstream_point (argp_fmtstream_t __fs);
|
||||
extern size_t __argp_fmtstream_point (argp_fmtstream_t __fs);
|
||||
+#endif
|
||||
|
||||
/* Internal routines. */
|
||||
extern void _argp_fmtstream_update (argp_fmtstream_t __fs);
|
||||
@@ -216,7 +220,11 @@ extern int __argp_fmtstream_ensure (argp
|
||||
#endif
|
||||
|
||||
#ifndef ARGP_FS_EI
|
||||
+#if defined(__GNUC__) && !defined(__GNUC_STDC_INLINE__)
|
||||
#define ARGP_FS_EI extern inline
|
||||
+#else
|
||||
+#define ARGP_FS_EI inline
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
ARGP_FS_EI size_t
|
Loading…
Reference in a new issue