Import polarssl-1.2.0 as security/polarssl.
PolarSSL is an SSL library written in ANSI C. PolarSSL makes it easy for developers to include cryptographic and SSL/TLS capabilities in their (embedded) products with as little hassle as possible. It is designed to be readable, documented, tested, loosely coupled and portable. This package includes headers/libs only, not the demo programs. PolarSSL is GPLv2, but offers exceptions to be distributed with other works licensed as Apache, BSD, CC0, EUPL, LGPL, ISC, WTFPL, X11, zlib/libpng.
This commit is contained in:
parent
a696eda828
commit
7451fffa94
6 changed files with 144 additions and 0 deletions
9
security/polarssl/DESCR
Normal file
9
security/polarssl/DESCR
Normal file
|
@ -0,0 +1,9 @@
|
|||
PolarSSL is an SSL library written in ANSI C. PolarSSL makes it easy for
|
||||
developers to include cryptographic and SSL/TLS capabilities in their
|
||||
(embedded) products with as little hassle as possible. It is designed to be
|
||||
readable, documented, tested, loosely coupled and portable.
|
||||
|
||||
This package includes headers/libs only, not the demo programs.
|
||||
|
||||
PolarSSL is GPLv2, but offers exceptions to be distributed with other works
|
||||
licensed as Apache, BSD, CC0, EUPL, LGPL, ISC, WTFPL, X11, zlib/libpng.
|
22
security/polarssl/Makefile
Normal file
22
security/polarssl/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# $NetBSD: Makefile,v 1.1 2012/12/11 23:29:27 gdt Exp $
|
||||
#
|
||||
|
||||
DISTNAME= polarssl-1.2.0-gpl
|
||||
PKGNAME= ${DISTNAME:-gpl=}
|
||||
CATEGORIES= security devel
|
||||
MASTER_SITES= http://polarssl.org/code/releases/
|
||||
EXTRACT_SUFX= .tgz
|
||||
FETCH_USING= curl
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://polarssl.org/
|
||||
COMMENT= Lightweight, modular cryptographic and SSL/TLS library
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
|
||||
USE_TOOLS+= gmake perl
|
||||
REPLACE_PERL= tests/scripts/*.pl
|
||||
USE_LANGUAGES= c
|
||||
TEST_TARGET= check
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
46
security/polarssl/PLIST
Normal file
46
security/polarssl/PLIST
Normal file
|
@ -0,0 +1,46 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2012/12/11 23:29:27 gdt Exp $
|
||||
include/polarssl/aes.h
|
||||
include/polarssl/arc4.h
|
||||
include/polarssl/asn1.h
|
||||
include/polarssl/asn1write.h
|
||||
include/polarssl/base64.h
|
||||
include/polarssl/bignum.h
|
||||
include/polarssl/blowfish.h
|
||||
include/polarssl/bn_mul.h
|
||||
include/polarssl/camellia.h
|
||||
include/polarssl/certs.h
|
||||
include/polarssl/cipher.h
|
||||
include/polarssl/cipher_wrap.h
|
||||
include/polarssl/config.h
|
||||
include/polarssl/ctr_drbg.h
|
||||
include/polarssl/debug.h
|
||||
include/polarssl/des.h
|
||||
include/polarssl/dhm.h
|
||||
include/polarssl/entropy.h
|
||||
include/polarssl/entropy_poll.h
|
||||
include/polarssl/error.h
|
||||
include/polarssl/gcm.h
|
||||
include/polarssl/havege.h
|
||||
include/polarssl/md.h
|
||||
include/polarssl/md2.h
|
||||
include/polarssl/md4.h
|
||||
include/polarssl/md5.h
|
||||
include/polarssl/md_wrap.h
|
||||
include/polarssl/net.h
|
||||
include/polarssl/openssl.h
|
||||
include/polarssl/padlock.h
|
||||
include/polarssl/pbkdf2.h
|
||||
include/polarssl/pem.h
|
||||
include/polarssl/pkcs11.h
|
||||
include/polarssl/rsa.h
|
||||
include/polarssl/sha1.h
|
||||
include/polarssl/sha2.h
|
||||
include/polarssl/sha4.h
|
||||
include/polarssl/ssl.h
|
||||
include/polarssl/ssl_cache.h
|
||||
include/polarssl/timing.h
|
||||
include/polarssl/version.h
|
||||
include/polarssl/x509.h
|
||||
include/polarssl/x509write.h
|
||||
include/polarssl/xtea.h
|
||||
lib/libpolarssl.a
|
13
security/polarssl/buildlink3.mk
Normal file
13
security/polarssl/buildlink3.mk
Normal file
|
@ -0,0 +1,13 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2012/12/11 23:29:27 gdt Exp $
|
||||
|
||||
BUILDLINK_TREE+= polarssl
|
||||
|
||||
.if !defined(POLARSSL_BUILDLINK3_MK)
|
||||
POLARSSL_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.polarssl+= polarssl>=0.10.0
|
||||
BUILDLINK_PKGSRCDIR.polarssl?= ../../security/polarssl
|
||||
|
||||
.endif # POLARSSL_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -polarssl
|
6
security/polarssl/distinfo
Normal file
6
security/polarssl/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2012/12/11 23:29:27 gdt Exp $
|
||||
|
||||
SHA1 (polarssl-1.2.0-gpl.tgz) = e7a9d3897c656feafdd48eb1a9836ee81a58a741
|
||||
RMD160 (polarssl-1.2.0-gpl.tgz) = 74137580162a7293b61205c3dcaf4b802815b8f7
|
||||
Size (polarssl-1.2.0-gpl.tgz) = 973427 bytes
|
||||
SHA1 (patch-Makefile) = c0d015a0b35d8a0394503d4e66897c14e76cfd0b
|
48
security/polarssl/patches/patch-Makefile
Normal file
48
security/polarssl/patches/patch-Makefile
Normal file
|
@ -0,0 +1,48 @@
|
|||
$NetBSD: patch-Makefile,v 1.1 2012/12/11 23:29:28 gdt Exp $
|
||||
|
||||
Fix DESTDIR for pkgsrc, and suppress building test programs.
|
||||
--- Makefile.orig 2012-04-05 07:07:50.000000000 -0500
|
||||
+++ Makefile 2012-11-14 23:27:47.000000000 -0600
|
||||
@@ -1,37 +1,24 @@
|
||||
-
|
||||
-DESTDIR=/usr/local
|
||||
-PREFIX=polarssl_
|
||||
+APPNAME_PRE=polarssl_
|
||||
|
||||
.SILENT:
|
||||
|
||||
all:
|
||||
cd library && $(MAKE) all && cd ..
|
||||
- cd programs && $(MAKE) all && cd ..
|
||||
cd tests && $(MAKE) all && cd ..
|
||||
|
||||
no_test:
|
||||
cd library && $(MAKE) all && cd ..
|
||||
- cd programs && $(MAKE) all && cd ..
|
||||
|
||||
lib:
|
||||
cd library && $(MAKE) all && cd ..
|
||||
|
||||
install:
|
||||
- mkdir -p $(DESTDIR)/include/polarssl
|
||||
- cp -r include/polarssl $(DESTDIR)/include
|
||||
+ mkdir -p ${DESTDIR}${PREFIX}/include/polarssl
|
||||
+ cp -r include/polarssl ${DESTDIR}${PREFIX}/include
|
||||
|
||||
- mkdir -p $(DESTDIR)/lib
|
||||
- cp library/libpolarssl.* $(DESTDIR)/lib
|
||||
+ mkdir -p ${DESTDIR}${PREFIX}/lib
|
||||
+ cp library/libpolarssl.* ${DESTDIR}${PREFIX}/lib
|
||||
|
||||
- mkdir -p $(DESTDIR)/bin
|
||||
- for p in programs/*/* ; do \
|
||||
- if [ -x $$p ] && [ ! -d $$p ] ; \
|
||||
- then \
|
||||
- f=$(PREFIX)`basename $$p` ; \
|
||||
- cp $$p $(DESTDIR)/bin/$$f ; \
|
||||
- fi \
|
||||
- done
|
||||
-
|
||||
clean:
|
||||
cd library && $(MAKE) clean && cd ..
|
||||
cd programs && $(MAKE) clean && cd ..
|
Loading…
Reference in a new issue