Fix messed up configure.sh.
This commit is contained in:
parent
c991ce276a
commit
7455acbd8c
2 changed files with 48 additions and 1 deletions
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2012/01/08 02:27:48 schmonz Exp $
|
||||
$NetBSD: distinfo,v 1.2 2012/04/19 21:05:45 joerg Exp $
|
||||
|
||||
SHA1 (Text-Markdown-Discount-0.02.tar.gz) = 101ec221011ef099599e90bec5ae0f0cea6c6e25
|
||||
RMD160 (Text-Markdown-Discount-0.02.tar.gz) = 29b4b24d76c1687ddd48568ae674b87acd8b1b20
|
||||
Size (Text-Markdown-Discount-0.02.tar.gz) = 180943 bytes
|
||||
SHA1 (patch-configure.sh) = 046ca124f1db6e659f9d950c1bda5ecb570d4224
|
||||
|
|
|
@ -0,0 +1,46 @@
|
|||
$NetBSD: patch-configure.sh,v 1.1 2012/04/19 21:05:46 joerg Exp $
|
||||
|
||||
--- discount-2.1.2/configure.sh.orig 2012-04-19 14:00:16.000000000 +0000
|
||||
+++ discount-2.1.2/configure.sh
|
||||
@@ -76,11 +76,11 @@ AC_C_INLINE
|
||||
AC_SCALAR_TYPES sub hdr
|
||||
AC_CHECK_BASENAME
|
||||
|
||||
-AC_CHECK_HEADERS sys/types.h pwd.h && AC_CHECK_FUNCS getpwuid
|
||||
+AC_CHECK_HEADERS sys/types.h pwd.h && AC_CHECK_FUNCS 'getpwuid(0)'
|
||||
|
||||
-if AC_CHECK_FUNCS srandom; then
|
||||
+if AC_CHECK_FUNCS 'srandom(0)'; then
|
||||
AC_DEFINE 'INITRNG(x)' 'srandom((unsigned int)x)'
|
||||
-elif AC_CHECK_FUNCS srand; then
|
||||
+elif AC_CHECK_FUNCS 'srand(0)'; then
|
||||
AC_DEFINE 'INITRNG(x)' 'srand((unsigned int)x)'
|
||||
else
|
||||
AC_DEFINE 'INITRNG(x)' '(void)1'
|
||||
@@ -102,7 +102,7 @@ else
|
||||
AC_DEFINE 'COINTOSS()' '1'
|
||||
fi
|
||||
|
||||
-if AC_CHECK_FUNCS strcasecmp; then
|
||||
+if AC_CHECK_FUNCS 'strcasecmp("X", "x")'; then
|
||||
:
|
||||
elif AC_CHECK_FUNCS stricmp; then
|
||||
AC_DEFINE strcasecmp stricmp
|
||||
@@ -110,7 +110,7 @@ else
|
||||
AC_FAIL "$TARGET requires either strcasecmp() or stricmp()"
|
||||
fi
|
||||
|
||||
-if AC_CHECK_FUNCS strncasecmp; then
|
||||
+if AC_CHECK_FUNCS 'strncasecmp("X", "x", 1)'; then
|
||||
:
|
||||
elif AC_CHECK_FUNCS strnicmp; then
|
||||
AC_DEFINE strncasecmp strnicmp
|
||||
@@ -118,7 +118,7 @@ else
|
||||
AC_FAIL "$TARGET requires either strncasecmp() or strnicmp()"
|
||||
fi
|
||||
|
||||
-if AC_CHECK_FUNCS fchdir || AC_CHECK_FUNCS getcwd ; then
|
||||
+if AC_CHECK_FUNCS 'fchdir(0)' || AC_CHECK_FUNCS 'getcwd((char *)0, 0)'; then
|
||||
AC_SUB 'THEME' ''
|
||||
else
|
||||
AC_SUB 'THEME' '#'
|
Loading…
Reference in a new issue