easy-rsa: updated to 3.0.5

3.0.5:
Fix: use AES256 for CA key
Also, don't use read -s, use stty -echo
Fix broken "nopass" option
Add -r to read to stop errors reported by shellcheck (and to behave)
remove overzealous quotes around $pkcs_opts (more SC errors)
Support for LibreSSL (now works on latest version of MacOS)
EasyRSA version will be reported in certificate comments
Client certificates now expire in 3 year (1080 days) by default
This commit is contained in:
adam 2018-10-11 09:13:30 +00:00
parent f584999b44
commit 7468cfe03d
3 changed files with 15 additions and 13 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.7 2018/07/04 13:40:34 jperkin Exp $
# $NetBSD: Makefile,v 1.8 2018/10/11 09:13:30 adam Exp $
DISTNAME= EasyRSA-3.0.4
PKGNAME= ${DISTNAME:S/EasyRSA/easy-rsa/}
DISTNAME= EasyRSA-nix-3.0.5
PKGNAME= ${DISTNAME:S/EasyRSA-nix/easy-rsa/}
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GITHUB:=OpenVPN/}
GITHUB_RELEASE= v${PKGVERSION_NOREV}
@ -12,6 +12,8 @@ HOMEPAGE= https://github.com/OpenVPN/easy-rsa
COMMENT= CLI utility to build and manage a PKI CA
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}/${DISTNAME:S/-nix//}
USE_LANGUAGES= # none
NO_CONFIGURE= yes
NO_BUILD= yes
@ -29,7 +31,7 @@ REQD_FILES+= ${EGDIR}/${f} ${PKG_SYSCONFDIR}/${f}
.endfor
SUBST_CLASSES+= sysconf
SUBST_STAGE.sysconf= pre-configure
SUBST_STAGE.sysconf= pre-install
SUBST_FILES.sysconf= easyrsa vars.example
SUBST_SED.sysconf= -e "s|@SYSCONFDIR@|${PKG_SYSCONFDIR}|"

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.6 2018/06/24 07:31:09 adam Exp $
$NetBSD: distinfo,v 1.7 2018/10/11 09:13:30 adam Exp $
SHA1 (EasyRSA-3.0.4.tgz) = 7355bb076317b052014086dea5aed212152d0bec
RMD160 (EasyRSA-3.0.4.tgz) = 118185837b4c8446d0269e25d43e0bbe2672e1ea
SHA512 (EasyRSA-3.0.4.tgz) = 0bc145e510891af022c05427436c3ec7a29fce9d83e022954acd0cc470c88c43f5549af0b6263b46e8dc5fd167621a118cba0c01a514c51032cea8f1efbb9787
Size (EasyRSA-3.0.4.tgz) = 37721 bytes
SHA1 (patch-easyrsa) = a7cb4c837ebddd07c859dbe7f07f67899d410c25
SHA1 (EasyRSA-nix-3.0.5.tgz) = 178e39c4669ad69118d4cd2763b0e07a828df950
RMD160 (EasyRSA-nix-3.0.5.tgz) = 2941f4f190fd2d9e1e3994ff36e8a7f89df67cac
SHA512 (EasyRSA-nix-3.0.5.tgz) = 22ddf6162f75d97efa2d021f667488b3202a33250111bfbeb49ae61c2f8bcc88847881c4031fc4c3382cb77d48f44c37afd79963b17ebd9058eff788b523f95f
Size (EasyRSA-nix-3.0.5.tgz) = 50270 bytes
SHA1 (patch-easyrsa) = e64deb7ca97eba9e2a3bd07688ce720ebef5331e
SHA1 (patch-vars.example) = 31ffcf40ced1fb07a7531ec7de373ad24c04455e

View file

@ -1,10 +1,10 @@
$NetBSD: patch-easyrsa,v 1.1 2018/06/24 07:31:09 adam Exp $
$NetBSD: patch-easyrsa,v 1.2 2018/10/11 09:13:30 adam Exp $
Set a sane default for config file. Needs to be SUBSTed.
--- easyrsa.orig 2017-08-22 12:51:05.000000000 +0000
--- easyrsa.orig 2018-09-15 04:21:19.000000000 +0000
+++ easyrsa
@@ -1046,6 +1046,9 @@ vars_setup() {
@@ -1137,6 +1137,9 @@ vars_setup() {
# EASYRSA, if defined:
elif [ -n "$EASYRSA" ] && [ -f "$EASYRSA/vars" ]; then
vars="$EASYRSA/vars"