lighttpd: update to 1.4.75. Changes:

* [mod_redirect] url.redirect-code = 308 new default
* [ls-hpack] more portability fixes for sys/queue.h
* [ls-hpack] update version to 2.3.3
* [TLS] default to stronger ciphers w/ PFS and AEAD
* [ci] apt-get install build-essential on Ubuntu
* [ci] /usr/local/opt keg-only pkgs on Darwin(macOS)
* [mod_authn_sasl] translate SASL_LOG_* to syslog
* [build] include src/compat/sys/queue.h in tarball
* [core] fdlog_openlog(), fdlog_closelog()
* [mod_accesslog] fdlog_openlog() if using syslog
* [cmake] fix LEMON_PATH with empty CMAKE_BUILD_TYPE
* [ci] limit github ci to specific branches
* [ci] prefer non-login shell for Cygwin CI build
* [ci] prefer dash for Cygwin and MSYS2 builds
* [mod_wstunnel] fix server.ping-interval w/ HTTP/2
* [mod_dirlisting] fix suffix display of '/' on file (fixes #3242)
* [mod_openssl] use internal asn1_time fn on 32-bit (fixes #3244)
* [mod_openssl] faster ASN1_TIME parse
* [mod_wolfssl] faster ASN1_TIME parse
* [doc] update TLS comment in sample lighttpd.conf
This commit is contained in:
schmonz 2024-03-13 15:56:33 +00:00
parent e8a71871f6
commit 7475dcefb5
3 changed files with 6 additions and 31 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.127 2024/02/21 21:32:13 schmonz Exp $
# $NetBSD: Makefile,v 1.128 2024/03/13 15:56:33 schmonz Exp $
DISTNAME= lighttpd-1.4.74
DISTNAME= lighttpd-1.4.75
CATEGORIES= www
MASTER_SITES= https://download.lighttpd.net/lighttpd/releases-1.4.x/
EXTRACT_SUFX= .tar.xz

View File

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.81 2024/02/29 18:42:29 schmonz Exp $
$NetBSD: distinfo,v 1.82 2024/03/13 15:56:33 schmonz Exp $
BLAKE2s (lighttpd-1.4.74.tar.xz) = b674d61d6b12e18d9a78f7e7db5a8b116b62a8d213ef1e808e0d082e4a10883d
SHA512 (lighttpd-1.4.74.tar.xz) = 96ae90885898ec0a13441f135209a1e7c447b74b1dfbc16e75bdabcba30a4a4dd26878c205feed7f78311bcbc81b54602635cc0a64ea7fb8fe5e081f136fae2d
Size (lighttpd-1.4.74.tar.xz) = 1098796 bytes
BLAKE2s (lighttpd-1.4.75.tar.xz) = 661b8886c0d5db546393bbabffbc589c8a204b5db9ad6ed4e383c5c221fd5ce0
SHA512 (lighttpd-1.4.75.tar.xz) = 2066ad3e9eeaed4179bd6d3a2becc4ed57d6b00cbdd729a3c0d9a7276ee9c7906c9f1274f4def696d5ef0e662158ea13eb7ecb8e107cac5519ac98a83cf9d7ef
Size (lighttpd-1.4.75.tar.xz) = 1102080 bytes
SHA1 (patch-doc_config_lighttpd.conf) = 50f9529ea7ecfae741ca47f0514175dbf1aa52d9
SHA1 (patch-doc_lighttpd.8) = e08ac362784aebaca566d0f65380b70a829d6b4e
SHA1 (patch-src_ls-hpack_lshpack.h) = caafa73634b4d1a16e496992802e8e6a04a02f44

View File

@ -1,24 +0,0 @@
$NetBSD: patch-src_ls-hpack_lshpack.h,v 1.2 2024/02/29 18:42:29 schmonz Exp $
Apply upstream (106c4b147b) macOS sys/queue.h portability patch.
--- src/ls-hpack/lshpack.h.orig 2024-02-20 04:42:50.000000000 +0000
+++ src/ls-hpack/lshpack.h
@@ -225,6 +225,8 @@ lshpack_dec_set_max_capacity (struct lsh
#endif
#endif
+#ifndef STAILQ_FOREACH
+
#ifndef SIMPLEQ_FOREACH
#include "../compat/sys/queue.h"
#endif
@@ -243,6 +245,8 @@ lshpack_dec_set_max_capacity (struct lsh
#define STAILQ_FOREACH SIMPLEQ_FOREACH
#endif
+#endif
+
#if defined(STAILQ_FIRST) && defined(STAILQ_NEXT) && !defined(STAILQ_FOREACH)
#define STAILQ_FOREACH(var, head, field) \
for((var) = STAILQ_FIRST((head)); \