This commit is contained in:
hubertf 1997-12-29 02:31:53 +00:00
parent 92b9d87a23
commit 747e31975e
5 changed files with 37 additions and 32 deletions

View file

@ -1,9 +1,10 @@
# New ports collection makefile for: Xaw3d
# New ports collection Makefile for: Xaw3d
# Version required: 1.3
# Date created: 18 November 1994
# Whom: asami
# Date created: 30th November 1997
# Whom: tron@lyssa.owl.de
#
# $Id: Makefile,v 1.1.1.1 1997/12/29 02:22:39 hubertf Exp $
# $NetBSD: Makefile,v 1.2 1997/12/29 02:31:53 hubertf Exp $
# FreeBSD Id: Makefile,v 1.14 1997/06/19 09:33:26 asami Exp
#
DISTNAME= Xaw3d-1.3
@ -11,16 +12,15 @@ CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= widgets/Xaw3d/R6.1
MAINTAINER= asami@FreeBSD.ORG
WRKSRC= ${WRKDIR}/xc/lib/Xaw3d
USE_IMAKE= yes
WRKSRC= ${WRKDIR}/xc/lib/Xaw3d
post-extract:
${MKDIR} ${WRKSRC}/X11/Xaw3d
cd ${WRKSRC}/X11/Xaw3d; ln -sf ../../*.h .
@(cd ${WRKSRC};ln -s .. X11)
post-install:
${LDCONFIG} -m ${PREFIX}/lib
${MKDIR} -p ${PREFIX}/share/doc/Xaw3d
${CP} ${FILESDIR}/README.XAW3D ${PREFIX}/share/doc/Xaw3d
.include <bsd.port.mk>

View file

@ -1,5 +1,5 @@
--- ./Imakefile.org Wed May 29 08:38:40 1996
+++ ./Imakefile Mon Aug 5 22:46:04 1996
--- Imakefile.orig Wed May 29 17:38:40 1996
+++ Imakefile Mon Dec 1 01:02:08 1997
@@ -7,7 +7,7 @@
#define HasSharedData YES
#define LibName Xaw3d
@ -14,10 +14,10 @@
LINTLIBS = $(LINTXLIB) $(LINTXTOOL)
-# EXTRA_DEFINES = -DARROW_SCROLLBAR -DUSEGRAY
+ EXTRA_DEFINES = -DARROW_SCROLLBAR -DUSEGRAY
+EXTRA_DEFINES = -DARROW_SCROLLBAR -DUSEGRAY
-# EXTRA_INCLUDES = -I.
+ EXTRA_INCLUDES = -I.
+EXTRA_INCLUDES = -I.
HEADERS = \
AllWidgets.h \

View file

@ -1 +1 @@
A 3-D Athena Widget set that looks like Motif
3-D widgets based on the Athena Widget set

View file

@ -1,9 +1,9 @@
Xaw3d is a Xaw (Athena Widget Set) replacement that looks
three-dimensional. The author is Kalib Keithley (kaleb@x.org).
This is version 1.2a.
This is Release 1.3 (3 June, 1996) of a set of 3-D widgets based
on the R6.1 Athena Widget set. The Three-D Athena may be used as
a general replacement for the Athena (Xaw) Widget set.
Added is a patch by me (Satoshi) to make the arrow scrollbar look real
bumpy.
Satoshi
asami@freebsd.org
In general, you may relink almost any Athena Widget based application
with the Three-D Athena Widget set and obtain a three dimensional
appearance on some of the widgets. On systems with shared libraries,
you can usually replace your shared libXaw with libXaw3d and obtain
the three dimensional appearance without even relinking.

View file

@ -1,6 +1,4 @@
lib/libXaw3d.a
lib/libXaw3d.so.6.1
@exec /sbin/ldconfig -m %B
@comment $NetBSD: PLIST,v 1.2 1997/12/29 02:31:59 hubertf Exp $
include/X11/Xaw3d/AllWidgets.h
include/X11/Xaw3d/AsciiSink.h
include/X11/Xaw3d/AsciiSinkP.h
@ -25,12 +23,12 @@ include/X11/Xaw3d/Layout.h
include/X11/Xaw3d/LayoutP.h
include/X11/Xaw3d/List.h
include/X11/Xaw3d/ListP.h
include/X11/Xaw3d/MenuButtoP.h
include/X11/Xaw3d/MenuButton.h
include/X11/Xaw3d/MultiSink.h
include/X11/Xaw3d/MultiSinkP.h
include/X11/Xaw3d/MenuButtoP.h
include/X11/Xaw3d/MultiSrc.h
include/X11/Xaw3d/MultiSrcP.h
include/X11/Xaw3d/MultiSink.h
include/X11/Xaw3d/MultiSinkP.h
include/X11/Xaw3d/Paned.h
include/X11/Xaw3d/PanedP.h
include/X11/Xaw3d/Panner.h
@ -43,19 +41,19 @@ include/X11/Xaw3d/Reports.h
include/X11/Xaw3d/Scrollbar.h
include/X11/Xaw3d/ScrollbarP.h
include/X11/Xaw3d/Simple.h
include/X11/Xaw3d/SimpleMenP.h
include/X11/Xaw3d/SimpleMenu.h
include/X11/Xaw3d/SimpleP.h
include/X11/Xaw3d/SimpleMenu.h
include/X11/Xaw3d/SimpleMenP.h
include/X11/Xaw3d/Sme.h
include/X11/Xaw3d/SmeP.h
include/X11/Xaw3d/SmeBSB.h
include/X11/Xaw3d/SmeBSBP.h
include/X11/Xaw3d/SmeLine.h
include/X11/Xaw3d/SmeLineP.h
include/X11/Xaw3d/SmeP.h
include/X11/Xaw3d/SmeThreeD.h
include/X11/Xaw3d/SmeThreeDP.h
include/X11/Xaw3d/StripCharP.h
include/X11/Xaw3d/StripChart.h
include/X11/Xaw3d/StripCharP.h
include/X11/Xaw3d/Template.c
include/X11/Xaw3d/Template.h
include/X11/Xaw3d/TemplateP.h
@ -76,3 +74,10 @@ include/X11/Xaw3d/Viewport.h
include/X11/Xaw3d/ViewportP.h
include/X11/Xaw3d/XawImP.h
include/X11/Xaw3d/XawInit.h
lib/libXaw3d.a
lib/libXaw3d.so.6.1
@exec /sbin/ldconfig -m %B || true
@unexec /sbin/ldconfig -m %B || true
share/doc/Xaw3d/README.XAW3D
@dirrm share/doc/Xaw3d
@dirrm include/X11/Xaw3d