wm/coma: import coma-1.0.

Coma is a minimalistic X11 Window Manager.

It has 2 framing modes: default, large. Only one can be active at a given
time and is specified at startup time:

- Default means it will split up your screen into columns just large enough
to fit 80 column xterms.

- Large means it will calculate the frames based on 161 column xterms (so
one can use tmux and split it to get 80 columns in each pane).

OK kamil@
This commit is contained in:
fcambus 2019-08-16 14:07:27 +00:00
parent 93be24a843
commit 7483f886b7
5 changed files with 67 additions and 0 deletions

10
wm/coma/DESCR Normal file
View file

@ -0,0 +1,10 @@
Coma is a minimalistic X11 Window Manager.
It has 2 framing modes: default, large. Only one can be active at a given
time and is specified at startup time:
- Default means it will split up your screen into columns just large enough
to fit 80 column xterms.
- Large means it will calculate the frames based on 161 column xterms (so
one can use tmux and split it to get 80 columns in each pane).

16
wm/coma/Makefile Normal file
View file

@ -0,0 +1,16 @@
# $NetBSD: Makefile,v 1.1 2019/08/16 14:07:27 fcambus Exp $
DISTNAME= coma-1.0
CATEGORIES= wm
MASTER_SITES= https://coma.one/releases/
MAINTAINER= fcambus@NetBSD.org
HOMEPAGE= https://coma.one/releases/
COMMENT= Keyboard driven tiling window manager
LICENSE= isc
USE_LANGUAGES= c99
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXft/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
wm/coma/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2019/08/16 14:07:27 fcambus Exp $
bin/coma
man/man1/coma.1

7
wm/coma/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2019/08/16 14:07:27 fcambus Exp $
SHA1 (coma-1.0.tar.gz) = e830786675e4f8542337363f8835e195e8f58593
RMD160 (coma-1.0.tar.gz) = 672f1202d92b0ba324f97d28c5c0185d59c1f106
SHA512 (coma-1.0.tar.gz) = 3df8fd17d269b3888fd931b5126f8e63c9aac63451be14fa8a20be09e945056cd7a45b062a6810a9bba0146fbd4b81791e8c0d9bbad1c18f26d1d3b222251e52
Size (coma-1.0.tar.gz) = 13487 bytes
SHA1 (patch-Makefile) = 939c2ee550abccc39967fb59fdff4a524c7cd30a

View file

@ -0,0 +1,31 @@
$NetBSD: patch-Makefile,v 1.1 2019/08/16 14:07:27 fcambus Exp $
Adapt install target for pkgsrc.
--- Makefile.orig 2019-01-17 20:01:53.000000000 +0000
+++ Makefile
@@ -2,9 +2,10 @@
CC?=cc
COMA=coma
+DESTDIR?=
PREFIX?=/usr/local
INSTALL_DIR=$(PREFIX)/bin
-MAN_DIR=$(PREFIX)/share/man
+MAN_DIR=$(PREFIX)/man
SRC= coma.c client.c config.c frame.c wm.c
OBJS= $(SRC:%.c=%.o)
@@ -27,8 +28,10 @@ LDFLAGS+=`pkg-config --libs x11 xft`
all: $(COMA)
install: $(COMA)
- install -m 555 $(COMA) $(INSTALL_DIR)/$(COMA)
- install -m 644 coma.1 $(MAN_DIR)/man1/coma.1
+ mkdir -p $(DESTDIR)$(INSTALL_DIR)
+ mkdir -p $(DESTDIR)$(MAN_DIR)/man1
+ install -m 555 $(COMA) $(DESTDIR)$(INSTALL_DIR)/$(COMA)
+ install -m 644 coma.1 $(DESTDIR)$(MAN_DIR)/man1/coma.1
$(COMA): $(OBJS)
$(CC) $(OBJS) $(LDFLAGS) -o $(COMA)