first import of pcf2bdf-1.04, a bitmap font de-compiler to the NetBSD
Packages Collection. Pcf2bdf is a font de-compiler. It converts X font from Portable Compiled Format (PCF) to Bitmap Distribution For- mat (BDF). It can also accept a compressed/gzipped PCF file as input, but gzip must be found in your PATH. FONTBOUNDINGBOX in a BDF file is not used by bdftopcf , so pcf2bdf generate irresponsible values.
This commit is contained in:
parent
8e14bac154
commit
749209902c
5 changed files with 67 additions and 0 deletions
7
fonts/pcf2bdf/DESCR
Normal file
7
fonts/pcf2bdf/DESCR
Normal file
|
@ -0,0 +1,7 @@
|
|||
Pcf2bdf is a font de-compiler. It converts X font from
|
||||
Portable Compiled Format (PCF) to Bitmap Distribution For-
|
||||
mat (BDF). It can also accept a compressed/gzipped PCF
|
||||
file as input, but gzip must be found in your PATH.
|
||||
|
||||
FONTBOUNDINGBOX in a BDF file is not used by bdftopcf , so
|
||||
pcf2bdf generate irresponsible values.
|
21
fonts/pcf2bdf/Makefile
Normal file
21
fonts/pcf2bdf/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2002/12/31 05:44:43 kei Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pcf2bdf-1.04
|
||||
CATEGORIES= fonts graphics x11
|
||||
MASTER_SITES= http://www.tsg.ne.jp/GANA/S/pcf2bdf/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= tech-pkg-ja@jp.netbsd.org
|
||||
HOMEPAGE= http://www.tsg.ne.jp/GANA/S/pcf2bdf/
|
||||
COMMENT= convert X font from PCF to BDF
|
||||
|
||||
USE_GMAKE= YES
|
||||
WRKSRC= ${WRKDIR}
|
||||
MAKEFILE= Makefile.gcc
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/pcf2bdf ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/pcf2bdf.man ${PREFIX}/man/man1/pcf2bdf.1
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
fonts/pcf2bdf/PLIST
Normal file
3
fonts/pcf2bdf/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/12/31 05:44:43 kei Exp $
|
||||
bin/pcf2bdf
|
||||
man/man1/pcf2bdf.1
|
5
fonts/pcf2bdf/distinfo
Normal file
5
fonts/pcf2bdf/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/12/31 05:44:43 kei Exp $
|
||||
|
||||
SHA1 (pcf2bdf-1.04.tgz) = 6fdcc10132e27d3c26ff7e4be541332ee5d4e927
|
||||
Size (pcf2bdf-1.04.tgz) = 9686 bytes
|
||||
SHA1 (patch-aa) = d750333e3ac74db0666a40a6902af02d85d02ba0
|
31
fonts/pcf2bdf/patches/patch-aa
Normal file
31
fonts/pcf2bdf/patches/patch-aa
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/12/31 05:44:43 kei Exp $
|
||||
|
||||
--- pcf2bdf.cc.orig Mon Oct 21 01:35:29 2002
|
||||
+++ pcf2bdf.cc Tue Dec 31 14:36:08 2002
|
||||
@@ -577,7 +577,7 @@
|
||||
}
|
||||
if (ifilename)
|
||||
{
|
||||
- ifp = fopen(ifilename, "rb");
|
||||
+ ifp = fopen(ifilename, "r");
|
||||
if (!ifp)
|
||||
return error_exit("failed to open input pcf file");
|
||||
}
|
||||
@@ -595,7 +595,7 @@
|
||||
fclose(ifp);
|
||||
char buf[1024];
|
||||
sprintf(buf, "gzip -dc %s", ifilename); // TODO
|
||||
- ifp = popen(buf, "rb");
|
||||
+ ifp = popen(buf, "r");
|
||||
_setmode(fileno(ifp), O_BINARY);
|
||||
read_bytes = 0;
|
||||
if (!ifp)
|
||||
@@ -604,7 +604,7 @@
|
||||
|
||||
if (ofilename)
|
||||
{
|
||||
- ofp = fopen(ofilename, "wb");
|
||||
+ ofp = fopen(ofilename, "w");
|
||||
if (!ofp)
|
||||
return error_exit("failed to open output bdf file");
|
||||
}
|
Loading…
Reference in a new issue