Use LTCONFIG_OVERRIDE and make sure that qt1 library path is included in

-rpath list.
This commit is contained in:
skrll 2000-08-16 18:29:50 +00:00
parent 2182615ef6
commit 749d3f58a2
3 changed files with 11 additions and 24 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.53 2000/08/15 23:20:51 hubertf Exp $
# $NetBSD: Makefile,v 1.54 2000/08/16 18:29:50 skrll Exp $
# FreeBSD Id: Makefile,v 1.5 1997/11/27 00:25:46 se Exp
#
@ -19,12 +19,15 @@ DEPENDS+= tiff-*:../../graphics/tiff
USE_X11BASE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
LTCONFIG_OVERRIDE= ${WRKSRC}/admin/ltconfig
GNU_CONFIGURE= yes
EVAL_PREFIX+= QT1DIR=qt1
CONFIGURE_ARGS= "--datadir=${PREFIX}/share/kde" \
"--with-qt-dir=${QT1DIR}/qt1"
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= "-Wl,-R${QT1DIR}/qt1/lib" \
"-L${QT1DIR}/qt1/lib"
.include "../../mk/bsd.prefs.mk"

View file

@ -1,5 +1,6 @@
$NetBSD: patch-sum,v 1.4 2000/06/02 13:44:16 drochner Exp $
$NetBSD: patch-sum,v 1.5 2000/08/16 18:29:51 skrll Exp $
MD5 (patch-aa) = 2933281323e49abecff7e2527032f1a1
MD5 (patch-aa) = 33d07bec77edcc04d7301c100c1e2607
MD5 (patch-ab) = 5d59a2d5eb50bb0883d3aa4ef5e0c9a5
MD5 (patch-ac) = ff8cb796b36e159941684a64522acffe
MD5 (patch-ad) = fa35def30787286ffdf7976b38f08e7e

View file

@ -1,10 +1,10 @@
$NetBSD: patch-aa,v 1.11 1999/11/22 20:27:23 jdolecek Exp $
$NetBSD: patch-aa,v 1.12 2000/08/16 18:29:51 skrll Exp $
The libtool staff was pulled into KDE, as rev 1.331 of
kde-common/admin/acinclude.m4.in (jdolecek)
--- configure.orig Wed Apr 28 17:24:12 1999
+++ configure Thu Jun 3 19:26:48 1999
--- configure.orig Tue Sep 7 16:23:19 1999
+++ configure Wed Aug 16 15:32:01 2000
@@ -507,9 +507,9 @@
# Prefer explicitly selected file to automatically selected ones.
if test -z "$CONFIG_SITE"; then
@ -17,24 +17,7 @@ The libtool staff was pulled into KDE, as rev 1.331 of
fi
fi
for ac_site_file in $CONFIG_SITE; do
@@ -2034,6 +2034,8 @@
kde_save_cflags="$CFLAGS"
CC=$CXX
CFLAGS="$CXXFLAGS"
+
+if false; then
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool --silent'
@@ -2267,6 +2269,7 @@
${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $host \
|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
+fi
# Redirect the config.log output again, so that the ltconfig log is not
# clobbered by the next message.
@@ -5376,37 +5379,37 @@
@@ -5382,37 +5382,37 @@
if test "default" = "default"; then
if test -z "$kde_htmldir"; then