update to 0.6 and add an explicit dependency on pkgconfig.

0.6
===
  - Fix some fairly serious memory leaks (Tommi Leino)
  - Cygwin build fix (Masahiro Sakai)
This commit is contained in:
recht 2004-04-03 11:20:20 +00:00
parent aead954ee2
commit 74cbda6145
3 changed files with 13 additions and 12 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.4 2004/02/14 18:26:30 jmmv Exp $
# $NetBSD: Makefile,v 1.5 2004/04/03 11:20:20 recht Exp $
DISTNAME= startup-notification-0.5
DISTNAME= startup-notification-0.6
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/startup-notification/0.5/}
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/startup-notification/0.6/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= benedikt.meurer@unix-ag.uni-siegen.de
@ -22,4 +22,5 @@ post-install:
doc/startup-notification.txt \
${PREFIX}/share/doc/startup-notification/
.include "../../devel/pkgconfig/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.2 2003/12/17 14:59:16 sketch Exp $
$NetBSD: distinfo,v 1.3 2004/04/03 11:20:20 recht Exp $
SHA1 (startup-notification-0.5.tar.bz2) = 54ae80d94e608c0bcecd0f9f1c85fd7ab4f48740
Size (startup-notification-0.5.tar.bz2) = 156294 bytes
SHA1 (patch-aa) = 7ac5a73bd27ca2210b7ee5160b70d9e70b7ed4a2
SHA1 (startup-notification-0.6.tar.bz2) = 7aebcbfbc060d6bad0f98811a98ced13f5873cce
Size (startup-notification-0.6.tar.bz2) = 206341 bytes
SHA1 (patch-aa) = 6ad6128961e8e21fd7b21b242788dad8f3e07e0b

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.1 2003/12/17 14:59:16 sketch Exp $
$NetBSD: patch-aa,v 1.2 2004/04/03 11:20:20 recht Exp $
--- libsn/sn-launcher.c.orig 2003-12-16 16:58:09.089918618 +0000
+++ libsn/sn-launcher.c 2003-12-16 16:58:36.533023772 +0000
@@ -176,7 +176,7 @@
--- libsn/sn-launcher.c.orig 2004-03-23 17:53:03.000000000 +0100
+++ libsn/sn-launcher.c
@@ -182,7 +182,7 @@ sn_launcher_context_initiate (SnLauncher
if (context->startup_id != NULL)
{
fprintf (stderr, "%s called twice for the same SnLaunchContext\n",
@ -11,7 +11,7 @@ $NetBSD: patch-aa,v 1.1 2003/12/17 14:59:16 sketch Exp $
return;
}
@@ -362,7 +362,7 @@
@@ -368,7 +368,7 @@ sn_launcher_context_setup_child_process
/* FIXME use something pluggable, not fprintf */
#define WARN_ALREADY_INITIATED(context) do { if ((context)->startup_id != NULL) { \
fprintf (stderr, "%s called for an SnLauncherContext that has already been initiated\n", \