Update to 2.70. From the changelog:

2.70 (2010-12-21)
* Improved handling of given feed email addresses to prevent mail
    servers rejecting poorly formed Froms
* Added X-RSS-TAGS header that lists any tags provided by an entry,
    which will be helpful in filtering incoming messages

2.69 (2010-11-12)
* Added support for connecting to SMTP server via SSL, see SMTP_SSL option
* Improved backwards compatibility by fixing issue with listing
    feeds when run with older Python versions
* Added selective feed email overrides through OVERRIDE_EMAIL and
    DEFAULT_EMAIL options
* Added NO_FRIENDLY_NAME to from from address only without the friendly name
* Added X-RSS-URL header in each message with the link to the original item

2.68 (2010-10-01)
* Added ability to pause/resume checking of individual feeds through
    pause and unpause commands
* Added ability to import and export OPML feed lists through
    importopml and exportopml commands

2.67 (2010-09-21)
* Fixed entries that include an id which is blank (i.e., an empty
    string) were being resent
* Fixed some entries not being sent by email because they had bad From headers
* Fixed From headers with HTML entities encoded twice
* Compatibility changes to support most recent development versions
    of feedparser
* Compatibility changes to support Google Reader feeds

2.66 (2009-12-21)
* Complete packaging of all necessary source files (rss2email,
    html2text, feedparser, r2e, etc.) into one bundle
* Included a more complete config.py with all options
* Default to HTML mail and CSS results
* Added 'reset' command to erase history of already seen entries
* Changed project email and homepage
* Made exception and error output text more useful
* Added X-RSS-Feed and X-RSS-ID headers to each email for easier filtering
* Improved enclosure handling
* Fixed MacOS compatibility issues
This commit is contained in:
schmonz 2011-01-28 01:41:52 +00:00
parent 71226b96d1
commit 74d0b1fa17
7 changed files with 54 additions and 105 deletions

View file

@ -1,14 +1,12 @@
# $NetBSD: Makefile,v 1.24 2010/02/10 19:17:41 joerg Exp $
# $NetBSD: Makefile,v 1.25 2011/01/28 01:41:52 schmonz Exp $
#
DISTNAME= rss2email-2.65
PKGREVISION= 1
DISTNAME= rss2email-2.70
CATEGORIES= mail
MASTER_SITES= ${HOMEPAGE}
EXTRACT_SUFX= .py
MAINTAINER= schmonz@NetBSD.org
HOMEPAGE= http://rss2email.infogami.com/
HOMEPAGE= http://www.allthingsrss.com/rss2email/
COMMENT= Get RSS feeds emailed to you
DEPENDS+= ${PYPKGPREFIX}-feedparser-[0-9]*:../../textproc/py-feedparser
@ -16,9 +14,6 @@ DEPENDS+= ${PYPKGPREFIX}-html2text-[0-9]*:../../textproc/py-html2text
PKG_DESTDIR_SUPPORT= user-destdir
WRKSRC= ${WRKDIR}
USE_TOOLS+= tr
NO_BUILD= yes
PYTHON_PATCH_SCRIPTS= *.py
@ -29,21 +24,24 @@ SUBST_SED.bin= -e 's|@LOCALBASE@|${LOCALBASE}|g'
SUBST_SED.bin+= -e 's|@PREFIX@|${PREFIX}|g'
SUBST_SED.bin+= -e 's|@PYTHONBIN@|${PYTHONBIN}|g'
SUBST_CLASSES+= crlf
SUBST_STAGE.crlf= post-extract
SUBST_FILES.crlf= config.py.example
SUBST_SED.crlf= -e 's| ||g'
SHAREDIR= ${PREFIX}/share/rss2email
EGDIR= ${PREFIX}/share/examples/rss2email
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
do-extract:
tr -d '\r' < ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \
> ${WRKSRC}/rss2email.py
cd ${FILESDIR} && cp config.py r2e r2e.1 ${WRKSRC}
post-extract:
cp ${FILESDIR}/r2e.1 ${WRKSRC}
do-install:
set -e; cd ${WRKSRC}; \
${INSTALL_SCRIPT_DIR} ${DESTDIR}${SHAREDIR}; \
${INSTALL_SCRIPT} rss2email.py ${DESTDIR}${SHAREDIR}; \
${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR}; \
${INSTALL_DATA} config.py ${DESTDIR}${EGDIR}; \
${INSTALL_DATA} config.py.example ${DESTDIR}${EGDIR}/config.py; \
${INSTALL_MAN} r2e.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1; \
${INSTALL_SCRIPT} r2e ${DESTDIR}${PREFIX}/bin

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.17 2009/04/07 04:41:18 schmonz Exp $
$NetBSD: distinfo,v 1.18 2011/01/28 01:41:52 schmonz Exp $
SHA1 (rss2email-2.65.py) = 8fe6c6c1bfe56164fba64378fc1f0b8295b1b8d9
RMD160 (rss2email-2.65.py) = fcc0df8e47d81c495f7c7aa045672bc0eaf898ab
Size (rss2email-2.65.py) = 25874 bytes
SHA1 (patch-ad) = 6b3c7908eadbebca34cde9431d1d85b3761f5aad
SHA1 (rss2email-2.70.tar.gz) = 8f59e33e38b0a01a9ce411b82b31708604228c37
RMD160 (rss2email-2.70.tar.gz) = d5d7a06c33d51c21784c069c27fb52ab87665b06
Size (rss2email-2.70.tar.gz) = 57961 bytes
SHA1 (patch-aa) = a19bb5795e7fcbfc8e03f86c25646b091052794b
SHA1 (patch-ab) = db8f4780a40f1231782e7391c7d7b03c011a8534
SHA1 (patch-ad) = d76be79ebd5886d75f885fe96d0d9d8b1720c243

View file

@ -1,76 +0,0 @@
### Vaguely Customizable Options ###
# The email address messages are from by default:
DEFAULT_FROM = "bozo@dev.null.invalid"
# 1: Send text/html messages when possible.
# 0: Convert HTML to plain text.
HTML_MAIL = 0
# 1: Only use the DEFAULT_FROM address.
# 0: Use the email address specified by the feed, when possible.
FORCE_FROM = 0
# 1: Receive one email per post
# 0: Receive an email every time a post changes
TRUST_GUID = 1
# 1: Generate Date header based on item's date, when possible
# 0: Generate Date header based on time sent
DATE_HEADER = 0
# A tuple consisting of some combination of
# ('issued', 'created', 'modified', 'expired')
# expressing ordered list of preference in dates
# to use for the Date header of the email.
DATE_HEADER_ORDER = ('modified', 'issued', 'created')
# 1: Apply Q-P conversion (required for some MUAs).
# 0: Send message in 8-bits.
# http://cr.yp.to/smtp/8bitmime.html
QP_REQUIRED = 0
# 1: Name feeds as they're being processed.
# 0: Keep quiet.
VERBOSE = 0
# 1: Use the publisher's email if you can't find the author's.
# 0: Just use the DEFAULT_FROM email instead.
USE_PUBLISHER_EMAIL = 0
# 1: Use SMTP_SERVER to send mail.
# 0: Call /usr/sbin/sendmail to send mail.
SMTP_SEND = 0
SMTP_SERVER = "smtp.yourisp.net:25"
AUTHREQUIRED = 0 # if you need to use SMTP AUTH set to 1
SMTP_USER = ' username' # for SMTP AUTH, set SMTP username here
SMTP_PASS = 'password' # for SMTP AUTH, set SMTP password here
# Set this to add a bonus header to all emails (start with '\n').
BONUS_HEADER = ''
# Example: BONUS_HEADER = '\nApproved: joe@bob.org'
# Set this to override From addresses. Keys are feed URLs, values are new titles.
OVERRIDE_FROM = {}
# Set this to override the timeout (in seconds) for feed server response
FEED_TIMEOUT = 60
# Optional CSS styling
USE_CSS_STYLING = 0
STYLE_SHEET='h1 {font: 18pt Georgia, "Times New Roman";} body {font: 12pt Arial;} a:link {font: 12pt Arial; font-weight: bold; color: #0000cc} blockquote {font-family: monospace; } .header { background: #e0ecff; border-bottom: solid 4px #c3d9ff; padding: 5px; margin-top: 0px; color: red;} .header a { font-size: 20px; text-decoration: none; } .footer { background: #c3d9ff; border-top: solid 4px #c3d9ff; padding: 5px; margin-bottom: 0px; } #entry {border: solid 4px #c3d9ff; } #body { margin-left: 5px; margin-right: 5px; }'
# If you have an HTTP Proxy set this in the format 'http://your.proxy.here:8080/'
PROXY=""
## html2text options ##
# Use Unicode characters instead of their ascii psuedo-replacements
UNICODE_SNOB = 0
# Put the links after each paragraph instead of at the end.
LINKS_EACH_PARAGRAPH = 0
# Wrap long lines at position. 0 for no wrapping. (Requires Python 2.3.)
BODY_WIDTH = 0

View file

@ -1,7 +0,0 @@
#!/bin/sh
set -e
if [ ! -d ~/.rss2email ]; then
mkdir ~/.rss2email
fi
cd ~/.rss2email
exec @PYTHONBIN@ @PREFIX@/share/rss2email/rss2email.py feeds.dat $*

View file

@ -0,0 +1,19 @@
$NetBSD: patch-aa,v 1.4 2011/01/28 01:41:53 schmonz Exp $
--- config.py.example.orig 2011-01-28 01:22:26.000000000 +0000
+++ config.py.example
@@ -92,3 +92,14 @@ PROXY=""
# To most correctly encode emails with international characters, we iterate through the list below and use the first character set that works
# Eventually (and theoretically) ISO-8859-1 and UTF-8 are our catch-all failsafes
CHARSET_LIST='US-ASCII', 'BIG5', 'ISO-2022-JP', 'ISO-8859-1', 'UTF-8'
+
+## html2text options ##
+
+# Use Unicode characters instead of their ascii psuedo-replacements
+UNICODE_SNOB = 0
+
+# Put the links after each paragraph instead of at the end.
+LINKS_EACH_PARAGRAPH = 0
+
+# Wrap long lines at position. 0 for no wrapping. (Requires Python 2.3.)
+BODY_WIDTH = 0

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.4 2011/01/28 01:41:53 schmonz Exp $
--- r2e.orig 2006-03-16 23:43:03.000000000 +0000
+++ r2e
@@ -1,2 +1,7 @@
#!/bin/sh
-python rss2email.py feeds.dat $*
+set -e
+if [ ! -d ~/.rss2email ]; then
+ mkdir ~/.rss2email
+fi
+cd ~/.rss2email
+exec @PYTHONBIN@ @PREFIX@/share/rss2email/rss2email.py feeds.dat $*

View file

@ -1,10 +1,10 @@
$NetBSD: patch-ad,v 1.6 2009/04/07 04:41:19 schmonz Exp $
$NetBSD: patch-ad,v 1.7 2011/01/28 01:41:53 schmonz Exp $
--- rss2email.py.orig 2009-04-05 13:43:25.000000000 -0400
--- rss2email.py.orig 2010-12-17 18:29:34.000000000 +0000
+++ rss2email.py
@@ -270,6 +270,7 @@ for e in ['error', 'gaierror']:
@@ -296,6 +296,7 @@ for e in ['error', 'gaierror']:
import feedparser
feedparser.USER_AGENT = "rss2email/"+__version__+ " +http://www.aaronsw.com/2002/rss2email/"
feedparser.USER_AGENT = "rss2email/"+__version__+ " +http://www.allthingsrss.com/rss2email/"
+sys.path.append("@LOCALBASE@/share/html2text")
import html2text as h2t