Fix build problem after changing rd2 handling.

This commit is contained in:
taca 2015-06-14 00:40:30 +00:00
parent f03fdf6b1d
commit 74d14df2e5
3 changed files with 30 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.40 2015/06/11 15:37:22 taca Exp $
# $NetBSD: Makefile,v 1.41 2015/06/14 00:40:30 taca Exp $
#
DISTNAME= mod_ruby-${VERSION}
@ -35,6 +35,12 @@ PKG_SYSCONFSUBDIR?= httpd
CONF_FILES+= ${PREFIX}/${RUBY_EG}/mod_ruby/mod_ruby.conf \
${PKG_SYSCONFDIR}/mod_ruby.conf
SUBST_CLASSES+= rd2
SUBST_STAGE.rd2= pre-configure
SUBST_FILES.rd2= doc/Makefile.in
SUBST_SED.rd2= -e 's|@RUBY_RD@|${RUBY_RD}|g'
SUBST_MESSAGE.rd2= Fixing rd2.
SUBST_CLASSES+= path
SUBST_STAGE.path= post-build
SUBST_FILES.path= examples/httpd.conf

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.11 2010/09/10 10:50:27 taca Exp $
$NetBSD: distinfo,v 1.12 2015/06/14 00:40:30 taca Exp $
SHA1 (mod_ruby-1.3.0.tar.gz) = 967c4efa1ec3f8b0d9870db8665295ba6e019fff
RMD160 (mod_ruby-1.3.0.tar.gz) = a87f2a54a0b501e27efffdaab88b5ad4e6abd413
Size (mod_ruby-1.3.0.tar.gz) = 114246 bytes
SHA1 (patch-aa) = a00f6d5baf7c470e7143aa5ba8b6955516787f27
SHA1 (patch-ac) = c88ef1288325717750f76e2234c631bd3d8126c5
SHA1 (patch-doc_Makefile.in) = 340cb64c1c194bd7679ecba0c5eb265f7fa1904d

View file

@ -0,0 +1,21 @@
$NetBSD: patch-doc_Makefile.in,v 1.1 2015/06/14 00:40:30 taca Exp $
Do not hard cord rd2.
--- doc/Makefile.in.orig 2004-07-01 03:49:24.000000000 +0000
+++ doc/Makefile.in
@@ -15,12 +15,12 @@ HTMLS = $(EN_HTMLS) $(JA_HTMLS)
.SUFFIXES: .en.rd .ja.euc.rd .en.html .ja.jis.html
.en.rd.en.html:
- $(RUBY) -Kn -S rd2 -r rd/rd2html-lib \
+ $(RUBY) -Kn @RUBY_RD@ -r rd/rd2html-lib \
--with-css=default.css \
$< > $@
.ja.euc.rd.ja.jis.html:
- $(RUBY) -Ke -S rd2 -r rd/rd2html-lib \
+ $(RUBY) -Ke @RUBY_RD@ -r rd/rd2html-lib \
--with-css=default.css --out-code=jis \
$< > $@