update to tint2-0.14.6
Major changes since 0.11 are: SVG support performance improvements moved to github many bugfixes
This commit is contained in:
parent
f25d4d09a0
commit
74e56ea9a1
9 changed files with 90 additions and 118 deletions
|
@ -1,52 +1,35 @@
|
|||
# $NetBSD: Makefile,v 1.41 2017/02/12 06:26:15 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.42 2017/07/28 08:42:17 tnn Exp $
|
||||
|
||||
DISTNAME= tint2-0.11
|
||||
PKGREVISION= 27
|
||||
DISTNAME= tint2-0.14.6
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://tint2.googlecode.com/files/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=o9000/}
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
|
||||
MAINTAINER= fernandotcl@gmail.com
|
||||
HOMEPAGE= http://code.google.com/p/tint2/
|
||||
HOMEPAGE= https://gitlab.com/o9000/tint2
|
||||
COMMENT= Tint2 is a simple panel/taskbar
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
USE_LANGUAGES= c c++ # XXX CMake. pkg does not really need c++
|
||||
USE_CMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
INSTALLATION_DIRS= share/examples/tint2
|
||||
OWN_DIRS= ${PKG_SYSCONFDIR}/xdg/tint2
|
||||
CONF_FILES= ${PREFIX}/share/examples/tint2/tint2rc \
|
||||
${PKG_SYSCONFDIR}/xdg/tint2/tint2rc
|
||||
|
||||
REPLACE_PYTHON+= src/tint2conf/tintwizard.py
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 34 35 36 # py-gtk2
|
||||
|
||||
# XXX: why not use normal CMAKE_ARGS infrastructure?
|
||||
CMAKE_OPTS+= -DCMAKE_INSTALL_PREFIX=${PREFIX}
|
||||
CMAKE_OPTS+= -DSYSCONFDIR=${PKG_SYSCONFDIR}
|
||||
CMAKE_OPTS+= -DMANDIR=${PKGMANDIR}
|
||||
# Below rpath fix is copypasted from graphics/vtk.
|
||||
CMAKE_OPTS+= -DCMAKE_INSTALL_RPATH:STRING=${PREFIX}/lib:${X11BASE}/lib${LIBABISUFFIX:Q} \
|
||||
CMAKE_OPTS+= -DCMAKE_SKIP_BUILD_RPATH:BOOL=ON \
|
||||
CMAKE_OPTS+= -DCMAKE_BUILD_WITH_INSTALL_RPATH:BOOL=ON \
|
||||
CMAKE_OPTS+= -DCMAKE_INSTALL_RPATH_USE_LINK_PATH:BOOL=ON
|
||||
|
||||
OPSYSVARS+= CMAKE_OPTS
|
||||
CMAKE_OPTS.Linux= -DENABLE_BATTERY=ON
|
||||
CMAKE_OPTS.*= -DENABLE_BATTERY=OFF
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && ${PREFIX}/bin/cmake ${CMAKE_OPTS} .
|
||||
CMAKE_ARGS.Linux= -DENABLE_BATTERY=ON
|
||||
CMAKE_ARGS.*= -DENABLE_BATTERY=OFF
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/sample/tint2rc \
|
||||
${INSTALL_DATA} ${WRKSRC}/themes/tint2rc \
|
||||
${DESTDIR}${PREFIX}/share/examples/tint2
|
||||
|
||||
.include "../../devel/cmake/buildlink3.mk"
|
||||
.include "../../graphics/imlib2/buildlink3.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../graphics/librsvg/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../x11/libXcomposite/buildlink3.mk"
|
||||
|
@ -54,4 +37,5 @@ post-install:
|
|||
.include "../../x11/libXinerama/buildlink3.mk"
|
||||
.include "../../x11/libXrandr/buildlink3.mk"
|
||||
.include "../../x11/py-gtk2/buildlink3.mk"
|
||||
.include "../../x11/startup-notification/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,12 +1,52 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2010/07/05 08:06:15 tnn Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2017/07/28 08:42:17 tnn Exp $
|
||||
bin/tint2
|
||||
bin/tint2conf
|
||||
bin/tintwizard.py
|
||||
man/man1/tint2.1
|
||||
share/applications/tint2.desktop
|
||||
share/applications/tint2conf.desktop
|
||||
share/doc/tint2/AUTHORS
|
||||
share/doc/tint2/ChangeLog
|
||||
share/doc/tint2/README
|
||||
share/doc/tint2/README.md
|
||||
share/doc/tint2/html/images/panel_padding.jpg
|
||||
share/doc/tint2/html/images/panel_size_margin.jpg
|
||||
share/doc/tint2/html/images/task_padding.jpg
|
||||
share/doc/tint2/html/images/taskbar_padding.jpg
|
||||
share/doc/tint2/html/manual.html
|
||||
share/doc/tint2/html/readme.html
|
||||
share/doc/tint2/tint2.md
|
||||
share/examples/tint2/tint2rc
|
||||
share/pixmaps/tint2conf.png
|
||||
share/pixmaps/tint2conf.svg
|
||||
share/icons/hicolor/scalable/apps/tint2.svg
|
||||
share/icons/hicolor/scalable/apps/tint2conf.svg
|
||||
share/locale/bs/LC_MESSAGES/tint2conf.mo
|
||||
share/locale/fr/LC_MESSAGES/tint2conf.mo
|
||||
share/locale/hr/LC_MESSAGES/tint2conf.mo
|
||||
share/locale/pl/LC_MESSAGES/tint2conf.mo
|
||||
share/locale/ru/LC_MESSAGES/tint2conf.mo
|
||||
share/locale/sr/LC_MESSAGES/tint2conf.mo
|
||||
share/mime/packages/tint2conf.xml
|
||||
share/tint2/default_icon.png
|
||||
share/tint2/horizontal-dark-opaque.tint2rc
|
||||
share/tint2/horizontal-dark-transparent.tint2rc
|
||||
share/tint2/horizontal-light-opaque.tint2rc
|
||||
share/tint2/horizontal-light-transparent.tint2rc
|
||||
share/tint2/icon_and_text_1.tint2rc
|
||||
share/tint2/icon_and_text_2.tint2rc
|
||||
share/tint2/icon_and_text_3.tint2rc
|
||||
share/tint2/icon_and_text_4.tint2rc
|
||||
share/tint2/icon_only_1.tint2rc
|
||||
share/tint2/icon_only_2.tint2rc
|
||||
share/tint2/icon_only_3.tint2rc
|
||||
share/tint2/icon_only_4.tint2rc
|
||||
share/tint2/icon_only_6.tint2rc
|
||||
share/tint2/icon_only_7.tint2rc
|
||||
share/tint2/text_only_1.tint2rc
|
||||
share/tint2/text_only_2.tint2rc
|
||||
share/tint2/text_only_3.tint2rc
|
||||
share/tint2/text_only_4.tint2rc
|
||||
share/tint2/text_only_5.tint2rc
|
||||
share/tint2/text_only_6.tint2rc
|
||||
share/tint2/vertical-dark-opaque.tint2rc
|
||||
share/tint2/vertical-dark-transparent.tint2rc
|
||||
share/tint2/vertical-light-opaque.tint2rc
|
||||
share/tint2/vertical-light-transparent.tint2rc
|
||||
share/tint2/vertical-neutral-icons.tint2rc
|
||||
|
|
|
@ -1,11 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.6 2015/11/04 03:28:55 agc Exp $
|
||||
$NetBSD: distinfo,v 1.7 2017/07/28 08:42:17 tnn Exp $
|
||||
|
||||
SHA1 (tint2-0.11.tar.bz2) = 9752255529673dabf13e7437afd1cd0b39d9c92b
|
||||
RMD160 (tint2-0.11.tar.bz2) = f094e81aec1fae98a88e8392c4c9e6b5fecb6120
|
||||
SHA512 (tint2-0.11.tar.bz2) = db88c17780d24b82badbedbce4518d736dfcb2a730ff500bcb36f2b32f65271c2424f0c2a34981f9d3af033b84252db0c8217e2dd7ca57f9a0eadbc98796115c
|
||||
Size (tint2-0.11.tar.bz2) = 91716 bytes
|
||||
SHA1 (patch-aa) = 2865cdb561d856615c607d589af9040bfc95e14b
|
||||
SHA1 (patch-ab) = 41d3059bc5d329a2f8ad55e05a43ef3e2e199fec
|
||||
SHA1 (patch-ac) = 3f95a80eabb16e6417fc843f9fef1a697487426d
|
||||
SHA1 (patch-src_panel.c) = 4eee14b11eb7b5c01b852ec13ee0ce216e20eefe
|
||||
SHA1 (patch-src_systray_systraybar.c) = 3bcd5e9749cc8943115eae9bb32cd5d6a9a7b1a0
|
||||
SHA1 (tint2-0.14.6.tar.gz) = 19627ec1948ccce6e30dba3f17e4481bbb232b52
|
||||
RMD160 (tint2-0.14.6.tar.gz) = 4733f93d22b7761045831d130ee7f6374e60dfad
|
||||
SHA512 (tint2-0.14.6.tar.gz) = c27f98d8236e62ae3f71b9cedfba5a4355a49425dcc6cb49c9da0fbca6447ed2ef6844e478f88d642c92e29551c1125bc65cd254e3ac63925c859ed55c351f81
|
||||
Size (tint2-0.14.6.tar.gz) = 465895 bytes
|
||||
SHA1 (patch-aa) = ed1232cd81cbdc7770c113192cea590e9c07531f
|
||||
SHA1 (patch-get_version.sh) = 70a7df800d7687102699eb37bcb61b90b13c725a
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.3 2010/07/05 08:06:15 tnn Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2017/07/28 08:42:17 tnn Exp $
|
||||
|
||||
--- CMakeLists.txt.orig 2010-06-15 21:38:14.000000000 +0000
|
||||
--- CMakeLists.txt.orig 2017-06-11 09:15:36.000000000 +0000
|
||||
+++ CMakeLists.txt
|
||||
@@ -99,7 +99,7 @@ set_target_properties( tint2 PROPERTIES
|
||||
set_target_properties(tint2 PROPERTIES LINK_FLAGS "-pthread" )
|
||||
|
||||
@@ -257,7 +257,7 @@ set_target_properties( tint2 PROPERTIES
|
||||
install( TARGETS tint2 DESTINATION bin )
|
||||
-install( FILES sample/tint2rc DESTINATION ${SYSCONFDIR}/xdg/tint2 )
|
||||
+#install( FILES sample/tint2rc DESTINATION ${SYSCONFDIR}/xdg/tint2 )
|
||||
install( FILES default_icon.png DESTINATION ${DATADIR}/tint2 )
|
||||
install( FILES AUTHORS ChangeLog README DESTINATION ${DOCDIR} )
|
||||
install( FILES doc/tint2.1 DESTINATION ${MANDIR}/man1 )
|
||||
install( FILES tint2.svg DESTINATION ${CMAKE_INSTALL_DATADIR}/icons/hicolor/scalable/apps )
|
||||
install( FILES tint2.desktop DESTINATION ${CMAKE_INSTALL_DATADIR}/applications )
|
||||
-install( FILES themes/tint2rc DESTINATION /etc/xdg/tint2 )
|
||||
+#install( FILES themes/tint2rc DESTINATION /etc/xdg/tint2 )
|
||||
install( FILES default_icon.png DESTINATION ${CMAKE_INSTALL_DATADIR}/tint2 )
|
||||
install( FILES AUTHORS ChangeLog README.md doc/tint2.md DESTINATION ${docdir} )
|
||||
install( FILES doc/manual.html doc/readme.html DESTINATION ${htmldir} )
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2010/07/05 08:06:15 tnn Exp $
|
||||
|
||||
--- src/tint2conf/main.c.orig 2010-06-16 15:11:43.000000000 +0000
|
||||
+++ src/tint2conf/main.c
|
||||
@@ -417,7 +417,7 @@ static void menuApply()
|
||||
copy_file(g_default_theme, g_path_config);
|
||||
|
||||
// restart panel
|
||||
- system("killall -SIGUSR1 tint2");
|
||||
+ system("pkill -SIGUSR1 tint2");
|
||||
}
|
||||
}
|
||||
|
||||
@@ -580,7 +580,7 @@ void read_config()
|
||||
}
|
||||
g_width = 500;
|
||||
g_height = 350;
|
||||
- g_cmd_property = g_strconcat( "python ", INSTALL_PREFIX, "/bin/tintwizard.py", (void*)0 );
|
||||
+ g_cmd_property = g_strconcat(INSTALL_PREFIX, "/bin/tintwizard.py", (void*)0 );
|
||||
|
||||
// load config
|
||||
path = g_build_filename (g_get_user_config_dir(), "tint2", "tint2confrc", NULL);
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2010/07/05 08:14:42 tnn Exp $
|
||||
|
||||
--- src/tint2conf/tintwizard.py.orig 2010-05-09 19:00:13.000000000 +0000
|
||||
+++ src/tint2conf/tintwizard.py
|
||||
@@ -1112,7 +1112,7 @@ class TintWizardGUI(gtk.Window):
|
||||
def apply(self, widget, event=None, confirmChange=True):
|
||||
"""Applies the current config to tint2."""
|
||||
# Check if tint2 is running
|
||||
- procs = os.popen('pidof "tint2"') # Check list of active processes for tint2
|
||||
+ procs = os.popen('pgrep "^tint2$"') # Check list of active processes for tint2
|
||||
pids = [] # List of process ids for tint2
|
||||
|
||||
for proc in procs.readlines():
|
16
x11/tint2/patches/patch-get_version.sh
Normal file
16
x11/tint2/patches/patch-get_version.sh
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-get_version.sh,v 1.1 2017/07/28 08:42:17 tnn Exp $
|
||||
|
||||
avoid git dependency
|
||||
|
||||
--- get_version.sh.orig 2017-06-11 09:15:36.000000000 +0000
|
||||
+++ get_version.sh
|
||||
@@ -1,5 +1,9 @@
|
||||
#!/bin/sh
|
||||
|
||||
+set -e
|
||||
+echo '#define VERSION_STRING "'$(head -n 1 ChangeLog)'"' > version.h
|
||||
+exit 0
|
||||
+
|
||||
MAJOR=0.14
|
||||
DIRTY=""
|
||||
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_panel.c,v 1.1 2015/02/08 18:06:10 tnn Exp $
|
||||
|
||||
Strict alignment. Upstream issue #273
|
||||
|
||||
--- src/panel.c.orig 2010-06-26 12:35:35.000000000 +0000
|
||||
+++ src/panel.c
|
||||
@@ -493,7 +493,7 @@ void set_panel_properties(Panel *p)
|
||||
XChangeProperty(server.dsp, p->main_win, server.atom._MOTIF_WM_HINTS, server.atom._MOTIF_WM_HINTS, 32, PropModeReplace, (unsigned char *) prop, 5);
|
||||
|
||||
// XdndAware - Register for Xdnd events
|
||||
- int version=5;
|
||||
+ long version=5;
|
||||
XChangeProperty(server.dsp, p->main_win, server.atom.XdndAware, XA_ATOM, 32, PropModeReplace, (unsigned char*)&version, 1);
|
||||
|
||||
update_strut(p);
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_systray_systraybar.c,v 1.1 2015/02/08 18:06:10 tnn Exp $
|
||||
|
||||
Strict alignment. Upstream issue #273
|
||||
|
||||
--- src/systray/systraybar.c.orig 2010-06-09 15:31:18.000000000 +0000
|
||||
+++ src/systray/systraybar.c
|
||||
@@ -277,7 +277,7 @@ void start_net()
|
||||
|
||||
// v0.3 trayer specification. tint2 always horizontal.
|
||||
// Vertical panel will draw the systray horizontal.
|
||||
- int orient = 0;
|
||||
+ long orient = 0;
|
||||
XChangeProperty(server.dsp, net_sel_win, server.atom._NET_SYSTEM_TRAY_ORIENTATION, XA_CARDINAL, 32, PropModeReplace, (unsigned char *) &orient, 1);
|
||||
VisualID vid;
|
||||
if (server.visual32 && (systray.alpha != 100 || systray.brightness != 0 || systray.saturation != 0))
|
Loading…
Reference in a new issue