wayland: Avoid trying and failing to use posix_fallocate on NetBSD.

I can now run GTK3 programs.
This commit is contained in:
nia 2019-08-19 12:50:23 +00:00
parent 00e4e0b13a
commit 7514442af7
3 changed files with 20 additions and 2 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.1 2019/08/18 16:05:12 nia Exp $
# $NetBSD: Makefile,v 1.2 2019/08/19 12:50:23 nia Exp $
DISTNAME= wayland-1.17.0
PKGREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://wayland.freedesktop.org/releases/
EXTRACT_SUFX= .tar.xz

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.1 2019/08/18 16:05:12 nia Exp $
$NetBSD: distinfo,v 1.2 2019/08/19 12:50:23 nia Exp $
SHA1 (wayland-1.17.0.tar.xz) = 4d9e08a7a4a07fa37a25d7aa3ef83f08edec0600
RMD160 (wayland-1.17.0.tar.xz) = 635494fb0f5d9eb1e782f98e08c3e0e26ff44268
@ -6,6 +6,7 @@ SHA512 (wayland-1.17.0.tar.xz) = c5051aab5ff078b368c196ecfedb33ccd961265bb914845
Size (wayland-1.17.0.tar.xz) = 437680 bytes
SHA1 (patch-Makefile.am) = af2c47eb2e1a4924ea842aeea1d0f00832762ec0
SHA1 (patch-configure.ac) = df15013a1639d673e5f0a86433a074f6201dbbc4
SHA1 (patch-cursor_os-compatibility.c) = 9aac1c734199bc7e33e7735356bc8dbc80fba89d
SHA1 (patch-src_event-loop.c) = 04d0eed4ba0708518201ec630dab97d52735fb0c
SHA1 (patch-src_wayland-os.c) = fc1a70d4baf8311afce92a081368104b7a732e27
SHA1 (patch-src_wayland-os.h) = 2e8fb20d4adfb3666adffe48104205488b4a1c7b

View file

@ -0,0 +1,16 @@
$NetBSD: patch-cursor_os-compatibility.c,v 1.1 2019/08/19 12:50:23 nia Exp $
fallocate is currently a no-op on NetBSD.
Make sure ftruncate is used instead.
--- cursor/os-compatibility.c.orig 2019-03-21 00:55:25.000000000 +0000
+++ cursor/os-compatibility.c
@@ -129,7 +129,7 @@ os_create_anonymous_file(off_t size)
if (fd < 0)
return -1;
-#ifdef HAVE_POSIX_FALLOCATE
+#if defined(HAVE_POSIX_FALLOCATE) && !defined(__NetBSD__)
ret = posix_fallocate(fd, 0, size);
if (ret != 0) {
close(fd);