Update to 0.9, take maintainership. Changes (from NEWS):
xzgv now uses GTK 2, with gdk-pixbuf as the image rendering back-end. imlib1 is no longer supported. Gamma, brightness and contrast are not currently supported. I've also included a fix for the "missing preview icons" problem (patch-ad). OK by wiz@.
This commit is contained in:
parent
bf6f3b2dbd
commit
7517c07f8a
6 changed files with 53 additions and 142 deletions
|
@ -1,24 +1,19 @@
|
|||
# $NetBSD: Makefile,v 1.36 2008/03/04 15:39:11 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.37 2009/01/05 16:08:20 shattered Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xzgv-0.8
|
||||
PKGNAME= xzgv-0.8.0.1
|
||||
PKGREVISION= 3
|
||||
DISTNAME= xzgv-0.9
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://ftp.ibiblio.org/pub/Linux/apps/graphics/viewers/X/
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xzgv/}
|
||||
|
||||
PATCHFILES= xzgv-0.8-integer-overflow-fix.diff
|
||||
PATCH_SITES= http://rus.members.beeb.net/
|
||||
PATCH_DIST_STRIP= -p1
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://rus.members.beeb.net/xzgv.html
|
||||
MAINTAINER= shattered@NetBSD.org
|
||||
HOMEPAGE= http://sourceforge.net/projects/xzgv
|
||||
COMMENT= Image viewer
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_X11BASE= yes
|
||||
USE_TOOLS+= gmake makeinfo
|
||||
INFO_FILES= # PLIST
|
||||
INFO_FILES= yes
|
||||
INSTALLATION_DIRS= bin ${PKGINFODIR} ${PKGMANDIR}/man1
|
||||
|
||||
do-install:
|
||||
|
@ -31,5 +26,5 @@ do-install:
|
|||
${INSTALL_DATA} "$$f" ${DESTDIR}${PREFIX}/${PKGINFODIR};\
|
||||
done
|
||||
|
||||
.include "../../graphics/imlib/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,11 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.9 2006/09/23 14:59:34 adrianp Exp $
|
||||
$NetBSD: distinfo,v 1.10 2009/01/05 16:08:20 shattered Exp $
|
||||
|
||||
SHA1 (xzgv-0.8-integer-overflow-fix.diff) = b18dfdaafe295e2c42764f59784b6b6201b489ea
|
||||
RMD160 (xzgv-0.8-integer-overflow-fix.diff) = bd75c87cf6f20e4fa2757afe472111e2253cb640
|
||||
Size (xzgv-0.8-integer-overflow-fix.diff) = 6374 bytes
|
||||
SHA1 (xzgv-0.8.tar.gz) = 1aa21336e2562849e6f5f984cbbfcb745489df3b
|
||||
RMD160 (xzgv-0.8.tar.gz) = e36466a73c27616610fd032b3a92898d95a55a17
|
||||
Size (xzgv-0.8.tar.gz) = 302801 bytes
|
||||
SHA1 (patch-aa) = 7a0d6e6b24d788fb9cf45967e4c3b434c621def3
|
||||
SHA1 (patch-ab) = cf4c746e3c4b9ac3a5968211a8f2c0b69d43bc99
|
||||
SHA1 (patch-ac) = 3a67b625b6eabd0c6e2399fb0a59fde4460d3893
|
||||
SHA1 (xzgv-0.9.tar.gz) = 5d8115c87be3836d9ed35dba777cd1dc48541715
|
||||
RMD160 (xzgv-0.9.tar.gz) = 7c3284eac5a0a368db1be2ed87f882e26d39fab7
|
||||
Size (xzgv-0.9.tar.gz) = 235367 bytes
|
||||
SHA1 (patch-aa) = fa502e0fc4fc94cfc88c4aa41505ac7563d982a6
|
||||
SHA1 (patch-ad) = 378e0c2e19064c2c276c6e0a3e89bdcbcc2c96c5
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.3 2001/08/23 15:56:41 jlam Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2009/01/05 16:08:20 shattered Exp $
|
||||
|
||||
--- config.mk.orig Sun Jan 7 23:57:44 2001
|
||||
--- config.mk.orig 2007-08-12 10:14:42.000000000 +0000
|
||||
+++ config.mk
|
||||
@@ -6,8 +6,8 @@
|
||||
# Set the C compiler to use, and options for it.
|
||||
|
@ -13,21 +13,12 @@ $NetBSD: patch-aa,v 1.3 2001/08/23 15:56:41 jlam Exp $
|
|||
|
||||
# Set the awk interpreter to use for a script used while compiling.
|
||||
# (This should be a `new' awk, such as gawk or mawk.)
|
||||
@@ -27,7 +27,7 @@
|
||||
# On non-x86-based machines (e.g. Alpha, Sparc, PPC), you should
|
||||
# comment it out.
|
||||
#
|
||||
-CFLAGS+=-DINTERP_MMX
|
||||
+#CFLAGS+=-DINTERP_MMX
|
||||
|
||||
# Set rendering backend to use. Currently only Imlib 1.x is properly
|
||||
# supported, so leave this alone. :-)
|
||||
@@ -45,7 +45,7 @@
|
||||
@@ -24,7 +24,7 @@ AWK=awk
|
||||
# MANDIR to directory for man page.
|
||||
# Usually it will be simpler to just set PREFIX.
|
||||
#
|
||||
-PREFIX=/usr/local
|
||||
+#PREFIX=/usr/local
|
||||
|
||||
# In theory it would be nice to put the info file and man page under
|
||||
# /usr/local/share. However, it's not clear if this is widely
|
||||
BINDIR=$(PREFIX)/bin
|
||||
INFODIR=$(PREFIX)/share/info
|
||||
MANDIR=$(PREFIX)/share/man/man1
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.4 2002/09/23 01:29:06 jlam Exp $
|
||||
|
||||
--- src/Makefile.orig Tue Apr 10 05:37:01 2001
|
||||
+++ src/Makefile
|
||||
@@ -30,7 +30,7 @@ BACKEND_LIBS=`case "$(BACKEND)" in \
|
||||
# compile when you do `make install'. :-)
|
||||
# (It would also be weird to have it made by the `doc' Makefile, IMHO.)
|
||||
|
||||
-all: xzgv install-info
|
||||
+all: xzgv
|
||||
|
||||
OBJS= main.o \
|
||||
filedetails.o gotodir.o updatetn.o confirm.o help.o \
|
||||
@@ -43,7 +43,7 @@ OBJS= main.o \
|
||||
backend.o
|
||||
|
||||
xzgv: $(OBJS)
|
||||
- $(CC) $(CFLAGS) -o xzgv $(OBJS) $(BACKEND_LIBS) -ljpeg -lpng -ltiff -lz
|
||||
+ $(CC) $(CPPFLAGS) $(CFLAGS) -o xzgv $(OBJS) $(BACKEND_LIBS) $(LDFLAGS) -ljpeg -lpng -ltiff -lz
|
||||
|
||||
backend.o:
|
||||
$(CC) $(CFLAGS) $(BACKEND_CFLAGS) -c -o backend.o backend.c
|
|
@ -1,82 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.3 2006/09/23 14:59:34 adrianp Exp $
|
||||
|
||||
--- src/readjpeg.c.orig 2006-09-23 15:52:41.000000000 +0100
|
||||
+++ src/readjpeg.c
|
||||
@@ -179,11 +179,13 @@ static unsigned char **lineptrs;
|
||||
static int have_image;
|
||||
static int width,height;
|
||||
static unsigned char *image;
|
||||
+static int cmyk;
|
||||
unsigned char *ptr,*ptr2;
|
||||
int chkw,chkh;
|
||||
int f,rec;
|
||||
static int greyscale; /* static to satisfy gcc -Wall */
|
||||
|
||||
+cmyk=0;
|
||||
greyscale=0;
|
||||
|
||||
lineptrs=NULL;
|
||||
@@ -225,6 +227,15 @@ if(cinfo.jpeg_color_space==JCS_GRAYSCALE
|
||||
greyscale=1;
|
||||
}
|
||||
|
||||
+if(cinfo.jpeg_color_space==JCS_CMYK)
|
||||
+ cmyk=1;
|
||||
+
|
||||
+if(cinfo.jpeg_color_space==JCS_YCCK)
|
||||
+ {
|
||||
+ cmyk=1;
|
||||
+ cinfo.out_color_space=JCS_CMYK;
|
||||
+ }
|
||||
+
|
||||
*wp=width=cinfo.image_width;
|
||||
*hp=height=cinfo.image_height;
|
||||
|
||||
@@ -266,7 +277,7 @@ if(!careful_jpeg)
|
||||
/* this one shouldn't hurt */
|
||||
cinfo.do_block_smoothing=FALSE;
|
||||
|
||||
-if(WH_BAD(width,height) || (*imagep=image=malloc(width*height*3))==NULL)
|
||||
+if(WH_BAD(width,height) || (*imagep=image=malloc(width*(height+cmyk)*3))==NULL)
|
||||
longjmp(jerr.setjmp_buffer,1);
|
||||
|
||||
jpeg_start_decompress(&cinfo);
|
||||
@@ -279,12 +290,33 @@ ptr=image+width*2*greyscale; /* put data
|
||||
for(f=0;f<height;f++,ptr+=width*3)
|
||||
lineptrs[f]=ptr;
|
||||
|
||||
-rec=cinfo.rec_outbuf_height;
|
||||
-while(cinfo.output_scanline<height)
|
||||
+if(!cmyk)
|
||||
{
|
||||
- f=height-cinfo.output_scanline;
|
||||
- jpeg_read_scanlines(&cinfo,lineptrs+cinfo.output_scanline,
|
||||
- f>rec?rec:f);
|
||||
+ rec=cinfo.rec_outbuf_height;
|
||||
+ while(cinfo.output_scanline<height)
|
||||
+ {
|
||||
+ f=height-cinfo.output_scanline;
|
||||
+ jpeg_read_scanlines(&cinfo,lineptrs+cinfo.output_scanline,
|
||||
+ f>rec?rec:f);
|
||||
+ }
|
||||
+ }
|
||||
+else /* cmyk output */
|
||||
+ {
|
||||
+ int tmp;
|
||||
+
|
||||
+ ptr=image;
|
||||
+ while(cinfo.output_scanline<height)
|
||||
+ {
|
||||
+ jpeg_read_scanlines(&cinfo,&ptr,1);
|
||||
+ ptr2=ptr;
|
||||
+ for(f=0;f<width;f++,ptr+=3,ptr2+=4)
|
||||
+ {
|
||||
+ tmp=ptr2[3];
|
||||
+ ptr[0]=(tmp*ptr2[0])/255;
|
||||
+ ptr[1]=(tmp*ptr2[1])/255;
|
||||
+ ptr[2]=(tmp*ptr2[2])/255;
|
||||
+ }
|
||||
+ }
|
||||
}
|
||||
|
||||
free(lineptrs);
|
33
graphics/xzgv/patches/patch-ad
Normal file
33
graphics/xzgv/patches/patch-ad
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-ad,v 1.1 2009/01/05 16:08:20 shattered Exp $
|
||||
|
||||
Proposed fix for "missing preview icons" problem, from
|
||||
http://sourceforge.net/tracker/index.php?func=detail&aid=1814712&group_id=203093&atid=984206
|
||||
|
||||
--- src/main.c.orig 2007-09-09 00:36:21.000000000 +0000
|
||||
+++ src/main.c
|
||||
@@ -200,7 +200,7 @@ int orient_state_flip[8] ={2,3,0,1,6,7
|
||||
/* required prototypes */
|
||||
void render_pixmap(int reset_pos);
|
||||
void cb_nextprev_tagged_image(int next,int view);
|
||||
-void idle_xvpic_load(int *entryp);
|
||||
+gint idle_xvpic_load(int *entryp);
|
||||
gint pic_win_resized(GtkWidget *widget,GdkEventConfigure *event);
|
||||
void cb_scaling_double(void);
|
||||
void cb_xscaling_double(void);
|
||||
@@ -2624,7 +2624,7 @@ else
|
||||
}
|
||||
|
||||
|
||||
-void idle_xvpic_load(int *entryp)
|
||||
+gint idle_xvpic_load(int *entryp)
|
||||
{
|
||||
static char buf[1024];
|
||||
struct clist_data_tag *datptr;
|
||||
@@ -2748,6 +2748,7 @@ for(f=0;f<IDLE_XVPIC_NUM_PER_CALL;f++)
|
||||
*entryp=-1;
|
||||
}
|
||||
}
|
||||
+ return TRUE;
|
||||
}
|
||||
|
||||
|
Loading…
Reference in a new issue