This program enables the IBM Thinkpad(tm) special keys. It is possible to bind
a program to the ThinkPad button. It has a on-screen display (OSD) to show volume, mute and brightness of the LCD.
This commit is contained in:
parent
55293024b8
commit
75247caf8d
6 changed files with 73 additions and 0 deletions
3
sysutils/tpb/DESCR
Normal file
3
sysutils/tpb/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
This program enables the IBM Thinkpad(tm) special keys. It is possible to bind
|
||||
a program to the ThinkPad button. It has a on-screen display (OSD) to show
|
||||
volume, mute and brightness of the LCD.
|
26
sysutils/tpb/Makefile
Normal file
26
sysutils/tpb/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# $NetBSD: Makefile,v 1.1 2004/02/02 15:49:17 soren Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tpb-0.6.1
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://savannah.nongnu.org/download/tpb/
|
||||
|
||||
MAINTAINER= soren@NetBSD.org
|
||||
HOMEPAGE= http://www.nongnu.org/tpb/
|
||||
COMMENT= Utility to enable the IBM ThinkPad(tm) special keys
|
||||
|
||||
ONLY_FOR_PLATFORM= *-*-i386
|
||||
|
||||
USE_X11= YES
|
||||
USE_BUILDLINK2= YES
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/tpb
|
||||
.for f in callback_example.sh nvram.txt tpbrc
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${PREFIX}/share/doc/tpb
|
||||
.endfor
|
||||
|
||||
.include "../../x11/xosd/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
6
sysutils/tpb/PLIST
Normal file
6
sysutils/tpb/PLIST
Normal file
|
@ -0,0 +1,6 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2004/02/02 15:49:17 soren Exp $
|
||||
bin/tpb
|
||||
share/doc/tpb/callback_example.sh
|
||||
share/doc/tpb/nvram.txt
|
||||
share/doc/tpb/tpbrc
|
||||
@dirrm share/doc/tpb
|
6
sysutils/tpb/distinfo
Normal file
6
sysutils/tpb/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2004/02/02 15:49:17 soren Exp $
|
||||
|
||||
SHA1 (tpb-0.6.1.tar.gz) = 096e00055a6cb56e98af850415b30dfce028442c
|
||||
Size (tpb-0.6.1.tar.gz) = 193520 bytes
|
||||
SHA1 (patch-aa) = 9bef74177f7754bea5f38df6de113eef8fec905d
|
||||
SHA1 (patch-ab) = a1e1d328f1fff84c3c10bcbfa093399c6d9917d6
|
11
sysutils/tpb/patches/patch-aa
Normal file
11
sysutils/tpb/patches/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/Makefile.in.orig 2004-02-02 16:45:59.000000000 +0100
|
||||
+++ src/Makefile.in 2004-02-02 16:46:29.000000000 +0100
|
||||
@@ -182,7 +182,7 @@
|
||||
|
||||
tpb: $(tpb_OBJECTS) $(tpb_DEPENDENCIES)
|
||||
@rm -f tpb
|
||||
- $(LINK) $(tpb_LDFLAGS) $(tpb_OBJECTS) $(tpb_LDADD) $(LIBS)
|
||||
+ $(LINK) $(tpb_LDFLAGS) $(tpb_OBJECTS) $(tpb_LDADD) $(LIBS) -R${LOCALBASE}/lib -R${X11BASE}/lib -lintl -lossaudio
|
||||
|
||||
tags: TAGS
|
||||
|
21
sysutils/tpb/patches/patch-ab
Normal file
21
sysutils/tpb/patches/patch-ab
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- src/tpb.c.orig 2004-02-02 15:46:17.000000000 +0100
|
||||
+++ src/tpb.c 2004-02-02 15:47:17.000000000 +0100
|
||||
@@ -22,14 +22,16 @@
|
||||
#include <ctype.h>
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
-#include <linux/soundcard.h>
|
||||
+#include <sys/soundcard.h>
|
||||
+#include <sys/wait.h>
|
||||
+#include <locale.h>
|
||||
+#include <signal.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/types.h>
|
||||
#include <unistd.h>
|
||||
-#include <wait.h>
|
||||
#include <X11/Xlib.h>
|
||||
#include "config.h"
|
||||
|
Loading…
Reference in a new issue