Decouple tests from build. Skip creating sysdeps, nothing uses it.
This commit is contained in:
parent
333affc350
commit
759200a5f9
3 changed files with 26 additions and 8 deletions
|
@ -1,4 +1,4 @@
|
||||||
# $NetBSD: Makefile,v 1.46 2020/11/19 09:35:43 schmonz Exp $
|
# $NetBSD: Makefile,v 1.47 2022/05/15 17:26:31 schmonz Exp $
|
||||||
|
|
||||||
DISTNAME= daemontools-0.76
|
DISTNAME= daemontools-0.76
|
||||||
PKGREVISION= 3
|
PKGREVISION= 3
|
||||||
|
@ -18,6 +18,7 @@ CONFLICTS+= daemontools-encore-[0-9]*
|
||||||
|
|
||||||
WRKSRC= ${WRKDIR}/admin/${PKGNAME_NOREV}
|
WRKSRC= ${WRKDIR}/admin/${PKGNAME_NOREV}
|
||||||
DJB_SLASHPACKAGE= YES
|
DJB_SLASHPACKAGE= YES
|
||||||
|
TEST_TARGET= rts
|
||||||
|
|
||||||
CMDDIR= ${WRKSRC}/command
|
CMDDIR= ${WRKSRC}/command
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.11 2021/10/26 11:19:28 nia Exp $
|
$NetBSD: distinfo,v 1.12 2022/05/15 17:26:31 schmonz Exp $
|
||||||
|
|
||||||
BLAKE2s (daemontools-0.76-man-20020131.tar.gz) = 8ee7328243c279426cb4b6ea48ec993886eaea1e2778dc877e1c32372f692e8f
|
BLAKE2s (daemontools-0.76-man-20020131.tar.gz) = 8ee7328243c279426cb4b6ea48ec993886eaea1e2778dc877e1c32372f692e8f
|
||||||
SHA512 (daemontools-0.76-man-20020131.tar.gz) = 1767fafb2d92902f903637f08363031971bda007d1b7b53059551c740976d1c643229ccc44171796c1dcb43cbd875a17178edc634e140671817e0ef0ba3ad80b
|
SHA512 (daemontools-0.76-man-20020131.tar.gz) = 1767fafb2d92902f903637f08363031971bda007d1b7b53059551c740976d1c643229ccc44171796c1dcb43cbd875a17178edc634e140671817e0ef0ba3ad80b
|
||||||
|
@ -9,4 +9,4 @@ Size (daemontools-0.76.sigq12.patch) = 1975 bytes
|
||||||
BLAKE2s (daemontools-0.76.tar.gz) = de1cc5249edbdbe3b8a3f0ab33b90068c965b936c952c336672e122d37bca6b0
|
BLAKE2s (daemontools-0.76.tar.gz) = de1cc5249edbdbe3b8a3f0ab33b90068c965b936c952c336672e122d37bca6b0
|
||||||
SHA512 (daemontools-0.76.tar.gz) = e4a7938352b745a03ccc41acdddba1e6782f0ca245e5cae060de62ab6c5a23c841a994c30140298d274405a7f26d53ba7e84e5810a3d185b2c01e4c0feffe6c7
|
SHA512 (daemontools-0.76.tar.gz) = e4a7938352b745a03ccc41acdddba1e6782f0ca245e5cae060de62ab6c5a23c841a994c30140298d274405a7f26d53ba7e84e5810a3d185b2c01e4c0feffe6c7
|
||||||
Size (daemontools-0.76.tar.gz) = 36975 bytes
|
Size (daemontools-0.76.tar.gz) = 36975 bytes
|
||||||
SHA1 (patch-src_Makefile) = 63795c7546d3248911e0d47194baccd8440547f5
|
SHA1 (patch-src_Makefile) = 445729d6e8f71ac1911db4b472ffe07ccb8608bb
|
||||||
|
|
|
@ -1,14 +1,31 @@
|
||||||
$NetBSD: patch-src_Makefile,v 1.1 2017/10/03 00:21:44 schmonz Exp $
|
$NetBSD: patch-src_Makefile,v 1.2 2022/05/15 17:26:31 schmonz Exp $
|
||||||
|
|
||||||
Use a pkgsrc-capable shell on all platforms.
|
Use a pkgsrc-capable shell on all platforms.
|
||||||
|
Run the tests separately from the build.
|
||||||
|
Skip creating sysdeps, nothing uses it.
|
||||||
|
|
||||||
--- src/Makefile.orig 2001-07-12 16:49:49.000000000 +0000
|
--- src/Makefile.orig 2001-07-12 16:49:49.000000000 +0000
|
||||||
+++ src/Makefile
|
+++ src/Makefile
|
||||||
@@ -265,7 +265,7 @@ readproctitle.o: compile error.h readpro
|
@@ -177,7 +177,9 @@ iopause.h: choose compile iopause.h1 iop
|
||||||
rts: envdir envuidgid fghack matchtest multilog pgrphack \
|
iopause.o: compile iopause.c iopause.h select.h tai.h taia.h uint64.h
|
||||||
readproctitle rts.tests setlock setuidgid softlimit supervise svc \
|
./compile iopause.c
|
||||||
svok svscan svscanboot svstat tai64n tai64nlocal
|
|
||||||
|
-it: rts sysdeps
|
||||||
|
+it: envdir envuidgid fghack matchtest multilog pgrphack \
|
||||||
|
+readproctitle rts.tests setlock setuidgid softlimit supervise svc \
|
||||||
|
+svok svscan svscanboot svstat tai64n tai64nlocal
|
||||||
|
|
||||||
|
load: conf-ld print-ld.sh systype warn-auto.sh
|
||||||
|
rm -f load
|
||||||
|
@@ -262,10 +264,8 @@ readproctitle: byte.a load readproctitle
|
||||||
|
readproctitle.o: compile error.h readproctitle.c
|
||||||
|
./compile readproctitle.c
|
||||||
|
|
||||||
|
-rts: envdir envuidgid fghack matchtest multilog pgrphack \
|
||||||
|
-readproctitle rts.tests setlock setuidgid softlimit supervise svc \
|
||||||
|
-svok svscan svscanboot svstat tai64n tai64nlocal
|
||||||
- env - /bin/sh rts.tests 2>&1 | cat -v > rts
|
- env - /bin/sh rts.tests 2>&1 | cat -v > rts
|
||||||
|
+rts:
|
||||||
+ env - ${PKGSRC_SHELL} rts.tests 2>&1 | cat -v > rts
|
+ env - ${PKGSRC_SHELL} rts.tests 2>&1 | cat -v > rts
|
||||||
|
|
||||||
scan_ulong.o: compile scan.h scan_ulong.c
|
scan_ulong.o: compile scan.h scan_ulong.c
|
||||||
|
|
Loading…
Reference in a new issue