Fix creating proper build_info directory.
Bump PKGREVISION.
This commit is contained in:
parent
5cd9bb962d
commit
75b049003e
3 changed files with 17 additions and 6 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.52 2013/06/15 02:12:48 taca Exp $
|
||||
# $NetBSD: Makefile,v 1.53 2013/07/07 15:02:56 taca Exp $
|
||||
|
||||
DISTNAME= rubygems-2.0.3
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= misc ruby
|
||||
MASTER_SITES= http://production.cf.rubygems.org/rubygems/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.41 2013/06/15 02:12:48 taca Exp $
|
||||
$NetBSD: distinfo,v 1.42 2013/07/07 15:02:56 taca Exp $
|
||||
|
||||
SHA1 (rubygems-2.0.3.tgz) = 51b2d002874a30ae729bcc48a3a0c5983ffb508b
|
||||
RMD160 (rubygems-2.0.3.tgz) = e2abad996a2380ba5f764a55304c3e416b715080
|
||||
|
@ -6,7 +6,7 @@ Size (rubygems-2.0.3.tgz) = 334203 bytes
|
|||
SHA1 (patch-aa) = 02958c28dc9da54bf6d9f854335aa8d8e071497b
|
||||
SHA1 (patch-ab) = 9339a71c9c45b8990d72075a68a8992a40b8c0d0
|
||||
SHA1 (patch-ac) = 1a59a5d2fc090dfcf6d3bd3b9c133f0ce4a1feee
|
||||
SHA1 (patch-ad) = de5b5a08035c2da3e8b08bcc5295d3998f13a854
|
||||
SHA1 (patch-ad) = 17e1c7fe9cb7de2c08e8d11a94dcbea082c3b4d1
|
||||
SHA1 (patch-af) = d96d5dafd830b0c94bf6c191a3274701ebc6d564
|
||||
SHA1 (patch-ag) = 5b94252ea03eba04849770bc141dfc58de932389
|
||||
SHA1 (patch-ah) = dd50c10662c0a295a8790446f9cd7159d0b498dd
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ad,v 1.11 2013/06/11 14:55:54 taca Exp $
|
||||
$NetBSD: patch-ad,v 1.12 2013/07/07 15:02:56 taca Exp $
|
||||
|
||||
* Add install_root option for pkgsrc's rubygems support.
|
||||
|
||||
--- lib/rubygems/installer.rb.orig 2013-02-21 21:50:03.000000000 +0000
|
||||
--- lib/rubygems/installer.rb.orig 2013-03-05 21:25:39.000000000 +0000
|
||||
+++ lib/rubygems/installer.rb
|
||||
@@ -89,6 +89,9 @@ class Gem::Installer
|
||||
# foo_exec18.
|
||||
|
@ -39,3 +39,14 @@ $NetBSD: patch-ad,v 1.11 2013/06/11 14:55:54 taca Exp $
|
|||
|
||||
@build_args = options[:build_args] || Gem::Command.build_args
|
||||
end
|
||||
@@ -773,7 +782,9 @@ EOF
|
||||
def write_build_info_file
|
||||
return if @build_args.empty?
|
||||
|
||||
- open spec.build_info_file, 'w' do |io|
|
||||
+ build_info_file = (@options[:install_root].nil?) ? spec.build_info_file :
|
||||
+ File.join(@options[:install_root], spec.build_info_file)
|
||||
+ open build_info_file, 'w' do |io|
|
||||
@build_args.each do |arg|
|
||||
io.puts arg
|
||||
end
|
||||
|
|
Loading…
Reference in a new issue