Adding new package for CPAN module Wx::Scintilla version 0.39 as requirement

of scheduled update of editors/p5-Padre package into editors/p5-Wx-Scintilla.

Scintilla is a contributed project which means it will not be the latest
by the time a new wxWidgets distribution is released. And on the scintilla
front, the Perl 5 lexer is not 100% bug free even and we do not have any
kind of Perl 6 support in Scintilla.

The ambitious goal of this project is to provide fresh Perl 5 and maybe 6
support in Wx while preserving compatibility with Wx::StyledTextCtrl and
continually contribute it back to Scintilla project.
This commit is contained in:
sno 2012-09-13 14:14:01 +00:00
parent 0943949c13
commit 75b2e3bfe2
4 changed files with 57 additions and 0 deletions

View file

@ -0,0 +1,8 @@
Scintilla is a contributed project which means it will not be the latest
by the time a new wxWidgets distribution is released. And on the scintilla
front, the Perl 5 lexer is not 100% bug free even and we do not have any
kind of Perl 6 support in Scintilla.
The ambitious goal of this project is to provide fresh Perl 5 and maybe 6
support in Wx while preserving compatibility with Wx::StyledTextCtrl and
continually contribute it back to Scintilla project.

View file

@ -0,0 +1,30 @@
# $NetBSD: Makefile,v 1.1 2012/09/13 14:14:01 sno Exp $
DISTNAME= Wx-Scintilla-0.39
PKGNAME= p5-${DISTNAME}
CATEGORIES= editor x11 perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Wx/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://search.cpan.org/dist/Wx-Scintilla/
COMMENT= Scintilla source code editing component for wxWidgets
LICENSE= ${PERL5_LICENSE}
BUILD_DEPENDS+= p5-Alien-wxWidgets-[0-9]*:../../x11/p5-Alien-wxWidgets
BUILD_DEPENDS+= {perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
PKG_DESTDIR_SUPPORT= user-destdir
MAKE_ENV+= LD_LIBRARY_PATH=${WRKSRC}/blib/arch/auto/Wx/Scintilla
USE_TOOLS+= perl
USE_LANGUAGES+= c c++
PERL5_PACKLIST= auto/Wx/Scintilla/.packlist
PERL5_MODULE_TYPE= Module::Build
BUILDLINK_DEPMETHOD.p5-Wx= build
.include "../../x11/p5-Wx/buildlink3.mk"
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2012/09/13 14:14:01 sno Exp $
SHA1 (Wx-Scintilla-0.39.tar.gz) = 40cb8b7b7ae0b8bb418d7c885022b821369ce42e
RMD160 (Wx-Scintilla-0.39.tar.gz) = d487ca7bb79ca5581f36fb8ca6e7a1a6649522ba
Size (Wx-Scintilla-0.39.tar.gz) = 848565 bytes
SHA1 (patch-aa) = 259d5d0ef26f43e18ff824f66582b1cf11815894

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2012/09/13 14:14:01 sno Exp $
--- inc/Module/Build/Scintilla/GTK.pm.orig 2012-09-04 10:20:47.000000000 +0000
+++ inc/Module/Build/Scintilla/GTK.pm
@@ -146,7 +146,7 @@ sub stc_link_xs {
'-Lblib/arch/auto/Wx/Scintilla ' . $self->stc_scintilla_link,
Alien::wxWidgets->libraries(qw(core base)),
$Config{perllibs},
- "-Wl,-rpath,'\$ORIGIN'",
+ "-Wl,-rpath,'" . File::Spec->catdir( $Config{vendorarch}, "auto/Wx/Scintilla" ) . "'",
);
$self->_run_command( \@cmd );