Initial import of Mark Henderson's multi-precision maths (hello mid-Atlantic

divide) fgmp-1.0b5 routines into the Packages Collection:

	FGMP is Mark Henderson's public domain implementation of a subset of
	the GNU gmp library with the same API.  The fgmp library also includes
	a couple of extra routines.
This commit is contained in:
agc 2007-01-03 07:53:37 +00:00
parent 7868be43f9
commit 75c02da60c
5 changed files with 54 additions and 0 deletions

3
math/fgmp/DESCR Normal file
View file

@ -0,0 +1,3 @@
FGMP is Mark Henderson's public domain implementation of a subset of
the GNU gmp library with the same API. The fgmp library also includes
a couple of extra routines.

28
math/fgmp/Makefile Normal file
View file

@ -0,0 +1,28 @@
# $NetBSD: Makefile,v 1.1.1.1 2007/01/03 07:53:37 agc Exp $
DISTNAME= fgmp-1.0b5-src-10.10
PKGNAME= fgmp-1.0b5
CATEGORIES= math
MASTER_SITES= http://hpux.cs.utah.edu/hppd/cgi-bin/redirect?hpux/Maths/Misc/fgmp-1.0b5/
MAINTAINER= pkgsrc-user@NetBSD.org
HOMEPAGE= http://hpux.cs.utah.edu/hppd/hpux/Maths/Misc/fgmp-1.0b5/
COMMENT= Minimalist free re-implementation of GNU multi-precision routines
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
USE_LIBTOOL= yes
do-configure:;
do-build:
cd ${WRKSRC} && ( \
${LIBTOOL} --mode=compile ${CC} -O -c gmp.c; \
${LIBTOOL} --mode=link ${CC} -o libfgmp.la gmp.lo \
-rpath ${PREFIX}/lib -version-info 1:0; \
)
do-install:
cd ${WRKSRC} && ${LIBTOOL} --mode=install ${INSTALL_LIB} libfgmp.la ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/gmp.h ${PREFIX}/include/fgmp.h
.include "../../mk/bsd.pkg.mk"

3
math/fgmp/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2007/01/03 07:53:37 agc Exp $
include/fgmp.h
lib/libfgmp.la

6
math/fgmp/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2007/01/03 07:53:37 agc Exp $
SHA1 (fgmp-1.0b5-src-10.10.tar.gz) = ff34ef4033958ad3ad130b74aea8b7e16acfb6bc
RMD160 (fgmp-1.0b5-src-10.10.tar.gz) = b85db676643fab4b5af18372fb719b6946cf11cf
Size (fgmp-1.0b5-src-10.10.tar.gz) = 13429 bytes
SHA1 (patch-aa) = 78b2dc3acd641e9b5b96e7de2f4ab12d71028ed1

View file

@ -0,0 +1,14 @@
$NetBSD: patch-aa,v 1.1.1.1 2007/01/03 07:53:37 agc Exp $
Silence compiler warnings
--- gmp.h 2006/12/29 14:27:44 1.1
+++ gmp.h 2006/12/29 14:28:02
@@ -21,6 +21,7 @@
*/
#include <stdio.h>
+#include <string.h>
#include <sys/types.h>
/* for malloc and free */