Initial import of rox-archive 0.1.2 into the NetBSD packages collection.

This is a simple ROX application for creating compressed tar files
and for extracting various kinds of archive.

Supplied by Rui-Xiang Guo in PR#16317. Thanks!
This commit is contained in:
cjep 2002-06-15 13:23:08 +00:00
parent d6c1d0cd60
commit 75c95f7da2
5 changed files with 90 additions and 0 deletions

View file

@ -0,0 +1,2 @@
This is a simple ROX application for creating compressed tar files
and for extracting various kinds of archive.

View file

@ -0,0 +1,36 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/06/15 13:23:08 cjep Exp $
#
DISTNAME= Archive-0.1.2
PKGNAME= rox-archive-0.1.2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=rox/}
EXTRACT_SUFX= .tgz
MAINTAINER= rxg@netbsd.org
HOMEPAGE= http://rox.sourceforge.net/
COMMENT= simple archiver
DEPENDS+= rox-lib>=0.1.4:../../sysutils/rox-lib
DIST_SUBDIR= rox
USE_PERL5= yes
NO_CONFIGURE= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/Archive
APPDIR= ${PREFIX}/share/rox
post-patch:
${CP} ${WRKSRC}/AppRun ${WRKSRC}/AppRun.1
${SED} -e s:@APPDIR@:"${APPDIR}":g < ${WRKSRC}/AppRun.1 \
> ${WRKSRC}/AppRun
${RM} ${WRKSRC}/AppRun.1 ${WRKSRC}/AppRun.orig
do-install:
${CP} -Rf ${WRKSRC} ${APPDIR}
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,7 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/06/15 13:23:08 cjep Exp $
share/rox/Archive/AppIcon.xpm
share/rox/Archive/AppRun
share/rox/Archive/Help/COPYING
share/rox/Archive/Help/README
@dirrm share/rox/Archive/Help
@dirrm share/rox/Archive

View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2002/06/15 13:23:08 cjep Exp $
SHA1 (rox/Archive-0.1.2.tgz) = 0c0e3f81faa0f18a7d2af3502757dea5e4bac3a1
Size (rox/Archive-0.1.2.tgz) = 11602 bytes
SHA1 (patch-aa) = 2dea1b3f2950cbd8a4c41a3e806f6611cc408a04

View file

@ -0,0 +1,40 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/06/15 13:23:08 cjep Exp $
--- AppRun.orig Sun Jul 9 18:22:31 2000
+++ AppRun
@@ -30,6 +30,8 @@
"Drop an archive onto me and I'll extract it.";
}
+$savebox = "@APPDIR@/ROX-Lib/bin/savebox";
+
$path = $ARGV[0];
# Convert relative paths to absolute (we may chdir() later).
@@ -65,7 +67,7 @@
chdir $dir;
system "tar cf - \"$leaf\" | gzip -c - | " .
- "savebox -t application/x-compressed-tar \"$leaf.tgz\"";
+ "$savebox -t application/x-compressed-tar \"$leaf.tgz\"";
}
sub unarchive {
@@ -154,7 +156,7 @@
}
else {
die unless $extract_stdout;
- system "$extract_stdout | savebox -t text/plain \"$found\"";
+ system "$extract_stdout | $savebox -t text/plain \"$found\"";
}
} else {
die unless $extract;
@@ -181,7 +183,7 @@
my $leaf = shift;
my $dir;
- chop ($dir = `savebox -d \"$leaf\"`);
+ chop ($dir = `$savebox -d \"$leaf\"`);
return $dir if $dir;