sysutils/py-Glances: Update to 3.2.7

Changes since 3.2.6.4:

===============
Version 3.2.7
===============

Enhancements:

    * Config to disable all plugins by default (or enable an exclusive list) #2089
    * Keybind(s) for modifying nice level #2081
    * [WEBUI] Reorganize help screen #2037
    * Add a Json stdout option #2060
    * Improve error message when export error occures
    * Improve error message when MQTT error occures
    * Change the way core are displayed
    * Remove unused key in the process list
    * Refactor top menu of the curse interface
    * Improve Irix display for the load plugin

Bug corrected:

    * In the sensor plugin thresholds in the configuration file should overwrite system ones #2058
    * Drive names truncated in Web UI #2055
    * Correct issue with CPU label

Documentation and CI:

    * Improve makefile help #2078
    * Add quote to the update command line (already ok for the installation). Related to #2073
    * Make Glances (almost) compliant with REUSE #2042
    * Update README for Debian package users
    * Update documentation for Docker
    * Update docs for new shortcut
    * Disable Pyright on the Git actions pipeline
    * Refactor comments
    * Except datutil import error
    * Another dep issue solved in the Alpine Docker + issue in the outdated method

Contributors for this version:

    * Nicolargo
    * Sylvain MOUQUET
    * FastThenLeft
    * Jiajie Chen
    * dbrennand
    * ewuerger
This commit is contained in:
fox 2022-08-08 09:28:06 +00:00
parent 94c6547607
commit 75cbf623e4
5 changed files with 20 additions and 17 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.19 2022/06/08 06:11:34 fox Exp $
# $NetBSD: Makefile,v 1.20 2022/08/08 09:28:06 fox Exp $
DISTNAME= Glances-3.2.6.4
DISTNAME= Glances-3.2.7
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= sysutils python
MASTER_SITES= ${MASTER_SITE_PYPI:=G/Glances/}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2022/05/07 08:06:51 fox Exp $
@comment $NetBSD: PLIST,v 1.10 2022/08/08 09:28:06 fox Exp $
bin/glances-${PYVERSSUFFIX}
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
@ -171,6 +171,9 @@ ${PYSITELIB}/glances/outputs/glances_stdout_csv.pyo
${PYSITELIB}/glances/outputs/glances_stdout_issue.py
${PYSITELIB}/glances/outputs/glances_stdout_issue.pyc
${PYSITELIB}/glances/outputs/glances_stdout_issue.pyo
${PYSITELIB}/glances/outputs/glances_stdout_json.py
${PYSITELIB}/glances/outputs/glances_stdout_json.pyc
${PYSITELIB}/glances/outputs/glances_stdout_json.pyo
${PYSITELIB}/glances/outputs/glances_unicode.py
${PYSITELIB}/glances/outputs/glances_unicode.pyc
${PYSITELIB}/glances/outputs/glances_unicode.pyo

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.18 2022/06/08 06:11:34 fox Exp $
$NetBSD: distinfo,v 1.19 2022/08/08 09:28:06 fox Exp $
BLAKE2s (Glances-3.2.6.4.tar.gz) = e803915d8c34567c77a6514cad8b08281c5e2dc94302ae43d7dc5a526067e8f4
SHA512 (Glances-3.2.6.4.tar.gz) = e2dccb793c616b13c406aca2ea548c50496cb639b7438307ce28b5d0cbc33c62e806928b60900cad6490d241df6edc38ae0b71e09662553acecf9a70ad571c52
Size (Glances-3.2.6.4.tar.gz) = 6910456 bytes
SHA1 (patch-glances_plugins_glances__cpu.py) = 0692c14bd8ac79a7a6a4ff7dfe1a6dfc61c8a8c5
SHA1 (patch-glances_plugins_glances__quicklook.py) = 7bc17f94fd3b2a9105123ee3f6ea44e500944e9e
BLAKE2s (Glances-3.2.7.tar.gz) = 32e0e519d4f6fb9c37a99c07d0b1d7323fbab8f1ee848711f54f01d4b2de48e2
SHA512 (Glances-3.2.7.tar.gz) = 45bf514f25fef302f56fcfc3fe0a4b3b606c8ccc21b1f9f3b56650a489a8e3f6f07a309b801c1d983c83c26ba84e2c43d4d3aeb1ab5173d87d8ec50297418101
Size (Glances-3.2.7.tar.gz) = 6911821 bytes
SHA1 (patch-glances_plugins_glances__cpu.py) = 23012b57a2f130cddb838d2b413c5a04d93d57c1
SHA1 (patch-glances_plugins_glances__quicklook.py) = 20478f6097f84a2bcf0688703b5946c76b161779

View file

@ -1,9 +1,9 @@
$NetBSD: patch-glances_plugins_glances__cpu.py,v 1.1 2021/12/05 11:46:40 fox Exp $
$NetBSD: patch-glances_plugins_glances__cpu.py,v 1.2 2022/08/08 09:28:06 fox Exp $
Disable system call counts in BSD.
--- glances/plugins/glances_cpu.py.orig 2021-11-20 09:22:55.000000000 +0000
--- glances/plugins/glances_cpu.py.orig 2022-07-28 16:12:29.000000000 +0000
+++ glances/plugins/glances_cpu.py
@@ -23,7 +23,7 @@ from glances.logger import logger
@@ -13,7 +13,7 @@ from glances.logger import logger
from glances.timer import getTimeSinceLastUpdate
from glances.compat import iterkeys
from glances.cpu_percent import cpu_percent
@ -12,9 +12,9 @@ Disable system call counts in BSD.
from glances.plugins.glances_core import Plugin as CorePlugin
from glances.plugins.glances_plugin import GlancesPlugin
@@ -347,7 +347,7 @@ class Plugin(GlancesPlugin):
@@ -366,7 +366,7 @@ class Plugin(GlancesPlugin):
# Steal CPU usage
ret.extend(self.curse_add_stat('steal', width=15, header=' '))
ret.extend(self.curse_add_stat('steal', width=14, header=' '))
# syscalls: number of system calls since boot. Always set to 0 on Linux. (do not display)
- if not LINUX:
+ if not LINUX and not BSD:

View file

@ -1,10 +1,10 @@
$NetBSD: patch-glances_plugins_glances__quicklook.py,v 1.2 2022/05/07 08:06:51 fox Exp $
$NetBSD: patch-glances_plugins_glances__quicklook.py,v 1.3 2022/08/08 09:28:06 fox Exp $
It seems cpu_hz_current and cpu_hz is not available in NetBSD, so add additional
check to see if the key exists.
--- glances/plugins/glances_quicklook.py.orig 2022-04-10 14:15:33.000000000 +0000
--- glances/plugins/glances_quicklook.py.orig 2022-07-28 16:12:29.000000000 +0000
+++ glances/plugins/glances_quicklook.py
@@ -74,10 +74,12 @@ class Plugin(GlancesPlugin):
@@ -64,10 +64,12 @@ class Plugin(GlancesPlugin):
# Get additional information
cpu_info = cpu_percent.get_info()
stats['cpu_name'] = cpu_info['cpu_name']