Remove IGNOREd mkisofs package -- can be reimported if someone really

splits mkisofs out from cdrecord.
This commit is contained in:
wiz 2002-07-03 12:15:55 +00:00
parent f40cfc13aa
commit 75dc60bb09
11 changed files with 1 additions and 195 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.151 2002/07/03 12:07:51 agc Exp $
# $NetBSD: Makefile,v 1.152 2002/07/03 12:15:55 wiz Exp $
#
COMMENT= System utilities
@ -68,7 +68,6 @@ SUBDIR+= medusa
SUBDIR+= memconf
SUBDIR+= memtest86
SUBDIR+= mgm
#SUBDIR+= mkisofs # currently part of cdrecord
SUBDIR+= mksunbootcd
SUBDIR+= mtools
SUBDIR+= mtoolsfm

View file

@ -1,4 +0,0 @@
mkisofs is effectively a pre-mastering program to generate the iso9660
filesystem - it takes a snapshot of a given directory tree, and generates
a binary image which will correspond to an iso9660 filesystem when written
to a block device.

View file

@ -1,23 +0,0 @@
# $NetBSD: Makefile,v 1.18 2001/02/17 17:42:16 wiz Exp $
#
DISTNAME= mkisofs-1.11.3
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.cdrom.com/pub/linux/tsx-11/packages/mkisofs/
MAINTAINER= mycroft@netbsd.org
HOMEPAGE= http://andante.jic.com/mkisofs.html
COMMENT= create ISO9660 filesystems with [optional] Rockridge extensions
IGNORE= "${PKGNAME} is now part of the cdrecord package" \
"(someone will maybe split mkisofs out from cdrecord)."
GNU_CONFIGURE= yes
ALL_TARGET= World
post-patch:
@cd ${WRKSRC}; \
${GREP} -v ^# mkisofs.8 >mkisofs.$$$$; \
${MV} mkisofs.$$$$ mkisofs.8
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST,v 1.1 2001/10/31 22:53:32 zuntum Exp $
bin/mkisofs
man/man8/mkisofs.8.gz

View file

@ -1,10 +0,0 @@
$NetBSD: distinfo,v 1.1 2001/05/11 09:25:36 wiz Exp $
SHA1 (mkisofs-1.11.3.tar.gz) = 99d79b294f10db9209de606771328658a45550ee
Size (mkisofs-1.11.3.tar.gz) = 108169 bytes
SHA1 (patch-aa) = 39138cedf3d90203dba8482ab8e05cbd08425e24
SHA1 (patch-ab) = 3c1c336705d3a0b7b054ff8113133687bd9c3ca5
SHA1 (patch-ac) = 7237df4ff84642166a8efdd07f1818f80bb792b2
SHA1 (patch-ae) = 91b8b24fd97c7a83e31284bb17b365822c123105
SHA1 (patch-af) = 1a49bca1aee32878d3cfafa958ccf78fcc3fde57
SHA1 (patch-ag) = 66085777eaec699e63e1ae4a10cfd4929bd1e51c

View file

@ -1,15 +0,0 @@
$NetBSD: patch-aa,v 1.5 1999/04/07 23:55:26 tron Exp $
--- mkisofs.8.orig Tue Jun 2 05:36:16 1998
+++ mkisofs.8 Thu Apr 8 01:46:17 1999
@@ -82,8 +79,10 @@
.B \-m
.I glob
]
+[
.B \-o
.I filename
+]
.I path
.SH DESCRIPTION
.B mkisofs

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ab,v 1.3 1998/08/07 11:14:05 agc Exp $
--- mkisofs.h.orig Thu Apr 10 04:41:48 1997
+++ mkisofs.h Wed Oct 29 12:14:38 1997
@@ -38,6 +38,8 @@
#define NON_UNIXFS
#endif
+#include <sys/types.h>
+
#ifdef VMS
#include <sys/dir.h>
#define dirent direct
@@ -46,7 +48,6 @@
#endif
#include <string.h>
-#include <sys/types.h>
#include <sys/stat.h>
#ifdef linux

View file

@ -1,41 +0,0 @@
$NetBSD: patch-ac,v 1.5 2000/02/05 06:56:16 wiz Exp $
--- name.c.orig Fri May 7 00:57:30 1999
+++ name.c Fri May 7 00:58:04 1999
@@ -25,6 +25,7 @@
#include "mkisofs.h"
+#include <stdlib.h>
#include <ctype.h>
extern int allow_leading_dots;
@@ -58,6 +59,7 @@
const char * pnt;
int priority = 32767;
char * result;
+ char * copy;
int seen_dot = 0;
int seen_semic = 0;
int tildes = 0;
@@ -105,13 +107,17 @@
last_dot = strrchr (pnt,'.');
if( (last_dot != NULL)
&& ( (last_dot[1] == '~')
- || (last_dot[1] == '\0')
|| (last_dot[1] == '\0')) )
{
- c = last_dot;
- *c = '\0';
+ /*
+ * We gotta copy the string first, to work around its constness.
+ */
+ copy = alloca (strlen(name) + 1);
+ memcpy (copy, name, strlen(name) + 1);
+ pnt = copy;
+ last_dot = strrchr (pnt,'.');
+ *last_dot = '\0';
last_dot = strrchr (pnt,'.');
- *c = '.';
}
while(*pnt)

View file

@ -1,25 +0,0 @@
$NetBSD: patch-ae,v 1.3 1998/08/07 11:14:05 agc Exp $
--- iso9660.h.back Thu Apr 10 05:41:46 1997
+++ iso9660.h Fri Feb 13 12:13:11 1998
@@ -136,9 +136,9 @@
char extent[4]; /* 731 */
char parent[2]; /* 721 */
char name[1];
-};
+} __attribute__((packed));
-struct iso_directory_record {
+struct iso_directory_record {
unsigned char length [ISODCL (1, 1)]; /* 711 */
char ext_attr_length [ISODCL (2, 2)]; /* 711 */
char extent [ISODCL (3, 10)]; /* 733 */
@@ -150,7 +150,7 @@
char volume_sequence_number [ISODCL (29, 32)]; /* 723 */
unsigned char name_len [ISODCL (33, 33)]; /* 711 */
char name [34]; /* Not really, but we need something here */
-};
+} __attribute__((packed));
#endif

View file

@ -1,36 +0,0 @@
$NetBSD: patch-af,v 1.3 1998/08/07 11:14:06 agc Exp $
--- mkisofs.c.orig Mon Jun 1 23:36:16 1998
+++ mkisofs.c Sat Jul 4 04:08:26 1998
@@ -53,11 +53,6 @@
#include "exclude.h"
-#ifdef __NetBSD__
-#include <sys/time.h>
-#include <sys/resource.h>
-#endif
-
struct directory * root = NULL;
static char version_string[] = "mkisofs v1.11.3";
@@ -459,19 +454,6 @@
usage();
exit(1);
}
-#ifdef __NetBSD__
- {
- int resource;
- struct rlimit rlp;
- if (getrlimit(RLIMIT_DATA,&rlp) == -1)
- perror("Warning: getrlimit");
- else {
- rlp.rlim_cur=33554432;
- if (setrlimit(RLIMIT_DATA,&rlp) == -1)
- perror("Warning: setrlimit");
- }
- }
-#endif
#ifdef HAVE_SBRK
mem_start = (unsigned long) sbrk(0);
#endif

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ag,v 1.2 1998/08/07 11:14:06 agc Exp $
--- defaults.h.orig Wed Apr 9 23:31:53 1997
+++ defaults.h Sat Jul 4 04:04:10 1998
@@ -39,6 +39,10 @@
#define SYSTEM_ID_DEFAULT "AIX"
#endif
+#ifdef __NetBSD__
+#define SYSTEM_ID_DEFAULT "NetBSD"
+#endif
+
#ifndef SYSTEM_ID_DEFAULT
#define SYSTEM_ID_DEFAULT "LINUX"
#endif