py-pypiserver: updated to 1.3.2

1.3.2:
- ENH: The Dockerfile used for the official Docker images now uses Python 3.6
  rather than Python 2.7
- ENH: The `welcome.html` page has been updated to provide more metadata
  and be more HTML-standards compliant
- FIX: the `pypi-server -U` command no longer fails when run inside the
  Docker container
- FIX: The `remove_pkg` API action now removes any extant instances of a
  package name-version combination, not just the first one found. This means
  that now, for example, if a `.whl` and `.tar.gz` file exist for the
  requested package name and version, both will be removed
- FIX: include missing `simple/` path on a URL in the example pip commands
  on the `welcome.html` page
- DOC: more consistent and accurate documentation for pip commands provided
  on the `welcome.html` page
- DOC: fixes to the README to make it easier for people to use pypiserver
  behind an apache webserver
This commit is contained in:
adam 2020-01-16 08:20:01 +00:00
parent 783821e0ff
commit 75df829645
3 changed files with 15 additions and 15 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.2 2019/10/16 16:45:16 adam Exp $
# $NetBSD: Makefile,v 1.3 2020/01/16 08:20:01 adam Exp $
DISTNAME= pypiserver-1.3.1
DISTNAME= pypiserver-1.3.2
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=p/pypiserver/}

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.2 2019/10/16 16:45:16 adam Exp $
$NetBSD: distinfo,v 1.3 2020/01/16 08:20:01 adam Exp $
SHA1 (pypiserver-1.3.1.zip) = 88d5f7ec0295e53f5aa659192dc57ae04b0c92a3
RMD160 (pypiserver-1.3.1.zip) = 146ea84eb5579d41fe5f90a7d41fda4b6ca50519
SHA512 (pypiserver-1.3.1.zip) = ea7e4572c8648b1aa9d78f8eea93e9e8355a1ecbdb01e56b954684e9a21f8bc3a2b62fc9ee778cc76e4d50412e5a0fa34e8d0a783eaad50c2614e09d86cd303f
Size (pypiserver-1.3.1.zip) = 538986 bytes
SHA1 (patch-setup.py) = 55a56372bbf0814f0249abddeb459cd5f36d3a19
SHA1 (pypiserver-1.3.2.zip) = a93a0ba37548e61417a25076acb1965849853d4c
RMD160 (pypiserver-1.3.2.zip) = e811a51790ee62255b2f6549825a788ef0807e5e
SHA512 (pypiserver-1.3.2.zip) = 5034b8ce1a7ac012d3ee9a5413e5fca5d75b3ee49ec52230a5a1dae3a63485a205d6a40ed57c349b55dd6f2d1666dd079d94bc9c03a123bd2eb7d9ef11c88b77
Size (pypiserver-1.3.2.zip) = 540495 bytes
SHA1 (patch-setup.py) = 711949ce59a54a88e2cf4af347ddc7db24683357

View file

@ -1,15 +1,15 @@
$NetBSD: patch-setup.py,v 1.1 2019/05/29 20:13:09 adam Exp $
$NetBSD: patch-setup.py,v 1.2 2020/01/16 08:20:02 adam Exp $
Do not require setuptools-git for building.
--- setup.py.orig 2019-03-10 15:33:57.000000000 +0000
--- setup.py.orig 2019-09-17 18:56:54.000000000 +0000
+++ setup.py
@@ -14,7 +14,7 @@ tests_require = ['pytest>=2.3', 'tox', '
@@ -20,7 +20,7 @@ tests_require = [
if sys.version_info == (2, 7):
tests_require.append('mock')
tests_require.append("mock")
-setup_requires = ['setuptools', 'setuptools-git >= 0.3']
+setup_requires = ['setuptools']
-setup_requires = ["setuptools", "setuptools-git >= 0.3"]
+setup_requires = ["setuptools"]
if sys.version_info >= (3, 5):
setup_requires.append('wheel >= 0.25.0') # earlier wheels fail in 3.5
setup_requires.append("wheel >= 0.25.0") # earlier wheels fail in 3.5
else: