Make it build on DragonFly. From Rumko via PR 41763.
This commit is contained in:
parent
dc392b9701
commit
75f29cb3be
3 changed files with 24 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.7 2008/08/17 03:21:45 dholland Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2009/08/23 20:02:28 hasso Exp $
|
||||
#
|
||||
|
||||
DISTNAME= prelude-pflogger-0.9.0-rc2
|
||||
|
@ -65,6 +65,7 @@ pre-patch:
|
|||
pre-configure:
|
||||
set -e; cd ${WRKSRC}; \
|
||||
aclocal; autoheader; automake -a --foreign -i; autoconf
|
||||
${LN} -s ${BUILDLINK_DIR}/lib/libltdl.so ${BUILDLINK_DIR}/lib/libltdlc.so
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${CC} ${CFLAGS} -o run-prelude-pflogger run-prelude-pflogger.c
|
||||
|
@ -73,4 +74,5 @@ post-install:
|
|||
${INSTALL_PROGRAM} ${WRKSRC}/run-prelude-pflogger ${DESTDIR}${PREFIX}/sbin/run-prelude-pflogger
|
||||
|
||||
.include "../../security/libprelude/buildlink3.mk"
|
||||
.include "../../devel/libltdl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.4 2008/06/12 02:14:45 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.5 2009/08/23 20:02:28 hasso Exp $
|
||||
|
||||
SHA1 (prelude-pflogger-0.9.0-rc2.tar.gz) = ae354809dae5f04392a1c93a88be4cf9993c3b43
|
||||
RMD160 (prelude-pflogger-0.9.0-rc2.tar.gz) = 7c5808b0ca515c8080c64b52aa0aae166831e4d4
|
||||
Size (prelude-pflogger-0.9.0-rc2.tar.gz) = 303763 bytes
|
||||
SHA1 (patch-aa) = b7f7623e75c324e593aec10d921ee5364a2fa542
|
||||
SHA1 (patch-ab) = 75a78b3d50067b07448aff9fde565f8bd5ab1b54
|
||||
SHA1 (patch-ac) = 18e596f3de2835fa31062e42d3760f70707c8812
|
||||
|
|
19
security/prelude-pflogger/patches/patch-ac
Normal file
19
security/prelude-pflogger/patches/patch-ac
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- src/process_packet.c.orig 2005-09-18 16:29:54 +0200
|
||||
+++ src/process_packet.c
|
||||
@@ -40,8 +40,14 @@
|
||||
#include <netinet/tcp.h>
|
||||
#include <netinet/udp.h>
|
||||
#include <net/if.h>
|
||||
-#include <net/if_pflog.h>
|
||||
-#include <net/pfvar.h>
|
||||
+#ifdef __DragonFly__
|
||||
+# include <net/if_var.h>
|
||||
+# include <net/pf/if_pflog.h>
|
||||
+# include <net/pf/pfvar.h>
|
||||
+#else
|
||||
+# include <net/if_pflog.h>
|
||||
+# include <net/pfvar.h>
|
||||
+#endif
|
||||
#include <netdb.h>
|
||||
#include <pcap.h>
|
||||
#include <sys/ioctl.h>
|
Loading…
Reference in a new issue