Update to 0.9.17. Changes:
- Implement RFC 4122 UUIDv1 identifier generation, more resistant to duplicate than our previous implementation in case of clock skew, or multiple client with the same analyzerid sending alert in parallel. - You can now provide NULL value to idmef_path_set() in order to destroy existing value within an IDMEF message. - Unify memory handling of value retrieval through idmef_path_t. This allow the user to retrieve and keep any values, even through the associated IDMEF message is freed. - Build system cleanup, enable RELRO when possible. - Implement PRELUDE_CLIENT_FLAGS_AUTOCONFIG, which is set by default, but that applications might unset in order for their client not to read the default profile/global configuration. - Fix possible assertion when destroying un-started prelude-client. - Improvement to the prelude-io API, the user might now hook its own handling function. - Fix dumping of (not) NULL criteria operator to string. Remove gratuitous space insertion when dumping criteria. - Headers fixes for C++ build. - Fix printing and cloning of empty IDMEF string. - In IDMEF to string convertion code, print <invalid enum value> in place of NULL on invalid enumeration value. - Various bug fixes.
This commit is contained in:
parent
68062d9a63
commit
7634cc570d
3 changed files with 44 additions and 44 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.29 2008/03/06 14:53:53 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.30 2008/04/28 10:51:49 shannonjr Exp $
|
||||
#
|
||||
DISTNAME= libprelude-0.9.16.2
|
||||
PKGREVISION= 1
|
||||
DISTNAME= libprelude-0.9.17
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
|
||||
http://www.prelude-ids.org/download/releases/old/
|
||||
|
@ -24,7 +23,7 @@ BUILD_DEFS+= VARBASE
|
|||
USE_PKGLOCALEDIR= yes
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_TOOLS+= chown make bison gawk
|
||||
USE_TOOLS+= chown make bison gawk gmake
|
||||
PKG_SYSCONFSUBDIR= prelude
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASEDIR:Q}
|
||||
CONFIGURE_ARGS+= --localstatedir=${VARBASE:Q}
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.21 2008/03/03 15:13:02 shannonjr Exp $
|
||||
$NetBSD: distinfo,v 1.22 2008/04/28 10:51:49 shannonjr Exp $
|
||||
|
||||
SHA1 (libprelude-0.9.16.2.tar.gz) = c2e5e3440b1bb89e2f84ca2f3d5cc73b5d1dbdea
|
||||
RMD160 (libprelude-0.9.16.2.tar.gz) = 5e4c7745006039589f0cf06e23677dcaa4423d35
|
||||
Size (libprelude-0.9.16.2.tar.gz) = 1986749 bytes
|
||||
SHA1 (patch-aa) = c8aff1bce0b649b77554eefca4625f69393ac1c2
|
||||
SHA1 (libprelude-0.9.17.tar.gz) = b2f93d3eff67ef8e1a756df6a2adab12ceb8740d
|
||||
RMD160 (libprelude-0.9.17.tar.gz) = 08abb60654fd06c376b8023609fb3ea9c804c47c
|
||||
Size (libprelude-0.9.17.tar.gz) = 2028451 bytes
|
||||
SHA1 (patch-aa) = 4a9f6a0e04ef497c374ec486b938116dccbc52a2
|
||||
SHA1 (patch-ab) = 3fa1b01b728cd1210cf22717e2f6c81a3d3b70cc
|
||||
SHA1 (patch-ad) = e89900459ed7834801ae22b7a4a711163ec3f86b
|
||||
SHA1 (patch-ae) = ec362a79320f8ab189597ddd4641e4718536c629
|
||||
|
|
|
@ -1,78 +1,78 @@
|
|||
$NetBSD: patch-aa,v 1.4 2007/09/05 18:58:19 shannonjr Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2008/04/28 10:51:49 shannonjr Exp $
|
||||
|
||||
--- Makefile.in.orig 2007-09-04 08:31:01.000000000 -0600
|
||||
--- Makefile.in.orig 2008-04-24 04:50:26.000000000 -0600
|
||||
+++ Makefile.in
|
||||
@@ -490,7 +490,7 @@ libexecdir = @libexecdir@
|
||||
libprelude_cflags = @libprelude_cflags@
|
||||
libprelude_libs = @libprelude_libs@
|
||||
libprelude_soname = @libprelude_soname@
|
||||
@@ -559,7 +559,7 @@ infodir = @infodir@
|
||||
install_sh = @install_sh@
|
||||
libdir = @libdir@
|
||||
libexecdir = @libexecdir@
|
||||
-localedir = @localedir@
|
||||
+localedir = @prefix@/share/locale
|
||||
localstatedir = @localstatedir@
|
||||
mandir = @mandir@
|
||||
mkdir_p = @mkdir_p@
|
||||
@@ -1034,71 +1034,14 @@ prelude-config.h: $(top_builddir)/config
|
||||
@@ -1099,71 +1099,14 @@ prelude-config.h: $(top_builddir)/config
|
||||
# Spool directory for report saving is mode
|
||||
|
||||
install-data-local:
|
||||
- $(INSTALL) -d -m 711 $(DESTDIR)$(prelude_spool_dir);
|
||||
- $(INSTALL) -d -m 755 $(DESTDIR)$(prelude_config_dir);
|
||||
- $(INSTALL) -d -m 755 $(DESTDIR)$(prelude_config_dir)/default;
|
||||
- $(INSTALL) -d -m 711 $(DESTDIR)$(prelude_config_dir)/profile;
|
||||
- @if test -f $(DESTDIR)$(prelude_config_dir)/default/client.conf; then \
|
||||
- $(INSTALL) -d -m 711 $(DESTDIR)$(PRELUDE_SPOOL_DIR);
|
||||
- $(INSTALL) -d -m 755 $(DESTDIR)$(PRELUDE_CONFIG_DIR);
|
||||
- $(INSTALL) -d -m 755 $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default;
|
||||
- $(INSTALL) -d -m 711 $(DESTDIR)$(PRELUDE_CONFIG_DIR)/profile;
|
||||
- @if test -f $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/client.conf; then \
|
||||
- echo; \
|
||||
- echo "********************************************************************************"; \
|
||||
- echo; \
|
||||
- echo "$(DESTDIR)$(prelude_config_dir)/default/client.conf already exist..."; \
|
||||
- echo "Installing default configuration in $(DESTDIR)$(prelude_config_dir)/default/client.conf-dist"; \
|
||||
- echo "$(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/client.conf already exist..."; \
|
||||
- echo "Installing default configuration in $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/client.conf-dist"; \
|
||||
- echo; \
|
||||
- echo "********************************************************************************"; \
|
||||
- echo; \
|
||||
- $(INSTALL) -m 644 $(top_srcdir)/client.conf $(DESTDIR)$(prelude_config_dir)/default/client.conf-dist; \
|
||||
- $(INSTALL) -m 644 $(top_builddir)/client.conf $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/client.conf-dist; \
|
||||
- else \
|
||||
- $(INSTALL) -m 644 $(top_srcdir)/client.conf $(DESTDIR)$(prelude_config_dir)/default; \
|
||||
- $(INSTALL) -m 644 $(top_builddir)/client.conf $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default; \
|
||||
- fi
|
||||
-
|
||||
- @if test -f $(DESTDIR)$(prelude_config_dir)/default/global.conf; then \
|
||||
- @if test -f $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/global.conf; then \
|
||||
- echo; \
|
||||
- echo "********************************************************************************"; \
|
||||
- echo; \
|
||||
- echo "$(DESTDIR)$(prelude_config_dir)/default/global.conf already exist..."; \
|
||||
- echo "Installing default configuration in $(DESTDIR)$(prelude_config_dir)/default/global.conf-dist"; \
|
||||
- echo "$(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/global.conf already exist..."; \
|
||||
- echo "Installing default configuration in $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/global.conf-dist"; \
|
||||
- echo; \
|
||||
- echo "********************************************************************************"; \
|
||||
- echo; \
|
||||
- $(INSTALL) -m 644 $(top_srcdir)/global.conf $(DESTDIR)$(prelude_config_dir)/default/global.conf-dist; \
|
||||
- $(INSTALL) -m 644 $(top_builddir)/global.conf $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/global.conf-dist; \
|
||||
- else \
|
||||
- $(INSTALL) -m 644 $(top_srcdir)/global.conf $(DESTDIR)$(prelude_config_dir)/default; \
|
||||
- $(INSTALL) -m 644 $(top_builddir)/global.conf $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default; \
|
||||
- fi
|
||||
-
|
||||
- @if test -f $(DESTDIR)$(prelude_config_dir)/default/idmef-client.conf; then \
|
||||
- @if test -f $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/idmef-client.conf; then \
|
||||
- echo; \
|
||||
- echo "********************************************************************************"; \
|
||||
- echo; \
|
||||
- echo "$(DESTDIR)$(prelude_config_dir)/default/idmef-client.conf already exist..."; \
|
||||
- echo "Installing default configuration in $(DESTDIR)$(prelude_config_dir)/default/idmef-client.conf-dist"; \
|
||||
- echo "$(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/idmef-client.conf already exist..."; \
|
||||
- echo "Installing default configuration in $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/idmef-client.conf-dist"; \
|
||||
- echo; \
|
||||
- echo "********************************************************************************"; \
|
||||
- echo; \
|
||||
- $(INSTALL) -m 644 $(top_srcdir)/idmef-client.conf $(DESTDIR)$(prelude_config_dir)/default/idmef-client.conf-dist; \
|
||||
- $(INSTALL) -m 644 $(top_builddir)/idmef-client.conf $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/idmef-client.conf-dist;\
|
||||
- else \
|
||||
- $(INSTALL) -m 644 $(top_srcdir)/idmef-client.conf $(DESTDIR)$(prelude_config_dir)/default; \
|
||||
- $(INSTALL) -m 644 $(top_builddir)/idmef-client.conf $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default; \
|
||||
- fi
|
||||
-
|
||||
- @if test -f $(DESTDIR)$(prelude_config_dir)/default/tls.conf; then \
|
||||
- @if test -f $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/tls.conf; then \
|
||||
- echo; \
|
||||
- echo "********************************************************************************"; \
|
||||
- echo; \
|
||||
- echo "$(DESTDIR)$(prelude_config_dir)/default/tls.conf already exist..."; \
|
||||
- echo "Installing default configuration in $(DESTDIR)$(prelude_config_dir)/default/tls.conf-dist"; \
|
||||
- echo "$(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/tls.conf already exist..."; \
|
||||
- echo "Installing default configuration in $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/tls.conf-dist"; \
|
||||
- echo; \
|
||||
- echo "********************************************************************************"; \
|
||||
- echo; \
|
||||
- $(INSTALL) -m 644 $(top_srcdir)/tls.conf $(DESTDIR)$(prelude_config_dir)/default/tls.conf-dist; \
|
||||
- $(INSTALL) -m 644 $(top_srcdir)/tls.conf $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/tls.conf-dist; \
|
||||
- else \
|
||||
- $(INSTALL) -m 644 $(top_srcdir)/tls.conf $(DESTDIR)$(prelude_config_dir)/default; \
|
||||
- $(INSTALL) -m 644 $(top_srcdir)/tls.conf $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default; \
|
||||
- fi
|
||||
+ $(INSTALL) -d -m 711 $(DESTDIR)$(prelude_spool_dir)
|
||||
+ $(BSD_INSTALL_DATA) $(top_srcdir)/client.conf @EGDIR@
|
||||
|
@ -81,10 +81,10 @@ $NetBSD: patch-aa,v 1.4 2007/09/05 18:58:19 shannonjr Exp $
|
|||
+ $(BSD_INSTALL_DATA) $(top_srcdir)/tls.conf @EGDIR@
|
||||
|
||||
uninstall-local:
|
||||
- rm -f $(DESTDIR)$(prelude_config_dir)/default/client.conf
|
||||
- rm -f $(DESTDIR)$(prelude_config_dir)/default/global.conf
|
||||
- rm -f $(DESTDIR)$(prelude_config_dir)/default/idmef-client.conf
|
||||
- rm -f $(DESTDIR)$(prelude_config_dir)/default/tls.conf
|
||||
- rm -f $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/client.conf
|
||||
- rm -f $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/global.conf
|
||||
- rm -f $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/idmef-client.conf
|
||||
- rm -f $(DESTDIR)$(PRELUDE_CONFIG_DIR)/default/tls.conf
|
||||
+
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
|
|
Loading…
Reference in a new issue