initial import of pygtk-0.6.9, a Python interface to GTK
This commit is contained in:
parent
332da6626c
commit
769972e81b
7 changed files with 122 additions and 0 deletions
6
x11/pygtk/DESCR
Normal file
6
x11/pygtk/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
This archive contains modules that allow you to use gtk in Python
|
||||
programs. At present, it is a fairly complete set of bindings.
|
||||
Despite the low version number, this piece of software is quite
|
||||
useful, and is usable to write moderately complex programs. (see the
|
||||
examples directory for some examples of the simpler programs you could
|
||||
write).
|
28
x11/pygtk/Makefile
Normal file
28
x11/pygtk/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2002/02/18 11:55:02 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pygtk-0.6.9
|
||||
PKGNAME= ${PYPKGPREFIX}-gtk-0.6.9
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ftp://ftp.gtk.org/pub/gtk/python/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.daa.com.au/~james/pygtk/
|
||||
COMMENT= Python Bindings for the GTK Widget Set
|
||||
|
||||
DEPENDS+= gtkglarea-*:../../x11/gtkglarea
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --disable-numpy
|
||||
CONFIGURE_ENV+= PYTHON=${PYTHONBIN}
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
PY_PATCHPLIST= yes
|
||||
|
||||
.include "../../graphics/imlib/buildlink.mk"
|
||||
.include "../../graphics/gdk-pixbuf/buildlink.mk"
|
||||
.include "../../devel/libglade/buildlink.mk"
|
||||
.include "../../lang/python/extension.buildlink.mk"
|
||||
.include "../../x11/gtk/buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
50
x11/pygtk/PLIST
Normal file
50
x11/pygtk/PLIST
Normal file
|
@ -0,0 +1,50 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/02/18 11:55:02 drochner Exp $
|
||||
${PYSITELIB}/GDK.py
|
||||
${PYSITELIB}/GDK.pyc
|
||||
${PYSITELIB}/GDK.pyo
|
||||
${PYSITELIB}/GTK.py
|
||||
${PYSITELIB}/GTK.pyc
|
||||
${PYSITELIB}/GTK.pyo
|
||||
${PYSITELIB}/GdkImlib.py
|
||||
${PYSITELIB}/GdkImlib.pyc
|
||||
${PYSITELIB}/GdkImlib.pyo
|
||||
${PYSITELIB}/GtkExtra.py
|
||||
${PYSITELIB}/GtkExtra.pyc
|
||||
${PYSITELIB}/GtkExtra.pyo
|
||||
${PYSITELIB}/_gdkimlibmodule.a
|
||||
${PYSITELIB}/_gdkimlibmodule.la
|
||||
${PYSITELIB}/_gdkimlibmodule.so
|
||||
${PYSITELIB}/_gtkglmodule.a
|
||||
${PYSITELIB}/_gtkglmodule.la
|
||||
${PYSITELIB}/_gtkglmodule.so
|
||||
${PYSITELIB}/_gtkmodule.a
|
||||
${PYSITELIB}/_gtkmodule.la
|
||||
${PYSITELIB}/_gtkmodule.so
|
||||
${PYSITELIB}/_libglademodule.a
|
||||
${PYSITELIB}/_libglademodule.la
|
||||
${PYSITELIB}/_libglademodule.so
|
||||
${PYSITELIB}/gdkpixbufmodule.a
|
||||
${PYSITELIB}/gdkpixbufmodule.la
|
||||
${PYSITELIB}/gdkpixbufmodule.so
|
||||
${PYSITELIB}/gtk.py
|
||||
${PYSITELIB}/gtk.pyc
|
||||
${PYSITELIB}/gtk.pyo
|
||||
${PYSITELIB}/gtkgl.py
|
||||
${PYSITELIB}/gtkgl.pyc
|
||||
${PYSITELIB}/gtkgl.pyo
|
||||
${PYSITELIB}/libglade.py
|
||||
${PYSITELIB}/libglade.pyc
|
||||
${PYSITELIB}/libglade.pyo
|
||||
${PYSITELIB}/pyglade/__init__.py
|
||||
${PYSITELIB}/pyglade/__init__.pyc
|
||||
${PYSITELIB}/pyglade/__init__.pyo
|
||||
${PYSITELIB}/pyglade/build.py
|
||||
${PYSITELIB}/pyglade/build.pyc
|
||||
${PYSITELIB}/pyglade/build.pyo
|
||||
${PYSITELIB}/pyglade/style.py
|
||||
${PYSITELIB}/pyglade/style.pyc
|
||||
${PYSITELIB}/pyglade/style.pyo
|
||||
${PYSITELIB}/pyglade/xmlparse.py
|
||||
${PYSITELIB}/pyglade/xmlparse.pyc
|
||||
${PYSITELIB}/pyglade/xmlparse.pyo
|
||||
@dirrm ${PYSITELIB}/pyglade
|
6
x11/pygtk/buildlink.mk
Normal file
6
x11/pygtk/buildlink.mk
Normal file
|
@ -0,0 +1,6 @@
|
|||
# $NetBSD: buildlink.mk,v 1.1.1.1 2002/02/18 11:55:02 drochner Exp $
|
||||
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
|
||||
BUILDLINK_DEPENDS.pygtk?= ${PYPKGPREFIX}-gtk-*
|
||||
DEPENDS+= ${BUILDLINK_DEPENDS.pygtk}:../../x11/pygtk
|
6
x11/pygtk/distinfo
Normal file
6
x11/pygtk/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/02/18 11:55:02 drochner Exp $
|
||||
|
||||
SHA1 (pygtk-0.6.9.tar.gz) = a6c8d30614f2f8d1be77064d839f48104eb8028b
|
||||
Size (pygtk-0.6.9.tar.gz) = 388901 bytes
|
||||
SHA1 (patch-aa) = a926a005a76d2805991b76830a002067de6daa67
|
||||
SHA1 (patch-ab) = e24ec6f868c128559d39186cf0088ace52c758bd
|
13
x11/pygtk/patches/patch-aa
Normal file
13
x11/pygtk/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/02/18 11:55:02 drochner Exp $
|
||||
|
||||
--- Makefile.in.orig Sat Feb 16 20:19:43 2002
|
||||
+++ Makefile.in Sat Feb 16 20:26:18 2002
|
||||
@@ -674,7 +674,7 @@
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-pkgincludeHEADERS install-pythonPYTHON
|
||||
+install-data-am: install-pythonPYTHON
|
||||
|
||||
install-exec-am: install-pyexecLTLIBRARIES
|
||||
|
13
x11/pygtk/patches/patch-ab
Normal file
13
x11/pygtk/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2002/02/18 11:55:02 drochner Exp $
|
||||
|
||||
--- generate/Makefile.in.orig Sat Feb 16 20:27:44 2002
|
||||
+++ generate/Makefile.in Sat Feb 16 20:29:26 2002
|
||||
@@ -249,7 +249,7 @@
|
||||
uninstall: uninstall-am
|
||||
|
||||
install-am: all-am
|
||||
- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
|
||||
+# @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
|
||||
|
||||
installcheck: installcheck-am
|
||||
install-strip:
|
Loading…
Reference in a new issue