Import heme from pkgsrc-wip. Packaged by pancake and modified by me.
Heme is a fast and portable console hex editor for unix systems. It has undo support (number of undo operations is only limited by available memory), ability to fill a range of addresses with the specified byte, ability to search for a single byte or character string. Offsets can be given in hexadecimal, octal or decimal. There are two editing modes: hex and ascii. In hex mode you type hexadecimal digits and in ascii mode you type characters. In the ascii mode cursor is automatically moved to the next byte after typing a character (this behaviour is configurable for hex mode).
This commit is contained in:
parent
22e2195115
commit
76bb09a31f
5 changed files with 59 additions and 0 deletions
11
editors/heme/DESCR
Normal file
11
editors/heme/DESCR
Normal file
|
@ -0,0 +1,11 @@
|
|||
Heme is a fast and portable console hex editor for unix systems. It
|
||||
has undo support (number of undo operations is only limited by
|
||||
available memory), ability to fill a range of addresses with the
|
||||
specified byte, ability to search for a single byte or character
|
||||
string.
|
||||
|
||||
Offsets can be given in hexadecimal, octal or decimal. There are two
|
||||
editing modes: hex and ascii. In hex mode you type hexadecimal digits
|
||||
and in ascii mode you type characters. In the ascii mode cursor is
|
||||
automatically moved to the next byte after typing a character (this
|
||||
behaviour is configurable for hex mode).
|
26
editors/heme/Makefile
Normal file
26
editors/heme/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2005/10/01 05:57:30 minskim Exp $
|
||||
#
|
||||
|
||||
DISTNAME= heme-0.4
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=heme/}
|
||||
|
||||
MAINTAINER= pancake@phreaker.net
|
||||
HOMEPAGE= http://keihanna.dl.sourceforge.net/sourceforge/heme/
|
||||
COMMENT= Fast and portable console hex editor
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
BUILD_TARGET= heme
|
||||
USE_NCURSES= # mvwchgat
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
INSTALLATION_DIRS= bin man/man1
|
||||
|
||||
.include "../../devel/ncurses/buildlink3.mk"
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/heme ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/heme.1 ${PREFIX}/man/man1
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
editors/heme/PLIST
Normal file
3
editors/heme/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2005/10/01 05:57:30 minskim Exp $
|
||||
bin/heme
|
||||
man/man1/heme.1
|
6
editors/heme/distinfo
Normal file
6
editors/heme/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2005/10/01 05:57:30 minskim Exp $
|
||||
|
||||
SHA1 (heme-0.4.tar.gz) = ae7727f9861e0ac36eeac7ddccb62739468f1251
|
||||
RMD160 (heme-0.4.tar.gz) = 478f527f8e4968968d0d055fddc1cdb98b632a8e
|
||||
Size (heme-0.4.tar.gz) = 21370 bytes
|
||||
SHA1 (patch-aa) = d64d01c8f3505b75dfa54f2291b63055b5a17e91
|
13
editors/heme/patches/patch-aa
Normal file
13
editors/heme/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/10/01 05:57:30 minskim Exp $
|
||||
|
||||
--- Makefile.orig 2005-03-06 10:52:31.000000000 -0800
|
||||
+++ Makefile
|
||||
@@ -1,6 +1,6 @@
|
||||
INSTALL_PREFIX = /usr/local
|
||||
-CFLAGS = -Wall -DHAVE_MMAP # remove -DHAVE_MMAP if you don't have mmap
|
||||
-LDFLAGS = -lcurses
|
||||
+CFLAGS+= -Wall -DHAVE_MMAP # remove -DHAVE_MMAP if you don't have mmap
|
||||
+LDFLAGS+= -lncurses
|
||||
OBJECTS = heme.o xmalloc.o error.o pconfig.o pgetopt.o
|
||||
TARGET = heme
|
||||
|
Loading…
Reference in a new issue