Fix inline usage.

This commit is contained in:
joerg 2012-10-15 09:35:16 +00:00
parent 8552cb9302
commit 76c0fd8423
2 changed files with 46 additions and 6 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.8 2010/10/03 12:47:20 obache Exp $
$NetBSD: distinfo,v 1.9 2012/10/15 09:35:16 joerg Exp $
SHA1 (ifile-1.3.4/ifile-1.3.4.tar.gz) = c8ef75cfe8f25af65b3384e016b7fd2d324346b0
RMD160 (ifile-1.3.4/ifile-1.3.4.tar.gz) = ac13f9b8ba99319be61764ffb9492cc9405b3ea7
Size (ifile-1.3.4/ifile-1.3.4.tar.gz) = 187742 bytes
SHA1 (patch-aa) = c61f441f9bcae546fcebe351be02cad9f1e3b00a
SHA1 (patch-aa) = f60b5642496e83707f722c2ea1d63460599226ba
SHA1 (patch-ad) = 6b92eec1416a40cc692ff58915f8ebf133160f6a
SHA1 (patch-argp_argp-fmtstream.h) = 505591cb210f783422a9e600e1f97a2ca3ae09ad

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.2 2003/07/25 15:25:14 salo Exp $
$NetBSD: patch-aa,v 1.3 2012/10/15 09:35:17 joerg Exp $
--- argp/argp.h.orig Tue Jun 10 16:09:27 2003
+++ argp/argp.h Fri Jul 25 16:47:12 2003
@@ -352,7 +352,7 @@
--- argp/argp.h.orig 2004-11-19 22:51:25.000000000 +0000
+++ argp/argp.h
@@ -352,7 +352,7 @@ struct argp_state
#define ARGP_NO_EXIT 0x20
/* Use the gnu getopt `long-only' rules for parsing arguments. */
@ -11,3 +11,42 @@ $NetBSD: patch-aa,v 1.2 2003/07/25 15:25:14 salo Exp $
/* Turns off any message-printing/exiting options. */
#define ARGP_SILENT (ARGP_NO_EXIT | ARGP_NO_ERRS | ARGP_NO_HELP)
@@ -446,8 +446,10 @@ extern void __argp_state_help __P ((__co
FILE *__stream, unsigned __flags));
/* Possibly output the standard usage message for ARGP to stderr and exit. */
+#if 0
extern void argp_usage __P ((__const struct argp_state *__state));
extern void __argp_usage __P ((__const struct argp_state *__state));
+#endif
/* If appropriate, print the printf string FMT and following args, preceded
by the program name and `:', to stderr, and followed by a `Try ... --help'
@@ -493,6 +495,7 @@ extern void __argp_failure __P ((__const
#endif
/* Returns true if the option OPT is a valid short option. */
+#if 0
extern int _option_is_short __P ((__const struct argp_option *__opt));
extern int __option_is_short __P ((__const struct argp_option *__opt));
@@ -500,6 +503,7 @@ extern int __option_is_short __P ((__con
options array. */
extern int _option_is_end __P ((__const struct argp_option *__opt));
extern int __option_is_end __P ((__const struct argp_option *__opt));
+#endif
/* Return the input field for ARGP in the parser corresponding to STATE; used
by the help routines. */
@@ -518,7 +522,11 @@ extern void *__argp_input __P ((__const
#endif
#ifndef ARGP_EI
+#if defined(__GNUC__) && !defined(__GNUC_STDC_INLINE__)
# define ARGP_EI extern inline
+#else
+# define ARGP_EI inline
+#endif
#endif
ARGP_EI void