Fix extraction of rpath options from Fortran linker.

This commit is contained in:
joerg 2013-11-29 12:59:31 +00:00
parent 3f1ecaa268
commit 76c7248fae
3 changed files with 39 additions and 1 deletions

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2013/11/14 15:04:12 asau Exp $
$NetBSD: distinfo,v 1.2 2013/11/29 12:59:31 joerg Exp $
SHA1 (Ipopt-3.11.5.tgz) = 66e3ae03179ba7541a478d185b256f336159fc6d
RMD160 (Ipopt-3.11.5.tgz) = 9fc02e86f9d69a85e77c492ade30df23dba8afc7
Size (Ipopt-3.11.5.tgz) = 4743371 bytes
SHA1 (patch-Ipopt_configure) = a8737f537b8638a71d65d83658770826bfefc5e6
SHA1 (patch-ThirdParty_HSLold_configure) = e4993ba13c1c84a4d83992c3ce0c58a500af7462

View file

@ -0,0 +1,18 @@
$NetBSD: patch-Ipopt_configure,v 1.1 2013/11/29 12:59:31 joerg Exp $
--- Ipopt/configure.orig 2013-11-28 03:29:00.000000000 +0000
+++ Ipopt/configure
@@ -5180,7 +5180,12 @@ fi
done
;;
- -[lLR]*)
+ -R*)
+ ac_arg="-Wl,$ac_arg"
+ shift
+ set X $ac_arg "$@"
+ ;;
+ -[lLR]*|-Wl*)
ac_exists=false
for ac_i in $ac_cv_f77_libs; do
if test x"$ac_arg" = x"$ac_i"; then

View file

@ -0,0 +1,18 @@
$NetBSD: patch-ThirdParty_HSLold_configure,v 1.1 2013/11/29 12:59:31 joerg Exp $
--- ThirdParty/HSLold/configure.orig 2013-11-28 03:27:10.000000000 +0000
+++ ThirdParty/HSLold/configure
@@ -4475,7 +4475,12 @@ fi
done
;;
- -[lLR]*)
+ -R*)
+ ac_arg="-Wl,$ac_arg"
+ shift
+ set X $ac_arg "$@"
+ ;;
+ -[lLR]*|-Wl*)
ac_exists=false
for ac_i in $ac_cv_f77_libs; do
if test x"$ac_arg" = x"$ac_i"; then