icinga2: fix build/package on macOS
From MAINTAINER Edgar Fuß.
This commit is contained in:
parent
5cff1ff336
commit
76d0ceed92
14 changed files with 93 additions and 35 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
DISTNAME= icinga2-2.12.3
|
||||
CATEGORIES= net sysutils
|
||||
|
@ -139,6 +139,12 @@ CMAKE_ARGS+= -DCMAKE_INSTALL_LOCALSTATEDIR=${VARBASE}
|
|||
# For ICINGA2_WITH_XXX see options.mk
|
||||
CMAKE_ARGS+= -DICINGA2_WITH_TESTS=OFF
|
||||
|
||||
# Avoid a name clash with Boost header on case-insensitive file systems.
|
||||
# Remove outdated GNUInstallDirs.cmake.
|
||||
post-extract:
|
||||
${MV} ${WRKSRC}/VERSION ${WRKSRC}/ICINGA2_VERSION
|
||||
${RM} ${WRKSRC}/third-party/cmake/GNUInstallDirs.cmake
|
||||
|
||||
# The configuration files are installed in etc/icinga2. You can't tell CMAKE
|
||||
# to put them elsewhere because the program and the config files contain
|
||||
# references to the config dir. So move them to share/examples after
|
||||
|
|
|
@ -1,17 +1,19 @@
|
|||
$NetBSD: distinfo,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
SHA1 (icinga2-2.12.3.tar.gz) = 2cbcb9e1dd85613c8452235bdacd0eac347b0f69
|
||||
RMD160 (icinga2-2.12.3.tar.gz) = 21d907c8441503fcfda975756ccc76fb2a04f5b4
|
||||
SHA512 (icinga2-2.12.3.tar.gz) = 28b87e03a8ffeb7a1d19ddf9555151b826f7bf1fd33b0139c2fc8abe7c89d66d96089d5b32d0aaccc3876040514b2bfbde9970416d5ec4ea3b023b17c0fb1799
|
||||
Size (icinga2-2.12.3.tar.gz) = 7534454 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = ef1bf5f3c7a787e2e1aba0ca241c605de21737c6
|
||||
SHA1 (patch-lib_base_string.cpp) = 8af8d9e7270664d9386f2dc2b0a3cc664f800610
|
||||
SHA1 (patch-lib_base_string.hpp) = f6c978a9fc1df45977ae02e35b59ff447630590b
|
||||
SHA1 (patch-lib_base_utility.cpp) = 85abaca2e84a0053247084b7f5f6baf70f50141c
|
||||
SHA1 (patch-lib_perfdata_elasticsearchwriter.cpp) = 8a98e1dfd0c273adebf842d6083c5f192c91bf0c
|
||||
SHA1 (patch-lib_perfdata_influxdbwriter.cpp) = 47df0dc5949e3812beb4d0d5168bc126f15d953c
|
||||
SHA1 (patch-lib_remote_configfileshandler.cpp) = 0b8ae9509a99df500502f163201bf0d1aeb8282d
|
||||
SHA1 (patch-lib_remote_httpserverconnection.cpp) = ce67da2feba7e262045478e933c4800d62d5591b
|
||||
SHA1 (patch-lib_remote_httputility.cpp) = 1da86b1be9566b977c7da03e17e206957f1bc0d7
|
||||
SHA1 (patch-lib_remote_infohandler.cpp) = 8f0767ced2be04953cfd6132a865de31da92e89e
|
||||
SHA1 (patch-CMakeLists.txt) = 052745f5725a90bdc1a113352f21eac590a2cb31
|
||||
SHA1 (patch-RELEASE.md) = 94f2651853010185415c653e89ec8f5c96e37fa2
|
||||
SHA1 (patch-doc_21-development.md) = 05afac552f1558a2dbf556d7c707c3d5625fba56
|
||||
SHA1 (patch-lib_base_string.cpp) = 8ee9a1fa7a34355a855df7c29614fab2ff98323e
|
||||
SHA1 (patch-lib_base_string.hpp) = 6e407f77f607a58bd726cebe6468469bc96b030f
|
||||
SHA1 (patch-lib_base_utility.cpp) = 78f269ba2bd3e29d24876c66e56e36267baed346
|
||||
SHA1 (patch-lib_perfdata_elasticsearchwriter.cpp) = b0a71a92be7c150088148cf4b3f33d9969027ca7
|
||||
SHA1 (patch-lib_perfdata_influxdbwriter.cpp) = c47de3528b648fbb53dd4d1b81a39cfe35e172f9
|
||||
SHA1 (patch-lib_remote_configfileshandler.cpp) = 34cc8f1a6b127a98efcf6ee7835367998ea202a0
|
||||
SHA1 (patch-lib_remote_httpserverconnection.cpp) = 6aa6a7a7dd8fce3f54c8a7b6496286074a4fc434
|
||||
SHA1 (patch-lib_remote_httputility.cpp) = a04578f7c9f2abdd9f9ed27bcd8cdc8a0cf3dd85
|
||||
SHA1 (patch-lib_remote_infohandler.cpp) = 2a91f1d38cad0234bbc5f8b6b2032baac71db91e
|
||||
SHA1 (patch-third-party_cmake_FindMySQL.cmake) = a33567c30db47c4fab379f1b7c358174dd85fdd3
|
||||
|
|
|
@ -1,12 +1,32 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: patch-CMakeLists.txt,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Define BOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT
|
||||
|
||||
Upstream Issue #8185, Pull Request #8192, commit 34942a35112438a91ef25ffa5f0c6c18f1999303
|
||||
|
||||
--- CMakeLists.txt.orig
|
||||
+++ CMakeLists.txt
|
||||
@@ -172,6 +172,9 @@ add_definitions(-DBOOST_COROUTINES_NO_DEPRECATION_WARNING)
|
||||
Rename VERSION to ICINGA2_VERSION to avoid name clashes on case-insensitive file systems.
|
||||
Upstream Pull Request #8596
|
||||
|
||||
--- CMakeLists.txt.orig 2020-12-15 12:30:19.000000000 +0100
|
||||
+++ CMakeLists.txt 2021-01-15 16:06:03.000000000 +0100
|
||||
@@ -89,7 +89,7 @@
|
||||
set(ICINGA2_LICENSE "${ICINGA2_LICENSE_GPL}\n\n---\n\n${ICINGA2_LICENSE_ADDITIONS}")
|
||||
file(WRITE "${CMAKE_CURRENT_BINARY_DIR}/LICENSE.txt" ${ICINGA2_LICENSE})
|
||||
|
||||
-file(STRINGS VERSION SPEC_VERSION REGEX "^Version:")
|
||||
+file(STRINGS ICINGA2_VERSION SPEC_VERSION REGEX "^Version:")
|
||||
string(LENGTH "${SPEC_VERSION}" SPEC_VERSION_LENGTH)
|
||||
math(EXPR SPEC_VERSION_LENGTH "${SPEC_VERSION_LENGTH} - 9")
|
||||
string(SUBSTRING ${SPEC_VERSION} 9 ${SPEC_VERSION_LENGTH} SPEC_VERSION)
|
||||
@@ -102,7 +102,7 @@
|
||||
configure_file(icinga-version.h.force ${CMAKE_CURRENT_BINARY_DIR}/icinga-version.h COPYONLY)
|
||||
else()
|
||||
if(NOT ICINGA2_GIT_VERSION_INFO OR GIT_VERSION MATCHES "-NOTFOUND$")
|
||||
- file(STRINGS VERSION SPEC_REVISION REGEX "^Revision: ")
|
||||
+ file(STRINGS ICINGA2_VERSION SPEC_REVISION REGEX "^Revision: ")
|
||||
string(LENGTH "${SPEC_REVISION}" SPEC_REVISION_LENGTH)
|
||||
math(EXPR SPEC_REVISION_LENGTH "${SPEC_REVISION_LENGTH} - 10")
|
||||
string(SUBSTRING ${SPEC_REVISION} 10 ${SPEC_REVISION_LENGTH} SPEC_REVISION)
|
||||
@@ -172,6 +172,9 @@
|
||||
|
||||
add_definitions(-DBOOST_FILESYSTEM_NO_DEPRECATED)
|
||||
|
||||
|
@ -16,3 +36,10 @@ Upstream Issue #8185, Pull Request #8192, commit 34942a35112438a91ef25ffa5f0c6c1
|
|||
link_directories(${Boost_LIBRARY_DIRS})
|
||||
include_directories(${Boost_INCLUDE_DIRS})
|
||||
|
||||
@@ -520,4 +523,4 @@
|
||||
)
|
||||
endif()
|
||||
|
||||
-include(CPack)
|
||||
\ No newline at end of file
|
||||
+include(CPack)
|
||||
|
|
16
net/icinga2/patches/patch-RELEASE.md
Normal file
16
net/icinga2/patches/patch-RELEASE.md
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-RELEASE.md,v 1.1 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Rename VERSION to ICINGA2_VERSION to avoid name clashes on case-insensitive file systems.
|
||||
Upstream Pull Request #8596
|
||||
|
||||
--- RELEASE.md.orig 2020-12-15 12:30:19.000000000 +0100
|
||||
+++ RELEASE.md 2021-01-15 16:08:14.000000000 +0100
|
||||
@@ -64,7 +64,7 @@
|
||||
Update the version:
|
||||
|
||||
```
|
||||
-sed -i "s/Version: .*/Version: $VERSION/g" VERSION
|
||||
+sed -i "s/Version: .*/Version: $VERSION/g" ICINGA2_VERSION
|
||||
```
|
||||
|
||||
## Changelog <a id="changelog"></a>
|
16
net/icinga2/patches/patch-doc_21-development.md
Normal file
16
net/icinga2/patches/patch-doc_21-development.md
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-doc_21-development.md,v 1.1 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Rename VERSION to ICINGA2_VERSION to avoid name clashes on case-insensitive file systems.
|
||||
Upstream Pull Request #8596
|
||||
|
||||
--- doc/21-development.md.orig 2020-12-15 12:30:19.000000000 +0100
|
||||
+++ doc/21-development.md 2021-01-15 16:09:28.000000000 +0100
|
||||
@@ -2305,7 +2305,7 @@
|
||||
|
||||
CMake determines the Icinga 2 version number using `git describe` if the
|
||||
source directory is contained in a Git repository. Otherwise the version number
|
||||
-is extracted from the [VERSION](VERSION) file. This behavior can be
|
||||
+is extracted from the [ICINGA2_VERSION](ICINGA2_VERSION) file. This behavior can be
|
||||
overridden by creating a file called `icinga-version.h.force` in the source
|
||||
directory. Alternatively the `-DICINGA2_GIT_VERSION_INFO=OFF` option for CMake
|
||||
can be used to disable the usage of `git describe`.
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: patch-lib_base_string.cpp,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: patch-lib_base_string.cpp,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Support Boost 1.74 when setting HTTP headers
|
||||
|
||||
Upstream Issue #8185, Pull Request #8575, commit eab07a7318f9e42157bc21d86585340d762759e7
|
||||
|
||||
--- lib/base/string.cpp.orig
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: patch-lib_base_string.hpp,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: patch-lib_base_string.hpp,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Support Boost 1.74 when setting HTTP headers
|
||||
|
||||
Upstream Issue #8185, Pull Request #8575, commit eab07a7318f9e42157bc21d86585340d762759e7
|
||||
|
||||
--- lib/base/string.hpp.orig
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: patch-lib_base_utility.cpp,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: patch-lib_base_utility.cpp,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Fix 'fs::copy_option' has not been declared with boost 1.74.0
|
||||
|
||||
Upstream Issue #8185, Pull Request #8184, commit c30bae2994f1e5f33f6da51eb96d423e9bf0f75c
|
||||
|
||||
--- lib/base/utility.cpp.orig
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: patch-lib_perfdata_elasticsearchwriter.cpp,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: patch-lib_perfdata_elasticsearchwriter.cpp,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Support Boost 1.74 when setting HTTP headers
|
||||
|
||||
Upstream Issue #8185, Pull Request #8575, commit 339b37a985b5f67ce5f0d2e02211d2c5b98a5d45
|
||||
|
||||
--- lib/perfdata/elasticsearchwriter.cpp.orig
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: patch-lib_perfdata_influxdbwriter.cpp,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: patch-lib_perfdata_influxdbwriter.cpp,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Support Boost 1.74 when setting HTTP headers
|
||||
|
||||
Upstream Issue #8185, Pull Request #8575, commit 339b37a985b5f67ce5f0d2e02211d2c5b98a5d45
|
||||
|
||||
--- lib/perfdata/influxdbwriter.cpp.orig 2020-08-03 15:43:47.000000000 +0200
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: patch-lib_remote_configfileshandler.cpp,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: patch-lib_remote_configfileshandler.cpp,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Support Boost 1.74 when setting HTTP headers
|
||||
|
||||
Upstream Issue #8185, Pull Request #8575, commit 339b37a985b5f67ce5f0d2e02211d2c5b98a5d45
|
||||
|
||||
--- lib/remote/configfileshandler.cpp.orig
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: patch-lib_remote_httpserverconnection.cpp,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: patch-lib_remote_httpserverconnection.cpp,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Support Boost 1.74 when setting HTTP headers
|
||||
|
||||
Upstream Issue #8185, Pull Request #8575, commit 339b37a985b5f67ce5f0d2e02211d2c5b98a5d45
|
||||
|
||||
--- lib/remote/httpserverconnection.cpp.orig 2020-08-03 15:43:47.000000000 +0200
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: patch-lib_remote_httputility.cpp,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: patch-lib_remote_httputility.cpp,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Support Boost 1.74 when setting HTTP headers
|
||||
|
||||
Upstream Issue #8185, Pull Request #8575, commit 339b37a985b5f67ce5f0d2e02211d2c5b98a5d45
|
||||
|
||||
--- lib/remote/httputility.cpp.orig
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: patch-lib_remote_infohandler.cpp,v 1.1 2021/01/15 00:37:17 wiz Exp $
|
||||
$NetBSD: patch-lib_remote_infohandler.cpp,v 1.2 2021/01/17 13:22:26 wiz Exp $
|
||||
|
||||
Support Boost 1.74 when setting HTTP headers
|
||||
|
||||
Upstream Issue #8185, Pull Request #8575, commit 339b37a985b5f67ce5f0d2e02211d2c5b98a5d45
|
||||
|
||||
--- lib/remote/infohandler.cpp.orig
|
||||
|
|
Loading…
Reference in a new issue