Works fine with system curses

This commit is contained in:
roy 2013-10-17 16:36:07 +00:00
parent e02e624947
commit 771528f246
5 changed files with 24 additions and 9 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.4 2012/10/06 11:54:35 asau Exp $
# $NetBSD: Makefile,v 1.5 2013/10/17 16:36:07 roy Exp $
#
DISTNAME= dungeon-3.2b
PKGREVISION= 1
DISTFILES= dungeon-gdt-glk.tar.gz \
glkterm-080.tar.gz
CATEGORIES= games
@ -48,5 +49,5 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dungeon-gdt/dungeon ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/dungeon-gdt/dundat ${DESTDIR}${DATADIR}/
.include "../../devel/ncurses/buildlink3.mk"
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2012/05/23 05:38:41 dholland Exp $
$NetBSD: distinfo,v 1.6 2013/10/17 16:36:07 roy Exp $
SHA1 (dungeon-gdt-glk.tar.gz) = ec148735ae713566c9511057473fbd899d673a6a
RMD160 (dungeon-gdt-glk.tar.gz) = aed6e4a42c03be0a9bce2248dcab3370e1b1fbde
@ -9,5 +9,6 @@ Size (glkterm-080.tar.gz) = 91260 bytes
SHA1 (patch-aa) = 172cc658c3ec2f188448659708e2047d01e426e0
SHA1 (patch-ab) = 05ddacb4213b23e2cbee576d7ac5074700b6a895
SHA1 (patch-ac) = a44574841a5c344de484053daea0394845534ef8
SHA1 (patch-dungeon-gdt_Makefile) = 4c70ed563b652d0c0aa2335e201af9e0c1678d8e
SHA1 (patch-glkterm_gtfref_c) = b9fd31e554710475f65d00bf0c6ab1f541fa2d21
SHA1 (patch-dungeon-gdt_Makefile) = 77337d3f5cad8748f4977304418e81c01f61e606
SHA1 (patch-glkterm_Makefile) = ff09354647a746e00953fb59d9e15f3813563f7a
SHA1 (patch-glkterm_gtfref_c) = 9b0df59fbde4bf49dc87508d8ecf8fdc850100ed

View file

@ -1,8 +1,8 @@
$NetBSD: patch-dungeon-gdt_Makefile,v 1.1 2012/05/23 05:38:41 dholland Exp $
$NetBSD: patch-dungeon-gdt_Makefile,v 1.2 2013/10/17 16:36:07 roy Exp $
Honor pkgsrc's LDFLAGS.
--- dungeon-gdt/Makefile~ 2009-11-25 19:44:23.000000000 +0000
--- dungeon-gdt/Makefile.orig 2009-11-25 19:44:23.000000000 +0000
+++ dungeon-gdt/Makefile
@@ -45,7 +45,7 @@ OBJS += glkstart.o
CFLAGS += -DPATH_DUNDAT=\"${DATADIR}/\" -DUSE_OS_RANDOM $(GDT_FLAG)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-glkterm_Makefile,v 1.1 2013/10/17 16:36:07 roy Exp $
--- glkterm/Makefile.orig 2013-10-17 16:31:53.000000000 +0000
+++ glkterm/Makefile
@@ -15,7 +15,7 @@ CC = gcc -ansi
# You may need to set directories to pick up the ncurses library.
#INCLUDEDIRS = -I/usr/5include
#LIBDIRS = -L/usr/5lib
-LIBS = -lncurses
+LIBS = -lcurses
OPTIONS = -O

View file

@ -1,8 +1,8 @@
$NetBSD: patch-glkterm_gtfref_c,v 1.1 2012/05/23 05:38:41 dholland Exp $
$NetBSD: patch-glkterm_gtfref_c,v 1.2 2013/10/17 16:36:07 roy Exp $
Patch out insecure temporary file code that appears to be unreachable.
--- glkterm/gtfref.c~ 2008-03-16 01:07:17.000000000 +0000
--- glkterm/gtfref.c.orig 2008-03-16 01:07:17.000000000 +0000
+++ glkterm/gtfref.c
@@ -99,7 +99,8 @@ frefid_t glk_fileref_create_temp(glui32
{