Fix build on DragonFly.
This commit is contained in:
parent
3b6a7d65a4
commit
7747ba1cc0
2 changed files with 14 additions and 10 deletions
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.3 2005/02/24 12:13:47 agc Exp $
|
||||
$NetBSD: distinfo,v 1.4 2006/05/29 14:06:27 joerg Exp $
|
||||
|
||||
SHA1 (gkrellm-multiping-2.0.8.tgz) = 88de3cda0e55ba33ed5c0d0c2d0aaa2c56ebf69d
|
||||
RMD160 (gkrellm-multiping-2.0.8.tgz) = 6d8d9d4b2379a48f15c1b654efd3149320a6b8a1
|
||||
Size (gkrellm-multiping-2.0.8.tgz) = 14377 bytes
|
||||
SHA1 (patch-aa) = a4da915eccae50d254deb8c67d1c398df6189662
|
||||
SHA1 (patch-ab) = 465567eb777db1d144d23e7fc457fb63db8ff23c
|
||||
SHA1 (patch-ac) = 4151e6d76665d33293038832c9cba4c4f56b3a56
|
||||
SHA1 (patch-ac) = d8979ef7d975ec19c71a72bfc9e19e6c82a16a83
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2004/02/24 23:41:56 cube Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2006/05/29 14:06:27 joerg Exp $
|
||||
|
||||
--- pinger.c.orig 2003-01-22 17:12:53.000000000 +0100
|
||||
--- pinger.c.orig 2004-01-16 07:48:09.000000000 +0000
|
||||
+++ pinger.c
|
||||
@@ -27,6 +27,7 @@ ________________________________________
|
||||
#include <sys/signal.h>
|
||||
|
@ -10,7 +10,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2004/02/24 23:41:56 cube Exp $
|
|||
#include <netinet/ip.h>
|
||||
#include <netinet/ip_icmp.h>
|
||||
#include <arpa/inet.h>
|
||||
@@ -220,42 +221,44 @@ static gchar *pr_icmph(struct icmp *icp)
|
||||
@@ -239,42 +240,48 @@ static gchar *pr_icmph(struct icmp *icp)
|
||||
g_string_assign(s, "Echo Reply");
|
||||
/* XXX ID + Seq + Data */
|
||||
break;
|
||||
|
@ -62,12 +62,16 @@ $NetBSD: patch-ac,v 1.1.1.1 2004/02/24 23:41:56 cube Exp $
|
|||
+ case ICMP_UNREACH_TOSHOST:
|
||||
g_string_assign(s, "Destination Host Unreachable At This TOS");
|
||||
break;
|
||||
+#if defined(__DragonFly__)
|
||||
+ case ICMP_UNREACH_FILTER_PROHIB:
|
||||
+#else
|
||||
+ case ICMP_UNREACH_ADMIN_PROHIBIT:
|
||||
+#endif
|
||||
+ g_string_assign(s, "Packet Prohibited");
|
||||
#ifdef ICMP_PKT_FILTERED
|
||||
case ICMP_PKT_FILTERED:
|
||||
g_string_assign(s, "Packet Filtered");
|
||||
@@ -277,21 +280,21 @@ static gchar *pr_icmph(struct icmp *icp)
|
||||
@@ -296,21 +303,21 @@ static gchar *pr_icmph(struct icmp *icp)
|
||||
break;
|
||||
}
|
||||
break;
|
||||
|
@ -94,7 +98,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2004/02/24 23:41:56 cube Exp $
|
|||
g_string_assign(s, "Redirect Type of Service and Host");
|
||||
break;
|
||||
default:
|
||||
@@ -305,12 +308,12 @@ static gchar *pr_icmph(struct icmp *icp)
|
||||
@@ -324,12 +331,12 @@ static gchar *pr_icmph(struct icmp *icp)
|
||||
g_string_assign(s, "Echo Request");
|
||||
/* XXX ID + Seq + Data */
|
||||
break;
|
||||
|
@ -110,7 +114,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2004/02/24 23:41:56 cube Exp $
|
|||
g_string_assign(s, "Frag reassembly time exceeded");
|
||||
break;
|
||||
default:
|
||||
@@ -319,23 +322,23 @@ static gchar *pr_icmph(struct icmp *icp)
|
||||
@@ -338,23 +345,23 @@ static gchar *pr_icmph(struct icmp *icp)
|
||||
break;
|
||||
}
|
||||
break;
|
||||
|
@ -139,7 +143,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2004/02/24 23:41:56 cube Exp $
|
|||
g_string_assign(s, "Information Reply");
|
||||
/* XXX ID + Seq */
|
||||
break;
|
||||
@@ -430,11 +433,11 @@ void pr_pack(char *buf, int cc, struct s
|
||||
@@ -448,11 +455,11 @@ void pr_pack(char *buf, int cc, struct s
|
||||
switch (icp->icmp_type) {
|
||||
case ICMP_ECHO:
|
||||
return;
|
||||
|
@ -155,7 +159,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2004/02/24 23:41:56 cube Exp $
|
|||
{
|
||||
struct ip *iph = (struct ip *) (&icp->icmp_data);
|
||||
struct icmp *icp1 =
|
||||
@@ -447,7 +450,7 @@ void pr_pack(char *buf, int cc, struct s
|
||||
@@ -465,7 +472,7 @@ void pr_pack(char *buf, int cc, struct s
|
||||
icp1->icmp_id != ident)
|
||||
return;
|
||||
error_pkt = (icp->icmp_type != ICMP_REDIRECT &&
|
||||
|
|
Loading…
Reference in a new issue